X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How can I disable the shift-enter function that opens whatever I've typed into the address bar in a new window?

  • 1 reply
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

Recently I've found that hitting "enter" after typing something into the address bar in Firefox causes it (search results, whatever) to open in a new window. I'm a fast typist but also a bit sloppy, and what's happening is that I'm hitting enter while my finger is still on the "shift" key. It's incredibly frustrating, and also seems to be a relatively new development: I've been using Firefox for years and don't recall ever encountering this until very recently. I will never, ever actually want to use this particular shortcut in my life, EVER, so what can I do to disable it?

I also recently had to install an add-on to disable the detach-and-tear option for tabs, which is something else (accidentally moving tabs to new windows when clicking on them) that only became a problem for me very recently. That has apparently been a problem for other people for quite some time, though, so maybe I had a long-ago-installed extension that prevented it, that was disabled post-FF56? Whatever the case, Firefox performance has dramatically improved with the new version, but frustrations like these continue to crop up.

Recently I've found that hitting "enter" after typing something into the address bar in Firefox causes it (search results, whatever) to open in a new window. I'm a fast typist but also a bit sloppy, and what's happening is that I'm hitting enter while my finger is still on the "shift" key. It's incredibly frustrating, and also seems to be a relatively new development: I've been using Firefox for years and don't recall ever encountering this until very recently. I will never, ever actually want to use this particular shortcut in my life, EVER, so what can I do to disable it? I also recently had to install an add-on to disable the detach-and-tear option for tabs, which is something else (accidentally moving tabs to new windows when clicking on them) that only became a problem for me very recently. That has apparently been a problem for other people for quite some time, though, so maybe I had a long-ago-installed extension that prevented it, that was disabled post-FF56? Whatever the case, Firefox performance has dramatically improved with the new version, but frustrations like these continue to crop up.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

கூடுதல் தகவல்

cor-el
  • Top 10 Contributor
  • Moderator
17419 தீர்வுகள் 157383 பதில்கள்
பதிவிடப்பட்டது

Hi.

I'm not aware of a way to disable the Shift action on the location/address bar. There is a pref (browser.urlbar.ctrlCanonizesURLs) to disable the Ctlr key for fixing up up the URL, but there isn't a pref to disable the Shift key, so you will have to be more cautious when the press the Enter key. You can drag the tab from the new window back to the Tab bar (free space or plus button) in the original window.

Hi. I'm not aware of a way to disable the Shift action on the location/address bar. There is a pref (browser.urlbar.ctrlCanonizesURLs) to disable the Ctlr key for fixing up up the URL, but there isn't a pref to disable the Shift key, so you will have to be more cautious when the press the Enter key. You can drag the tab from the new window back to the Tab bar (free space or plus button) in the original window.