X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Cannot install add-ons because of connection error

  • 29 replies
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

No add-ons coming from https://addons.mozilla.org/en-US/firefox/ can be installed in my Mac, all because of a single issue ("Download failed. Please check your connection."). I've noticed that images in this site cannot load properly as well. I checked the console and it seems that the GET request was responded with 404. Install requests sent to other websites seem to be working. I successfully installed zotero from its website and some other add-ons via downloaded .xpi files. However, some .xpi's cannot be installed directly either. I got a message saying this add-on appears to be corrupt.

I duckduckwent this issue and tried all the following solutions (though none has helped): 1. Added "xpinstall.enabled => true" and "xpinstall.signatures.required => false" in about:config; 2. Downloaded the .xpi file directly using other browsers, but when I tried to add it manually, I got the message saying this add-on is corrupt. 3. I tried InstallTrigger.install({URL: "https://addons.mozilla.org/firefox/downloads/file/1168281/adblock_plus-3.4.2-an+fx.xpi?src=search"}) in the console and still got the connection error. I clicked on several install links in add-ons websites and they came back with 404. I think these links were redirecting me to addons.mozilla.org.

I don't have any antivirus software in my Mac, at least not that I know of. I enabled "allow site to install add-ons" and "allow pop-ups", etc.

No add-ons coming from https://addons.mozilla.org/en-US/firefox/ can be installed in my Mac, all because of a single issue ("Download failed. Please check your connection."). I've noticed that images in this site cannot load properly as well. I checked the console and it seems that the GET request was responded with 404. Install requests sent to other websites seem to be working. I successfully installed zotero from its website and some other add-ons via downloaded .xpi files. However, some .xpi's cannot be installed directly either. I got a message saying this add-on appears to be corrupt. I duckduckwent this issue and tried all the following solutions (though none has helped): 1. Added "xpinstall.enabled => true" and "xpinstall.signatures.required => false" in about:config; 2. Downloaded the .xpi file directly using other browsers, but when I tried to add it manually, I got the message saying this add-on is corrupt. 3. I tried InstallTrigger.install({URL: "https://addons.mozilla.org/firefox/downloads/file/1168281/adblock_plus-3.4.2-an+fx.xpi?src=search"}) in the console and still got the connection error. I clicked on several install links in add-ons websites and they came back with 404. I think these links were redirecting me to addons.mozilla.org. I don't have any antivirus software in my Mac, at least not that I know of. I enabled "allow site to install add-ons" and "allow pop-ups", etc.
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

yc_cxy said

jscher2000 said
I wonder why you do not get that redirect? Are you using a proxy of any kind?

It rings a bell – I do have "Cisco AnyConnect Secure Mobility Client" installed but use its VPN service only very infrequently to the extent that I forget I have this application in my Mac in the first place.

That is the only proxy I use as far as I know but it's closed for the most part. Could it be possibly the cause?

Hmm, does it make any difference if you use it?

Probably your connection setting is the default, but you can check here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

I believe the default is "Use system proxy settings", which piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. I'm not sure "No proxy" would be compatible with your Cisco VPN client, but you could test whether it makes any difference.

Anything odd here?

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 32.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:64.0) Gecko/20100101 Firefox/64.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Issuer value field:

CN = DigiCert SHA2 High Assurance Server CA OU = www.digicert.com O = DigiCert Inc C = US

Issuer value field: CN = DigiCert SHA2 High Assurance Server CA OU = www.digicert.com O = DigiCert Inc C = US
cor-el
  • Top 10 Contributor
  • Moderator
17566 தீர்வுகள் 158879 பதில்கள்
பதிவிடப்பட்டது

Try to rename the cert9.db (cert9OLD.db) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename the cert9.db (cert9OLD.db) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached. *https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

Try to rename the cert9.db (cert9OLD.db) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached. If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

This does not help solve the issue. It seems that even if I delete the cert9.db file altogether with firefox closed, a new cert9.db file is automatically created once I open firefox to test the result.

The expired certificate issue is still denying any access to addons.cdn.mozilla.net or related address. As I tried directly accessing addons.cdn.mozilla.net, the web went back as 404 (see screenshot attached).

''cor-el [[#answer-1226674|said]]'' <blockquote> Try to rename the cert9.db (cert9OLD.db) file and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached. If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db. </blockquote> This does not help solve the issue. It seems that even if I delete the cert9.db file altogether with firefox closed, a new cert9.db file is automatically created once I open firefox to test the result. The expired certificate issue is still denying any access to addons.cdn.mozilla.net or related address. As I tried directly accessing addons.cdn.mozilla.net, the web went back as 404 (see screenshot attached).
jscher2000
  • Top 10 Contributor
8783 தீர்வுகள் 71823 பதில்கள்
பதிவிடப்பட்டது

yc_cxy said

As I tried directly accessing addons.cdn.mozilla.net, the web went back as 404 (see screenshot attached).

Hmm, if I try

http://addons.cdn.mozilla.net/

I get a 301 (Permanently Moved) redirect to

https://static.addons.mozilla.net/

which yields a 403 (Forbidden) error.

I wonder why you do not get that redirect? Are you using a proxy of any kind?

''yc_cxy [[#answer-1226759|said]]'' <blockquote> As I tried directly accessing addons.cdn.mozilla.net, the web went back as 404 (see screenshot attached). </blockquote> Hmm, if I try http://addons.cdn.mozilla.net/ I get a 301 (Permanently Moved) redirect to https://static.addons.mozilla.net/ which yields a 403 (Forbidden) error. I wonder why you do not get that redirect? Are you using a proxy of any kind?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

jscher2000 said

I wonder why you do not get that redirect? Are you using a proxy of any kind?

It rings a bell – I do have "Cisco AnyConnect Secure Mobility Client" installed but use its VPN service only very infrequently to the extent that I forget I have this application in my Mac in the first place.

That is the only proxy I use as far as I know but it's closed for the most part. Could it possibly be the cause?

''jscher2000 [[#answer-1226760|said]]'' <blockquote> I wonder why you do not get that redirect? Are you using a proxy of any kind? </blockquote> It rings a bell – I do have "Cisco AnyConnect Secure Mobility Client" installed but use its VPN service only very infrequently to the extent that I forget I have this application in my Mac in the first place. That is the only proxy I use as far as I know but it's closed for the most part. Could it possibly be the cause?

yc_cxy மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8783 தீர்வுகள் 71823 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

yc_cxy said

jscher2000 said
I wonder why you do not get that redirect? Are you using a proxy of any kind?

It rings a bell – I do have "Cisco AnyConnect Secure Mobility Client" installed but use its VPN service only very infrequently to the extent that I forget I have this application in my Mac in the first place.

That is the only proxy I use as far as I know but it's closed for the most part. Could it be possibly the cause?

Hmm, does it make any difference if you use it?

Probably your connection setting is the default, but you can check here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

I believe the default is "Use system proxy settings", which piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. I'm not sure "No proxy" would be compatible with your Cisco VPN client, but you could test whether it makes any difference.

Anything odd here?

''yc_cxy [[#answer-1226762|said]]'' <blockquote> ''jscher2000 [[#answer-1226760|said]]'' <blockquote> I wonder why you do not get that redirect? Are you using a proxy of any kind? </blockquote> It rings a bell – I do have "Cisco AnyConnect Secure Mobility Client" installed but use its VPN service only very infrequently to the extent that I forget I have this application in my Mac in the first place. That is the only proxy I use as far as I know but it's closed for the most part. Could it be possibly the cause? </blockquote> Hmm, does it make any difference if you use it? Probably your connection setting is the default, but you can check here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. I believe the default is "Use system proxy settings", which piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. I'm not sure "No proxy" would be compatible with your Cisco VPN client, but you could test whether it makes any difference. Anything odd here?
பதிவிடப்பட்டது

உதவிகரமான பதில்

jscher2000 said

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click. I believe the default is "Use system proxy settings", which piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. I'm not sure "No proxy" would be compatible with your Cisco VPN client, but you could test whether it makes any difference. Anything odd here?

OMG it worked! I experimented with the proxy menu with and without VPN. After I turned on the "enable DNS over HTTPS" option (see screen shot attached), things started to work!!!!

I can finally install add-ons in firefox!! Thank you so much!

''jscher2000 [[#answer-1226763|said]]'' <blockquote> In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. I believe the default is "Use system proxy settings", which piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. I'm not sure "No proxy" would be compatible with your Cisco VPN client, but you could test whether it makes any difference. Anything odd here? </blockquote> OMG it worked! I experimented with the proxy menu with and without VPN. After I turned on the "enable DNS over HTTPS" option (see screen shot attached), things started to work!!!! I can finally install add-ons in firefox!! Thank you so much!

yc_cxy மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17566 தீர்வுகள் 158879 பதில்கள்
பதிவிடப்பட்டது

Do you see this intermediate certificate listed in the Certificate Manager?

  • DigiCert SHA2 High Assurance Server CA
  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates -> Authorities
Do you see this intermediate certificate listed in the Certificate Manager? *DigiCert SHA2 High Assurance Server CA *Options/Preferences -> Privacy & Security<br>Certificates: View Certificates -> Authorities
jscher2000
  • Top 10 Contributor
8783 தீர்வுகள் 71823 பதில்கள்
பதிவிடப்பட்டது

yc_cxy said

OMG it worked! I experimented with the proxy menu with and without VPN. After I turned on the "enable DNS over HTTPS" option (see screen shot attached), things started to work!!!!

Hmm, I wonder what is going on with your regular DNS provider!!

''yc_cxy [[#answer-1226767|said]]'' <blockquote> OMG it worked! I experimented with the proxy menu with and without VPN. After I turned on the "enable DNS over HTTPS" option (see screen shot attached), things started to work!!!! </blockquote> Hmm, I wonder what is going on with your regular DNS provider!!