Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error opening a website

  • 5 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 64 views
  • Last reply by jscher2000

When we open our website blog on Firefox Quantum, we get following error. Strange thing is it is talking about Opera browser not firefox

Error 400

We're sorry, but we could not fulfill your request for /eco-blog/ on this server.

An invalid request was received. If you are using a proxy server, bypass the proxy server or contact your proxy server administrator. This may also be caused by a bug in the Opera web browser.

Your technical support key is: 70c4-07fa-582e-c5e4

You can use this key to fix this problem yourself.

If you are unable to fix the problem yourself, please contact ** at **.com and be sure to provide the technical support key shown above.

All Replies (5)

Web search: https://www.bing.com/search?q=Error%20400

Looks like something is wrong either with the request the computer is sending, or the servers don't understand it.

Please provide a public link (no password) that we can check out. No Personal Information Please !

FredMcD மூலமாக திருத்தப்பட்டது

I had no problem with the link from United States east coast. Where are you? Are you using a proxy?

We are trying it from Delray beach US and India, but we are getting same error. We are not using any proxy.

Thanks for the URL. I tested in Firefox 64.0, and I got the 400 response. The console shows these response headers:

HTTP/2.0 400 Bad Request
content-type: text/html; charset=UTF-8
server: nginx
date: Tue, 18 Dec 2018 16:46:45 GMT
x-powered-by: PHP/5.6.39
x-cache: Error from cloudfront
via: 1.1 06ea20ff21ab652336f17ada0744f860.cloudfront.net (CloudFront)
x-amz-cf-id: x0msohcVRDGMMd01zGH3uGYpxL2FzwCUlSmKZCNoWCbevdNxUvl-dQ==
X-Firefox-Spdy: h2

The site will load if I disable Firefox from using HTTP/2, which you could try as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste http2 and pause while the list is filtered

(3) Double-click the network.http.spdy.enabled.http2 preference to switch the value from true to false

That gave me a successful retrieval:

HTTP/1.1 200 OK
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Server: nginx
Date: Tue, 18 Dec 2018 16:53:23 GMT
Vary: Accept-Encoding
X-Powered-By: PHP/5.6.39
Set-Cookie: PHPSESSID=edee2405a3b1e337eaaefa119e91ee26; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Link: <https://www.customearthpromos.com/eco-blog/wp-json/>; rel="https://api.w.org/"
Content-Encoding: gzip
X-Cache: Miss from cloudfront
Via: 1.1 628a240f95efaa5a233539a357803160.cloudfront.net (CloudFront)
X-Amz-Cf-Id: YP6w4u1EiAyds-uNdM7KgDjCIkfcXHPa6Mjw4_OrJqElkAdk0HJH-A==

Can you report that problem to the host and see whether there is a workaround? If HTTP/2 doesn't work with the server or the CloudFront service, there probably is a way to send Firefox a code instructing it to fall back to using HTTP/1.1 without ending up stuck on a 400 page.