X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Settings don't exist in FF 64 for "Allow or block media autoplay in Firefox"

  • 6 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by ronks
பதிவிடப்பட்டது

On a Mozilla How-To page (https://support.mozilla.org/en-US/kb/block-autoplay), instructions are given for going to Permissions under Privacy and Security to easily select to allow or not allow autoplay of videos.

But on FF 64, that feature simply doesn't exist! (See uploaded image compared to image on the above linked Mozilla help page.)

I'm seeing a couple somewhat recent discussions about stopping autoplay in Yahoo, but it's a bit above my head, as there are configurations talked about that I don't know how to start doing.

Also, it's unclear to me in those discussions if Mozilla intentionally got rid of this easy-to-do setting, and if so why, and if it plans to bring it back or what.

In the meantime, what exactly do I do to stop autoplay of videos?

On a Mozilla How-To page (https://support.mozilla.org/en-US/kb/block-autoplay), instructions are given for going to Permissions under Privacy and Security to easily select to allow or not allow autoplay of videos. But on FF 64, that feature simply doesn't exist! (See uploaded image compared to image on the above linked Mozilla help page.) I'm seeing a couple somewhat recent discussions about stopping autoplay in Yahoo, but it's a bit above my head, as there are configurations talked about that I don't know how to start doing. Also, it's unclear to me in those discussions if Mozilla intentionally got rid of this easy-to-do setting, and if so why, and if it plans to bring it back or what. In the meantime, what exactly do I do to stop autoplay of videos?
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

seacleer said

But on FF 64, that feature simply doesn't exist! (See uploaded image compared to image on the above linked Mozilla help page.)

Hello seacleer,

That article starts with :

"This feature is planned for a future Firefox release. " ......

It's being tested in studies and in Nightly (pre-release) versions of Firefox

In the meantime, what exactly do I do to stop autoplay of videos?

Would you check this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.autoplay.

and check these settings :

media.autoplay.enabled.user-gestures-needed = true

media.autoplay.ask-permission = true

media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt]

media.autoplay.allow-muted = false

If you have to change anything, then close and restart Firefox.

Read this answer in context 1

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0

கூடுதல் தகவல்

McCoy
  • Top 10 Contributor
545 தீர்வுகள் 5143 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

seacleer said

But on FF 64, that feature simply doesn't exist! (See uploaded image compared to image on the above linked Mozilla help page.)

Hello seacleer,

That article starts with :

"This feature is planned for a future Firefox release. " ......

It's being tested in studies and in Nightly (pre-release) versions of Firefox

In the meantime, what exactly do I do to stop autoplay of videos?

Would you check this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.autoplay.

and check these settings :

media.autoplay.enabled.user-gestures-needed = true

media.autoplay.ask-permission = true

media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt]

media.autoplay.allow-muted = false

If you have to change anything, then close and restart Firefox.

''seacleer [[#question-1244003|said]]'' <blockquote> But on FF 64, that feature simply doesn't exist! (See uploaded image compared to image on the above linked Mozilla help page.) </blockquote> Hello seacleer, That article starts with : "''This feature is planned for a future Firefox release. ''" ...... It's being tested in studies and in Nightly (pre-release) versions of Firefox <blockquote> In the meantime, what exactly do I do to stop autoplay of videos? </blockquote> Would you check this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''media.autoplay.''' and check these settings : '''media.autoplay.enabled.user-gestures-needed''' = true '''media.autoplay.ask-permission''' = true '''media.autoplay.default''' = 0 [0=Allowed, 1=Blocked, 2=Prompt] '''media.autoplay.allow-muted''' = false If you have to change anything, then close and restart Firefox.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank you very much!

Thank you very much!
McCoy
  • Top 10 Contributor
545 தீர்வுகள் 5143 பதில்கள்
பதிவிடப்பட்டது

seacleer said

Thank you very much!

My pleasure  !

''seacleer [[#answer-1181723|said]]'' <blockquote> Thank you very much! </blockquote> My pleasure !
theslaw 0 தீர்வுகள் 7 பதில்கள்
பதிவிடப்பட்டது

But, what settings do I use to stop autoplay and to prompt me approve playing.

But, what settings do I use to stop autoplay and to prompt me approve playing.
StevenCee 0 தீர்வுகள் 135 பதில்கள்
பதிவிடப்பட்டது

McCoy said

seacleer said If you have to change anything, then close and restart Firefox.

OK, doesn't it look like all those settings need to be changed? You confused the issue by saying "If you have change anything". If those are the settings, wouldn't you OF COURSE have to change the settings, ALL of the settings?

''McCoy [[#answer-1181721|said]]'' <blockquote> ''seacleer [[#question-1244003|said]]'' If you have to change anything, then close and restart Firefox. </blockquote> OK, doesn't it look like all those settings need to be changed? You confused the issue by saying "If you have change anything". If those are the settings, wouldn't you OF COURSE have to change the settings, ALL of the settings?
ronks 1 தீர்வுகள் 15 பதில்கள்
பதிவிடப்பட்டது

Have tried that, not restarted FF yet, I expect that will resolve my issue too. But I'm puzzled; the first three settings:

> media.autoplay.enabled.user-gestures-needed = true > media.autoplay.ask-permission = true > media.autoplay.default = [2=Prompt]

seem to overlap one another. I'd be interested in a description of each and how they differ.

Have tried that, not restarted FF yet, I expect that will resolve my issue too. But I'm puzzled; the first three settings: > media.autoplay.enabled.user-gestures-needed = true > media.autoplay.ask-permission = true > media.autoplay.default = [2=Prompt] seem to overlap one another. I'd be interested in a description of each and how they differ.