X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Auto fill/complete for URLs has been working differently/wonky since a couple of months ago

  • 2 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by PeteSapai
பதிவிடப்பட்டது

Firefox has changed the way its URL auto fill works a while ago. (At least 3 months ago; I remember stumbling on a reddit post from Sep 16th saying that it should be fixed with v63, which is why I waited to try it out.) It seems to be mostly with redirects, see examples below, but also with new sites: it seems to only auto complete after you visited a new site at least twice. I'm a fairly advanced user, so I'm quite convinced I've checked all possible solutions, like check settings in about:config, do a clean install, etc. Also, this behaviour has changed on both my computers and my new work pc.

I'm fairly certain it used to work like it still does in Pale Moon, which is my preferred method Examples: 1. If you go to steampowered.com you're forwarded to store.steampowered.com. If you now close the tab and type 'ste' PM autofills it to steampowered.com, Fx does not. It does suggest the page, but does not auto complete it (it does, however, autofill 'sto' to store.steampowered.com).

2. The same thing happens for chrome.google.com, which redirects to google.com/chrome

3. ikea.nl forwards to ikea.com/nl/nl/. PM autofills 'ik' to ikea.nl, Fx, again, does not. It _does_ auto fill to ikea.com, which is doubly annoying, because now you have to click 'to ikea.nl' every time.

So, is this change by design? Can and will it be fixed/reverted?

Firefox has changed the way its URL auto fill works a while ago. (At least 3 months ago; I remember stumbling on a reddit post from Sep 16th saying that it should be fixed with v63, which is why I waited to try it out.) It seems to be mostly with redirects, see examples below, but also with new sites: it seems to only auto complete after you visited a new site at least twice. I'm a fairly advanced user, so I'm quite convinced I've checked all possible solutions, like check settings in about:config, do a clean install, etc. Also, this behaviour has changed on both my computers and my new work pc. I'm fairly certain it used to work like it still does in Pale Moon, which is my preferred method Examples: 1. If you go to steampowered.com you're forwarded to store.steampowered.com. If you now close the tab and type 'ste' PM autofills it to steampowered.com, Fx does not. It does suggest the page, but does not auto complete it (it does, however, autofill 'sto' to store.steampowered.com). 2. The same thing happens for chrome.google.com, which redirects to google.com/chrome 3. ikea.nl forwards to ikea.com/nl/nl/. PM autofills 'ik' to ikea.nl, Fx, again, does not. It _does_ auto fill to ikea.com, which is doubly annoying, because now you have to click 'to ikea.nl' every time. So, is this change by design? Can and will it be fixed/reverted?

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Still working like that with 64.0.2

Still working like that with 64.0.2
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

66.0.2, Fx still behaving like this.

66.0.2, Fx still behaving like this.