X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

When I want to look at a statement from my bank or a menu from a restaurant, I'm forced to choose somewhere to save it. No option to just preview.

  • 1 reply
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

I have a Macbook Pro and I don't have this problem when browsing on Safari. Firefox requires that I save documents or pages of websites instead of letting me just look at the page. I tried to upload the screenshot, but the gear is just spinning in the uploaded images box, so I don't know if it will send

I have a Macbook Pro and I don't have this problem when browsing on Safari. Firefox requires that I save documents or pages of websites instead of letting me just look at the page. I tried to upload the screenshot, but the gear is just spinning in the uploaded images box, so I don't know if it will send

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi L17A, bank statements and menus sound like pages that might normally be in PDF format. Could you check your PDF setting on the Preferences page:

View PDF files in Firefox

Please note that you may see both "Preview in Firefox" -- the built-in viewer to read a preview of a PDF in a tab -- and "Use Preview (default)" -- for Apple's stand-alone PDF viewing application. If you are being forced to save files, this setting might be "Save File" rather than either of those.

Was that the the problem?


Sometimes Firefox stops obeying those instructions, which can be caused by corruption in the settings file that stores download handling preferences. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. PDFs should be set back to "Preview in Firefox". Any improvement?


Sometimes an individual site will force PDFs to download rather than letting you view them in a tab. We can help you investigate any remaining site-specific problem, and suggest add-ons to work around them.

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 31.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:63.0) Gecko/20100101 Firefox/63.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8635 தீர்வுகள் 70624 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi L17A, bank statements and menus sound like pages that might normally be in PDF format. Could you check your PDF setting on the Preferences page:

View PDF files in Firefox

Please note that you may see both "Preview in Firefox" -- the built-in viewer to read a preview of a PDF in a tab -- and "Use Preview (default)" -- for Apple's stand-alone PDF viewing application. If you are being forced to save files, this setting might be "Save File" rather than either of those.

Was that the the problem?


Sometimes Firefox stops obeying those instructions, which can be caused by corruption in the settings file that stores download handling preferences. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. PDFs should be set back to "Preview in Firefox". Any improvement?


Sometimes an individual site will force PDFs to download rather than letting you view them in a tab. We can help you investigate any remaining site-specific problem, and suggest add-ons to work around them.

Hi L17A, bank statements and menus sound like pages that might normally be in PDF format. Could you check your PDF setting on the Preferences page: [[View PDF files in Firefox]] Please note that you may see both "Preview in Firefox" -- the built-in viewer to read a preview of a PDF in a tab -- and "Use Preview (default)" -- for Apple's stand-alone PDF viewing application. If you are being forced to save files, this setting might be "Save File" rather than either of those. Was that the the problem? ---- Sometimes Firefox stops obeying those instructions, which can be caused by corruption in the settings file that stores download handling preferences. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit/Quit * (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then rename '''handlers.json''' to something like '''handlersOLD.json'''. If you see a file named '''mimeTypes.rdf''', rename that one to '''mimeTypesOLD.rdf'''. Start Firefox back up again. PDFs should be set back to "Preview in Firefox". Any improvement? ---- ''Sometimes an individual site will force PDFs to download rather than letting you view them in a tab. We can help you investigate any remaining site-specific problem, and suggest add-ons to work around them.''