X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Stop ALL videos autoplaying - not just those with sound

  • 12 replies
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

Previously I had the 'autoplay' option set to false. Now with the update (I'm on 63.0.1, Windows, 64 bit) I have

media.autoplay.default = 1 media.autoplay.ask-permission = true media.autoplay.enabled.user-gestures-needed = true

I want all videos to not play, not just those with sound. How can I stop all videos playing?

Thanks.

Previously I had the 'autoplay' option set to false. Now with the update (I'm on 63.0.1, Windows, 64 bit) I have media.autoplay.default = 1 media.autoplay.ask-permission = true media.autoplay.enabled.user-gestures-needed = true I want all videos to not play, not just those with sound. How can I stop all videos playing? Thanks.

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!!

Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!!
Pj 42 தீர்வுகள் 869 பதில்கள்
பதிவிடப்பட்டது

ChrompSquad said

Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!!

I dunno. Edit it to About:Config and go.

Video Autoplay: See

''ChrompSquad [[#answer-1170729|said]]'' <blockquote> Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!! </blockquote> I dunno. Edit it to '''About:Config''' and go. Video Autoplay: See *https://support.mozilla.org/en-US/questions/1238380#answer-1167225
cor-el
  • Top 10 Contributor
  • Moderator
17574 தீர்வுகள் 158974 பதில்கள்
பதிவிடப்பட்டது

You may have once typed about:config/ with a slash appended.

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

You may have once typed <b>about:config/</b> with a slash appended. You can use these steps to remove saved items from an autocomplete drop-down list. #click the (empty) input field on the web page to open the drop-down list #highlight an entry in the drop-down list with cursor Down key<br>do not click the mouse or press the Enter key #press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry Note that hovering with the mouse no longer works.
cor-el
  • Top 10 Contributor
  • Moderator
17574 தீர்வுகள் 158974 பதில்கள்
பதிவிடப்பட்டது
See also: *Disable HTML5 Autoplay<br>https://addons.mozilla.org/firefox/addon/disable-autoplay/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

You may have once typed about:config/ with a slash appended. You can use these steps to remove saved items from an autocomplete drop-down list.
  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry
Note that hovering with the mouse no longer works.

That's the bizarre thing - "about:config" is in the list, but not "about:config/"

Oh ok, I fixed it - I had saved "about:config" as a bookmark, and Firefox was helpfully putting the "/" on the end. I deleted the bookmark (which did NOT have the "/" on it, by the way), and now it doesn't autocomplete.

''cor-el [[#answer-1170815|said]]'' <blockquote> You may have once typed <b>about:config/</b> with a slash appended. You can use these steps to remove saved items from an autocomplete drop-down list. #click the (empty) input field on the web page to open the drop-down list #highlight an entry in the drop-down list with cursor Down key<br>do not click the mouse or press the Enter key #press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry Note that hovering with the mouse no longer works. </blockquote> That's the bizarre thing - "about:config" is in the list, but not "about:config/" Oh ok, I fixed it - I had saved "about:config" as a bookmark, and Firefox was helpfully putting the "/" on the end. I deleted the bookmark (which did NOT have the "/" on it, by the way), and now it doesn't autocomplete.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Pj said

ChrompSquad said
Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!!

I dunno. Edit it to About:Config and go.

Video Autoplay: See

Autoplay is stopped for videos *with audio* only. I have changed that setting. I want videos *without audio* to not autoplay as well. The old pref did that. The new one does not.

''Pj [[#answer-1170799|said]]'' <blockquote> ''ChrompSquad [[#answer-1170729|said]]'' <blockquote> Also... why does me typing "about:con..." auto complete to "about:config/"? It doesn't work with the trailing slash!! </blockquote> I dunno. Edit it to '''About:Config''' and go. Video Autoplay: See *https://support.mozilla.org/en-US/questions/1238380#answer-1167225 </blockquote> Autoplay is stopped for videos *with audio* only. I have changed that setting. I want videos *without audio* to not autoplay as well. The old pref did that. The new one does not.
பதிவிடப்பட்டது

உதவிகரமான பதில்

cor-el said

See also:

That one works, thanks. Edit - nope, some stuff still autoplays on imgur.

Seems really odd that they put in a new pref, which does less than the old one, and that you need an addon to fix it.

''cor-el [[#answer-1170821|said]]'' <blockquote> See also: *Disable HTML5 Autoplay<br>https://addons.mozilla.org/firefox/addon/disable-autoplay/ </blockquote> That one works, thanks. Edit - nope, some stuff still autoplays on imgur. Seems really odd that they put in a new pref, which does less than the old one, and that you need an addon to fix it.

ChrompSquad மூலமாக திருத்தப்பட்டது

TyDraniu
  • Top 25 Contributor
338 தீர்வுகள் 1897 பதில்கள்
பதிவிடப்பட்டது

No, for muted videos you can change media.autoplay.allow-muted to false. You don't need an addon.

No, for muted videos you can change ''media.autoplay.allow-muted'' to '''false'''. You don't need an addon.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

TyDraniu said

No, for muted videos you can change media.autoplay.allow-muted to false. You don't need an addon.

Do you know what, this still doesn't work.

https://imgur.com/gallery/8y6sleb for example

''TyDraniu [[#answer-1170854|said]]'' <blockquote> No, for muted videos you can change ''media.autoplay.allow-muted'' to '''false'''. You don't need an addon. </blockquote> Do you know what, this still doesn't work. https://imgur.com/gallery/8y6sleb for example
TyDraniu
  • Top 25 Contributor
338 தீர்வுகள் 1897 பதில்கள்
பதிவிடப்பட்டது

Change default to 2 and block-event to true.

Change default to 2 and block-event to true.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

https://imgur.com/gallery/U4dEk72 https://imgur.com/gallery/IdBMCMa Still plays
cor-el
  • Top 10 Contributor
  • Moderator
17574 தீர்வுகள் 158974 பதில்கள்
பதிவிடப்பட்டது

This video doesn't play by default for me with the pref set to 1.

This video doesn't play by default for me with the pref set to 1. *media.autoplay.default = 1 *https://imgur.com/gallery/8y6sleb