X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How can I turn off AutoPlay in Firefox? It is not listed in preferences.

  • 5 replies
  • 6 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

The new 'update' on Firefox (63.0, I think) turned on all my AutoPlays that I had previously turned off. Very annoying. How can I turn off AutoPlay? Do they have to update the software?

The new 'update' on Firefox (63.0, I think) turned on all my AutoPlays that I had previously turned off. Very annoying. How can I turn off AutoPlay? Do they have to update the software?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

THIS SOLUTION IS FOR FIREFOX 63.

For Firefox 66, see: Allow or block media autoplay in Firefox


Hi chrissporter, these hidden settings have evolved in preparation for being added to the Permissions section of the Preferences page in a later release. For now, you'll still need to use about:config.

The old media.autoplay.enabled preference has been replaced by several new ones (you may see it, but Firefox ignores it). Please give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • *Edit* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

Read this answer in context 4

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8642 தீர்வுகள் 70696 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

THIS SOLUTION IS FOR FIREFOX 63.

For Firefox 66, see: Allow or block media autoplay in Firefox


Hi chrissporter, these hidden settings have evolved in preparation for being added to the Permissions section of the Preferences page in a later release. For now, you'll still need to use about:config.

The old media.autoplay.enabled preference has been replaced by several new ones (you may see it, but Firefox ignores it). Please give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • *Edit* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

THIS SOLUTION IS FOR FIREFOX 63. ''For Firefox 66, see:'' [[Allow or block media autoplay in Firefox]] ---- Hi chrissporter, these hidden settings have evolved in preparation for being added to the Permissions section of the Preferences page in a later release. For now, you'll still need to use about:config. The old '''media.autoplay.enabled''' preference has been replaced by several new ones (you may see it, but Firefox ignores it). Please give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * *Edit* ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63.

jscher2000 மூலமாக திருத்தப்பட்டது

rosawood 4 தீர்வுகள் 42 பதில்கள்
பதிவிடப்பட்டது

It's not working with the latest update 66.0.2 64 bit. This is infuriating! Why would autoplay be the default? Why would anyone want video to play automatically?

I've tried all the suggestions, even tried turning autoplay options on and off individually in about:config, but I still have videos autoplaying--though muted (is that supposed to be helpful when it's till taking up bandwidth?). I'm ready to go back to the previous iteration because this is just not working, and i absolutely hate Chrome so can't go there.

Attached are my current settings. Is there something I can change that I haven't tried before?

It's not working with the latest update 66.0.2 64 bit. This is infuriating! Why would autoplay be the default? Why would anyone want video to play automatically? I've tried all the suggestions, even tried turning autoplay options on and off individually in about:config, but I still have videos autoplaying--though muted (is that supposed to be helpful when it's till taking up bandwidth?). I'm ready to go back to the previous iteration because this is just not working, and i absolutely hate Chrome so can't go there. Attached are my current settings. Is there something I can change that I haven't tried before?

rosawood மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8642 தீர்வுகள் 70696 பதில்கள்
பதிவிடப்பட்டது

Hi rosawood, Firefox 66 has changed. Please check this article:

Allow or block media autoplay in Firefox

Firefox's feature focuses on the initial page load. Some sites start autoplaying later after you scroll or take other action in the page, and those may not be stopped. There are add-ons to try to tackle those.

Hi rosawood, Firefox 66 has changed. Please check this article: [[Allow or block media autoplay in Firefox]] Firefox's feature focuses on the initial page load. Some sites start autoplaying later after you scroll or take other action in the page, and those may not be stopped. There are add-ons to try to tackle those.
rosawood 4 தீர்வுகள் 42 பதில்கள்
பதிவிடப்பட்டது

The sound is turned off, but the video still plays.

The sound is turned off, but the video still plays.
jscher2000
  • Top 10 Contributor
8642 தீர்வுகள் 70696 பதில்கள்
பதிவிடப்பட்டது

rosawood said

The sound is turned off, but the video still plays.

That happens on some sites. Do you want to start a new question and indicate where you have the problem:

https://support.mozilla.org/questions/new/desktop/privacy-and-security

As usual, keep scrolling down past article suggestions to continue with the form.

''rosawood [[#answer-1210228|said]]'' <blockquote> The sound is turned off, but the video still plays. </blockquote> That happens on some sites. Do you want to start a new question and indicate where you have the problem: https://support.mozilla.org/questions/new/desktop/privacy-and-security As usual, keep scrolling down past article suggestions to continue with the form.