X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How do I turn off autocomplete?

  • 11 replies
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

Simple question: How do I turn off autocomplete in the search bar?

Autocomplete is the function which inputs text I did not type into the text box. Autocomplete is not the dropdown beneath the search bar, that is automatic suggestions. Autocomplete is not the feature that fills out forms, that is autofill. Autocomplete has nothing to do with storing browsing history or any other information. It is not a security feature, it is a usability feature. I do not want to turn off automatic suggestions, autofill, cookies, history tracking, or any other information storage or usability functions. I only want to turn off autocomplete. Please tell me how to turn off autocomplete, and only autocomplete. I shouldn't have to go into detail like this but I know from past experience that it can take literally weeks to wade through the endless mis-directions to finally get to an answer that actually addresses autocomplete. So do not respond by telling me anything about shutting off any other features, or I will report your post for spam.

I quit Google Chrome and switched to Mozilla Firefox because Google employees informed me that it is Google's stated intent that not only will there not be any option to turn off autocomplete in their browser, but that they outright wish to suppress any and all attempts to circumvent the feature, as they--and they have told me this directly--wish to force the feature on their users. I hope I will not receive the same attitude from Mozilla on this subject. Autocomplete is not just a minor feature, it is a major problem for my browsing and it is imperative that I have a way to turn it off. Not having a way to turn it off is a deal-breaker for me. I will quit Firefox and find another browser if I cannot turn off autocomplete.

Simple question: How do I turn off autocomplete in the search bar? Autocomplete is the function which inputs text I did not type into the text box. Autocomplete is not the dropdown beneath the search bar, that is automatic suggestions. Autocomplete is not the feature that fills out forms, that is autofill. Autocomplete has nothing to do with storing browsing history or any other information. It is not a security feature, it is a usability feature. I do not want to turn off automatic suggestions, autofill, cookies, history tracking, or any other information storage or usability functions. I only want to turn off autocomplete. Please tell me how to turn off autocomplete, and only autocomplete. I shouldn't have to go into detail like this but I know from past experience that it can take literally weeks to wade through the endless mis-directions to finally get to an answer that actually addresses autocomplete. So do not respond by telling me anything about shutting off any other features, or I will report your post for spam. I quit Google Chrome and switched to Mozilla Firefox because Google employees informed me that it is Google's stated intent that not only will there not be any option to turn off autocomplete in their browser, but that they outright wish to suppress any and all attempts to circumvent the feature, as they--and they have told me this directly--wish to force the feature on their users. I hope I will not receive the same attitude from Mozilla on this subject. Autocomplete is not just a minor feature, it is a major problem for my browsing and it is imperative that I have a way to turn it off. Not having a way to turn it off is a deal-breaker for me. I will quit Firefox and find another browser if I cannot turn off autocomplete.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Go to about:config and set browser.urlbar.autocomplete.enabled = false

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 30.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

கூடுதல் தகவல்

FredMcD
  • Top 10 Contributor
4230 தீர்வுகள் 59026 பதில்கள்
பதிவிடப்பட்டது

Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.

Type '''about:preferences#privacy'''<enter> in the address bar. At the bottom of the page, find '''Location Bar. '''
TyDraniu
  • Top 25 Contributor
310 தீர்வுகள் 1728 பதில்கள்
பதிவிடப்பட்டது

I've never experienced autocomplete in the search bar. You probably mean the URL bar.

I've never experienced autocomplete in the search bar. You probably mean the URL bar.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Yes, I meant the URL bar. My mistake.

I didn't know that the search bar and address bar have different functionality. I might be able to get by on using the search bar instead of the URL bar, but I would much prefer to simply have autocomplete turned off entirely.

Yes, I meant the URL bar. My mistake. I didn't know that the search bar and address bar have different functionality. I might be able to get by on using the search bar instead of the URL bar, but I would much prefer to simply have autocomplete turned off entirely.
TyDraniu
  • Top 25 Contributor
310 தீர்வுகள் 1728 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Go to about:config and set browser.urlbar.autocomplete.enabled = false

Go to ''about:config'' and set ''browser.urlbar.autocomplete.enabled'' = '''false'''
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

It worked! Thanks. It also disabled the dropdown suggestions, though. I'll take it as an acceptable compromise, though I am rather disappointed in having to give up such a useful feature just to shut down a completely unrelated feature which gets in my way.

It worked! Thanks. It also disabled the dropdown suggestions, though. I'll take it as an acceptable compromise, though I am rather disappointed in having to give up such a useful feature just to shut down a completely unrelated feature which gets in my way.
exekutive 0 தீர்வுகள் 4 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

This "feature" is infuriating. It's like some snatching the wheel and turning the car while you're trying to drive. Why can't we have auto-suggest without auto-this-is-what-you-really-want Mozilla?

This "feature" is infuriating. It's like some snatching the wheel and turning the car while you're trying to drive. Why can't we have auto-suggest without auto-this-is-what-you-really-want Mozilla?
FredMcD
  • Top 10 Contributor
4230 தீர்வுகள் 59026 பதில்கள்
பதிவிடப்பட்டது

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

If you want to leave feedback for Firefox developers, you can go to the Firefox ''Help'' menu and select ''Submit Feedback...'' or use [https://qsurvey.mozilla.com/s3/FirefoxInput/ this link]. Your feedback gets collected by a team of people who read it and gather data about the most common issues.
GoodToGo 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

I wanted to update this, because I recently had the same issue and found this question in my search results.

You can go to about:config and change browser.urlbar.autoFill to false. This will remove the autocomplete but keep the suggestions.

I wanted to update this, because I recently had the same issue and found this question in my search results. You can go to ''about:config'' and change ''browser.urlbar.autoFill'' to '''false'''. This will remove the autocomplete but keep the suggestions.
jscher2000
  • Top 10 Contributor
8642 தீர்வுகள் 70690 பதில்கள்
பதிவிடப்பட்டது

GoodToGo said

I wanted to update this, because I recently had the same issue and found this question in my search results.

You can go to about:config and change browser.urlbar.autoFill to false. This will remove the autocomplete but keep the suggestions.

Yes, the suggested address that appears inside the address bar itself as you type is called autofill. If you only want to turn off autofill and not suggestions in the drop-down, this is the best way to do it.

''GoodToGo [[#answer-1206165|said]]'' <blockquote> I wanted to update this, because I recently had the same issue and found this question in my search results. <br><br> You can go to ''about:config'' and change '''browser.urlbar.autoFill''' to '''false'''. This will remove the autocomplete but keep the suggestions. </blockquote> Yes, the suggested address that appears ''inside the address bar itself'' as you type is called autofill. If you only want to turn off autofill and not suggestions in the drop-down, this is the best way to do it.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The automatic text in the address bar is called autocomplete, this is a community standard. If Firefox is calling it autofill, then they are going to confuse a lot of users because autofill is the term used for forms automatically filling themselves out with your stored information.

The automatic text in the address bar is called autocomplete, this is a community standard. If Firefox is calling it autofill, then they are going to confuse a lot of users because autofill is the term used for forms automatically filling themselves out with your stored information.
FredMcD
  • Top 10 Contributor
4230 தீர்வுகள் 59026 பதில்கள்
பதிவிடப்பட்டது

thereaverofdarkness said

. . . because autofill is the term used for forms automatically filling themselves out

Add-ons, not forms. When a page is loaded, the add-on checks for and files out any open input box.

''thereaverofdarkness [[#answer-1207580|said]]'' <blockquote> . . . because autofill is the term used for forms automatically filling themselves out </blockquote> Add-ons, not forms. When a page is loaded, the add-on checks for and files out any open input box.