X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Why on some website content (e.g. animated GIFs on Twitter and Giphy) does blocking HTML5 autoplay also prevent manually playing media?

  • 6 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

I have only just noticed this issue, having not encountered it before. It's a problem for both embedded content and content on Giphy. There used to at least be media controls available to start the media playback, but that does not seem to be the case now. First encountered this on Firefox v61, and updated to 62.0 and am still experiencing the same issue.

The key is that I do not want any media to autoplay without me interacting with it, but now it seems that animated gifs are not even presenting me with media controls to activate them. If I enable media.autoplay.enabled, the animated gifs will autoplay successfully, but then all of the other content that I do not want to autoplay will also autoplay.

I have only just noticed this issue, having not encountered it before. It's a problem for both embedded content and content on Giphy. There used to at least be media controls available to start the media playback, but that does not seem to be the case now. First encountered this on Firefox v61, and updated to 62.0 and am still experiencing the same issue. The key is that I do not want any media to autoplay without me interacting with it, but now it seems that animated gifs are not even presenting me with media controls to activate them. If I enable media.autoplay.enabled, the animated gifs will autoplay successfully, but then all of the other content that I do not want to autoplay will also autoplay.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 30.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

கூடுதல் தகவல்

Shadow110 1072 தீர்வுகள் 14836 பதில்கள்
பதிவிடப்பட்டது

No idea what extensions your running, you can stop it with uBlock Origin, Ghostory, Malwarebytes

https://addons.mozilla.org/firefox/addon/ublock-origin/ https://addons.mozilla.org/firefox/addon/ghostery/ Use Ghostery to train the sliders in Ublock and what 3party/Media to let through, they work together well. https://addons.mozilla.org/firefox/addon/malwarebytes/ This will break 3rd party cookies which tend to be media. All controls for each program is handy to toggle on off, reload Note they will all break pages and need to learn.

There is info here : https://blog.mozilla.org/firefox/make-your-firefox-browser-a-privacy-superpower-with-these-extensions/?utm_source=www.mozilla.org&utm_medium=referral&utm_campaign=fx-content-hub

https://addons.mozilla.org/firefox/search/?platform=windows&q=stop%20autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/

No idea what extensions your running, you can stop it with uBlock Origin, Ghostory, Malwarebytes https://addons.mozilla.org/firefox/addon/ublock-origin/ https://addons.mozilla.org/firefox/addon/ghostery/ Use Ghostery to train the sliders in Ublock and what 3party/Media to let through, they work together well. https://addons.mozilla.org/firefox/addon/malwarebytes/ This will break 3rd party cookies which tend to be media. All controls for each program is handy to toggle on off, reload Note they will all break pages and need to learn. There is info here : https://blog.mozilla.org/firefox/make-your-firefox-browser-a-privacy-superpower-with-these-extensions/?utm_source=www.mozilla.org&utm_medium=referral&utm_campaign=fx-content-hub https://addons.mozilla.org/firefox/search/?platform=windows&q=stop%20autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Okay, the only content blocking extension I'm currently running is uBlock Origin. I'll look into your advice.

Thanks.

Okay, the only content blocking extension I'm currently running is uBlock Origin. I'll look into your advice. Thanks.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

This did not correct the issue. Even if I disable all add-ons, embedded GIFs from Giphy still fail to play and fail to provide any media playback controls. The only thing that allows the embedded GIFs to play is to enable media autoplay in about:config.

This did not correct the issue. Even if I disable all add-ons, embedded GIFs from Giphy still fail to play and fail to provide any media playback controls. The only thing that allows the embedded GIFs to play is to enable media autoplay in about:config.
cor-el
  • Top 10 Contributor
  • Moderator
17564 தீர்வுகள் 158866 பதில்கள்
பதிவிடப்பட்டது

GIFV files are usually MP4 files and are played with the HTML5 media player. So being media files they are affected by the autoplay setting. Website may not always work properly with autoplay disabled via the pref, so maybe look for an extension to see if that works better.

GIFV files are usually MP4 files and are played with the HTML5 media player. So being media files they are affected by the autoplay setting. Website may not always work properly with autoplay disabled via the pref, so maybe look for an extension to see if that works better.
jscher2000
  • Top 10 Contributor
8783 தீர்வுகள் 71817 பதில்கள்
பதிவிடப்பட்டது

Some players hide the controls. As a first step, try right-clicking the media and choose Show Controls. That should give you a play button.

Some players hide the controls. As a first step, try right-clicking the media and choose Show Controls. That ''should'' give you a play button.
cor-el
  • Top 10 Contributor
  • Moderator
17564 தீர்வுகள் 158866 பதில்கள்
பதிவிடப்பட்டது

There should also be a Play item in the context menu if the MP4 file is loaded properly.

There should also be a Play item in the context menu if the MP4 file is loaded properly.