X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

FED UP with the damned BLUE DOTS. What's the PROPER way to (PERMANENTLY) turn them off in FF61?

  • 18 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Pj
பதிவிடப்பட்டது

Yes, I mean the "animated" (my ass!) blue dots that appear on the leftmost tab.

Yes, I mean the "animated" (my ass!) blue dots that appear on the leftmost tab.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 30.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

கூடுதல் தகவல்

FFus3r 50 தீர்வுகள் 757 பதில்கள்
பதிவிடப்பட்டது

can you attach screenshot?

can you attach screenshot?
Shadow110 1072 தீர்வுகள் 14836 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Type about:config in the Firefox address bar and hit the Enter-key afterwards. Confirm that you will be careful if the warning intermediary page is displayed. Use the search to find toolkit.cosmeticAnimations.enabled Double-click on the preference name to toggle its state.

Double Click it to False Restart Firefox.

I had 4 more but seems they have changed the code.

Type about:config in the Firefox address bar and hit the Enter-key afterwards. Confirm that you will be careful if the warning intermediary page is displayed. Use the search to find toolkit.cosmeticAnimations.enabled Double-click on the preference name to toggle its state. Double Click it to False Restart Firefox. I had 4 more but seems they have changed the code.
Shadow110 1072 தீர்வுகள் 14836 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

At least I think they this turns of something.

At least I think they this turns of something.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Will wait 24 hours to ensure they don't come back, but that setting change -might- work ;) Thank you.

Will wait 24 hours to ensure they don't come back, but that setting change -might- work ;) Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Resetting toolkit.cosmeticAnimations.enabled works temporarily, but the dancing-dots keep "coming back from the dead." I dimly recall a change to a .css file which was (effectively) more "sticky."

Resetting toolkit.cosmeticAnimations.enabled works temporarily, but the dancing-dots keep "coming back from the dead." I dimly recall a change to a .css file which was (effectively) more "sticky."

BillM மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FFus3r said

can you attach screenshot?

How do you screen-shot *animation*? (animation that's *built-into Firefox*)?

''FFus3r [[#answer-1151296|said]]'' <blockquote> can you attach screenshot? </blockquote> How do you screen-shot *animation*? (animation that's *built-into Firefox*)?

BillM மூலமாக திருத்தப்பட்டது

McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

BillM said

That setting works temporarily, but the dancing-dots keep "coming back from the dead." I dimly recall a change to a .css file which was (effectively) more "sticky."

Maybe what worked for the OP in this thread may work for you as well :

https://support.mozilla.org/en-US/questions/1197903

''BillM [[#answer-1157716|said]]'' <blockquote> That setting works temporarily, but the dancing-dots keep "coming back from the dead." I dimly recall a change to a .css file which was (effectively) more "sticky." </blockquote> Maybe what worked for the OP in this thread may work for you as well : https://support.mozilla.org/en-US/questions/1197903
FFus3r 50 தீர்வுகள் 757 பதில்கள்
பதிவிடப்பட்டது

use userChrome.css

link in mccoy's reply

use '''userChrome.css ''' link in mccoy's reply

FFus3r மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71066 பதில்கள்
பதிவிடப்பட்டது

Hi BillM, I use a style rule in userChrome.css to replace the "ping-ponging" dot with the circling element, but there are some cases where I still see the dots. Maybe it's only at startup? I don't pay close attention to when it appears.

Are you already familiar with userChrome.css from making other tweaks to Firefox's toolbar area? Just in case you aren't, when you have 10 minutes to focus on it, here's how it works:

This assumes you do not already have a userChrome.css file. If you do already have a working userChrome.css file, you just need to add the rule under (A) to your file.

(A) Select and copy the following style rule code

/* Revert tab throbber */
.tab-throbber[busy]::before {
  background-image: url("chrome://global/skin/icons/loading.png") !important;
  animation: unset !important;
}
.tab-throbber[busy]:not([progress])::before {
  /* Grays the blue during "Connecting" state */
  filter: grayscale(100%);
}
@media (min-resolution: 2dppx) {
  .tab-throbber[busy]::before {
    background-image: url("chrome://global/skin/icons/loading@2x.png") !important;
  }
}

(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that Windows Explorer window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you generated in Step B into the chrome folder you created in Step C

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Hi BillM, I use a style rule in userChrome.css to replace the "ping-ponging" dot with the circling element, but there are some cases where I still see the dots. Maybe it's only at startup? I don't pay close attention to when it appears. Are you already familiar with userChrome.css from making other tweaks to Firefox's toolbar area? Just in case you aren't, when you have 10 minutes to focus on it, here's how it works: ''This assumes you do not already have a userChrome.css file. If you ''do'' already have a working userChrome.css file, you just need to add the rule under (A) to your file.'' '''(A) Select and copy the following style rule code''' <pre>/* Revert tab throbber */ .tab-throbber[busy]::before { background-image: url("chrome://global/skin/icons/loading.png") !important; animation: unset !important; } .tab-throbber[busy]:not([progress])::before { /* Grays the blue during "Connecting" state */ filter: grayscale(100%); } @media (min-resolution: 2dppx) { .tab-throbber[busy]::before { background-image: url("chrome://global/skin/icons/loading@2x.png") !important; } } </pre> '''(B) Generate and download a''' <code>userChrome.css</code> '''file''' Open the following page and paste the above rules into the editor, replacing the sample rule: https://www.userchrome.org/download-userchrome-css.html Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot) Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot) Minimize that Windows Explorer window for later reference. '''(C) Create a new''' <code>chrome</code> '''folder in your profile folder''' The following article has the detailed steps for that (#1, #2, and I recommend #3) https://www.userchrome.org/how-create-userchrome-css.html ''I have videos for both Windows and Mac in case the text is not clear.'' '''(D) Move the''' <code>userChrome.css</code> '''file you generated in Step B into the''' <code>chrome</code> '''folder you created in Step C''' The next time you exit Firefox and start it up again, it should discover that file and apply the rules.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks, will try it. Do not currently have a UserChrome.css ... I assume (on Windows) that .css file needs to be copied to all users' desktops, rather than to some shared-by-all location...?

Thanks, will try it. Do not currently have a UserChrome.css ... I assume (on Windows) that .css file needs to be copied to all users' desktops, rather than to some shared-by-all location...?

BillM மூலமாக திருத்தப்பட்டது

McCoy
  • Top 10 Contributor
534 தீர்வுகள் 5035 பதில்கள்
பதிவிடப்பட்டது

McCoy said

Maybe what worked for the OP in this thread may work for you as well :
https://support.mozilla.org/en-US/questions/1197903

That wasn't worth a try  ?

''McCoy [[#answer-1157719|said]]'' <blockquote> Maybe what worked for the OP in this thread may work for you as well :<BR> https://support.mozilla.org/en-US/questions/1197903 </blockquote> That wasn't worth a try ?
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71066 பதில்கள்
பதிவிடப்பட்டது

BillM said

Thanks, will try it. Do not currently have a UserChrome.css ... I assume (on Windows) that .css file needs to be copied to all users' desktops, rather than to some shared-by-all location...?

Yes, each Firefox profile has its own settings files.

''BillM [[#answer-1162770|said]]'' <blockquote> Thanks, will try it. Do not currently have a UserChrome.css ... I assume (on Windows) that .css file needs to be copied to all users' desktops, rather than to some shared-by-all location...? </blockquote> Yes, each Firefox profile has its own settings files.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Seems like a blatant standards violation to me. Ordinary users should NOT be forced to endure animation on our slower-than-Mozilla network links ... unless there's a DAMN good reason.

Seems like a blatant standards violation to me. Ordinary users should NOT be forced to endure animation on our slower-than-Mozilla network links ... unless there's a DAMN good reason.
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71066 பதில்கள்
பதிவிடப்பட்டது

BillM said

Seems like a blatant standards violation to me.

Hi BillM, what standards? If you feel that Firefox does not comply with browser standards, or laws/regulations, you could initiate a thread on Discourse. It not something that can be fixed in the support forum since we are not the developers.

https://discourse.mozilla.org/c/firefox-development

''BillM [[#answer-1183557|said]]'' <blockquote> Seems like a blatant standards violation to me. </blockquote> Hi BillM, what standards? If you feel that Firefox does not comply with browser standards, or laws/regulations, you could initiate a thread on Discourse. It not something that can be fixed in the support forum since we are not the developers. https://discourse.mozilla.org/c/firefox-development
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Fair enough re: appropriate discussion venue, except that this problem manifests in existing, shipping code, affecting users today.

I've always viewed the ideal browser as a tool or an appliance, not a laboratory. De-facto standards are a good thing, and I believe no other major browser (Chrome, IE, Firefox pre-63) FORCES bandwidth-robbing animation on users, in the out-of-the-box configuration.

Animation should either be opt-in (from the site designer's POV) - or, at worst, a simple, end-user-visible setting to DISable it... not something that's force-fed to users or that requires complex config changes.

Distractions in the UI are counter-productive unless they convey widely-understood meaning, and the animated dots don't. (Am reviewing W3C standards and will take the topic to Discourse in the next few days for further discussion, if that seems appropriate.)

(And the impact on bandwidth needs to be quantified; I only know that *I* find it objectionable, in a WiFi-constrained environment.)

Fair enough re: appropriate discussion venue, except that this problem manifests in existing, shipping code, affecting users today. I've always viewed the ideal browser as a tool or an appliance, not a laboratory. De-facto standards are a good thing, and I believe no other major browser (Chrome, IE, Firefox pre-63) FORCES bandwidth-robbing animation on users, in the out-of-the-box configuration. Animation should either be opt-in (from the site designer's POV) - or, at worst, a simple, end-user-visible setting to DISable it... not something that's force-fed to users or that requires complex config changes. Distractions in the UI are counter-productive unless they convey widely-understood meaning, and the animated dots don't. (Am reviewing W3C standards and will take the topic to Discourse in the next few days for further discussion, if that seems appropriate.) (And the impact on bandwidth needs to be quantified; I only know that *I* find it objectionable, in a WiFi-constrained environment.)
WestEnd
  • Top 25 Contributor
60 தீர்வுகள் 5379 பதில்கள்
பதிவிடப்பட்டது

Little lost here can the OP or someone whom knows what is meant by the blue dot show a screenshot of it? I use a userChrome.css so not sure if that removed or stopped the blue dots?

Little lost here can the OP or someone whom knows what is meant by the blue dot show a screenshot of it? I use a userChrome.css so not sure if that removed or stopped the blue dots?
cor-el
  • Top 10 Contributor
  • Moderator
17473 தீர்வுகள் 157940 பதில்கள்
பதிவிடப்பட்டது

The blue dots have replaced the rotating throbber on a tab that indicates that a tab is busy loading content. You usually see messages at the bottom of the Firefox window to show what Firefox is currently doing.

The blue dots have replaced the rotating throbber on a tab that indicates that a tab is busy loading content. You usually see messages at the bottom of the Firefox window to show what Firefox is currently doing.
Pj 42 தீர்வுகள் 869 பதில்கள்
பதிவிடப்பட்டது

jscher2000 said

I use a style rule in userChrome.css to replace the "ping-ponging" dot with the circling element, but there are some cases where I still see the dots...

Well, I tried this and I see Circling/Dancing Dot/Circling. I guess it's back to About:Config and find something in there to turn it off. I'd actually like a Flashing Red 'Traffic Light' Dot or the whole Tab to Blink or Pulse Red. (Grin)


~Pj

''jscher2000 [[#answer-1162763|said]]'' <blockquote> I use a style rule in '''userChrome.css''' to replace the "ping-ponging" dot with the circling element, but there are some cases where I still see the dots... </blockquote> Well, I tried this and I see '''''Circling/Dancing Dot/Circling'''''. I guess it's back to '''About:Config''' and find something in there to turn it off. I'd actually like a Flashing Red 'Traffic Light' Dot or the whole Tab to Blink or Pulse Red. (Grin) ~Pj