Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Keep Firefox from zooming when I'm trying to scroll?

  • 9 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 85 views
  • Last reply by MarjaE

Hi,

I am photosensitive, so I have to block a lot of flashing, blinking, and animation, including zooming. I haven't found any other browsers that I can configure to be accessible. I can't use safe mode-- it isn't safe.

I also have coordination problens, so have to disable Firefox's "autoscrolling" and "smooth scrolling" and use Scroll+ to scroll.

Firefox sometimes stops scrolling and starts zooming as I'm trying to scroll. This is NOT because I've accidentally scrolled over an embedded migraine from Google Migraines, or because I've hit control or command. Those keys are on the keyboard, and if I'm scrolling, my good hand is on the mouse.

Is there any way to prevent this?

I have an add-on to set zoom levels in the toolbar, and to avoid animation when adjusting them, so I don't need to be able to set them through the keyboard+sticky keys+mouse combination. So is there an about:config fix to disable the control+scroll or command+scroll combinations? Or another way to avoid accidental zooming?

Thanks.

All Replies (9)

Hi, Firefox comes with a zoom feature in Customize. Maybe disable the Extension you have and try it, it does learn after a week it will have all your top sites just the way you like them. https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars It is probable that that Extension is causing the issue.

As well one of the Contributors runs :

With userChrome we can help you remove all flashing lights like : Transparent turn off highlight of Address Bar

/* Transparent toolbar backgrounds */

  1. nav-bar, #PersonalToolbar {
 background-color: transparent !important;
 background-image: none !important;

} /* Remove top line on nav bar */

  1. nav-bar {
 box-shadow: none !important;

} ______________________________ https://www.accessfirefox.org/

Ok like wow with all your add-ons/Extensions. I can not pick just one or 2 that maybe the issue. Please TEST : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

We may have to get you to make a new Profile so can start from scratch to see which Extension is causing this (if it is) Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

Give a yell back for your issue and help with userChorme if needed.

"Hi, Firefox comes with a zoom feature in Customize."

I don't see it in Customize.

"Maybe disable the Extension you have and try it"

I need Zoom Page WE. Otherwise it's far harder to adjust font sizes, so text isn't too small to read, and doesn't overlap with other text or get hidden behind other objects.

"Please TEST : SAFE MODE"

SAFE MODE IS NOT SAFE!

I am photosensitive and need to block flashing. If I try to use safe mode, or if I try to use a new profile without adequate safety tools, I will get hit by more animation online, and I will get hurt.

3 Bar Menu --> Customize and the icon looks like -+ and under it it says Zoom Control.

Hi, sorry, was not thinking of that. This site will not have anything like it : https://www.accessfirefox.org/ as it is meant for issues like yours. Or if can get a friend to help you.

With out testing it is unknown if it is the Zoom We or Firefox that has the issue. The Zoom We was update 2 weeks ago. Their email support : dw-dev@gmx.com

The problem could be with that update that you just got from them.

Okay, thats.

I've had this problem, on and off, for months. Some users have been reporting it for years.

Zoom enlarges the largest text, as well as the smallest, and screws with scrolling, so I prefer minimum font sizes.

I've used the about:config fixes to block a lot of animation, including animated gifs and pngs, the blinking cursor, and most ui animation. So I am not sure what nav bar and address bar animation you're referring to.

I've also installed user css to try to block the tab loading throbber, and it doesn't always load in time, so I'd rather use an about:config or other preference fix than user css.

Hi, I will message some one to see if the can help you more. Think about what you need and make a list.

Some images like map zoom if you rotate the mouse wheel when you hover such an image, This can happen inadvertently when you scroll a page with the mouse wheel and touch the image. Because this zooming is done via JavaScript, the only way to avoid this is to keep the mouse pointer in 'safe' area on the page (e.g. far left or far right in the scroll bar area) and avoid images that might zoom automatically. This is similar to drop-down menu that open when you hover over a menu bar like you mentioned in the past and that annoying as well when you move the mouse from the top to the website area to scroll and you need to move the mouse carefully to avoid such menus from opening. Website designers do not make it easy to avoid actions happening automatically when you navigate a web page.

I don't know how the Scroll+ program works with Firefox's built-in features. However, you can disable the Command + mouse scroll wheel from doing anything special and see whether that helps.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste wheel and pause while the list is filtered

(3) {MAC} Double-click the mousewheel.with_meta.action preference to display a dialog where you can enter the desired value, change 3 to 1 and then click OK

(4) Double-click the mousewheel.with_control.action preference to display a dialog where you can enter the desired value, change 3 to 1 and then click OK

These are the possible values:

  • 0 => do nothing
  • 1 => scroll
  • 2 => emulate back/forward buttons
  • 3 => zoom (default setting)
  • 4 => horizontal scroll
  • 5 => zoom (pinch zoom; not sure how this is different)

jscher2000 மூலமாக திருத்தப்பட்டது

Thanks!

I actually had control and meta set to 1, but they didn't keep it from zooming. I've set it to 0-- my scrolling software still works that way-- maybe that will keep it from zooming.