Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't play music samples on Amazon website.

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 1357 views
  • Last reply by john40

When I click to play the track sample, the little circle goes round, but there's no sound coming out. Other sites like Youtube work fine. I'm using Windows 10 with Flash ad-on, on a new build PC. The flash setting is set to "ask first", but I don't think it gets that far. It was just the same before I installed flash.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi john40, yes, due to an antitrust settlement, everyone with an N version of Windows has to get the Media Feature Pack separately. I don't know whether Mozilla can integrate that information more obviously in Firefox rather than people finding their way eventually to that support article.

Regarding WebM VP9, as far as I know, YouTube uses it in certain cases, possibly including very high frame rate videos. If you like, you can enable that in settings, but if if you notice YouTube slowing down a lot, you may prefer to turn it back off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to switch the value from false to true (if you change your mind later, you can double-click to flip it back)

Read this answer in context 👍 0

All Replies (14)

The Amazon website uses HTML5, so there is no need for Adobe Flash Player in this instance. I tested it on my system and I have no issues.

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thanks for the reply, but I've done as suggested and it has made no difference.

Have you already tried Firefox Safe Mode to see if the issue is present there? It would likely rule out any issues with the settings or conflicting add-ons.

I've just checked it in Firefox safe mode, and it's exactly the same, no sound.

john40 said

I've just checked it in Firefox safe mode, and it's exactly the same, no sound.

This would mean your Browser is corrupted or damaged installation and needs to be uninstalled and Mozilla folder deleted and then reinstalled to fix your problem. As with any software if in "Safe Mode" you have issue then the software itself is damaged and needs to be uninstalled and reinstall to fix the error install.

WestEnd மூலமாக திருத்தப்பட்டது

OK, I've uninstalled it, re-installed it, and it still doesn't work.

I've also done the "refresh firefox" procedure. But still no sound on Amazon and other music sales sites that provide listening samples. Youtube videos play correctly, with sound.

What audio file formats work for you on this test page:

http://hpr.dogphilosophy.net/test/

Any since it may be related: do you have any "red" exclamation points for video formats on this test page:

https://www.youtube.com/html5

On the test page, they all play fine except mp3 and caf which say "Does Not Support". If I click on them it says "Like, DUDE! Something went wrong! Cannot actually decode this media".

The 2nd site shows 2 red exclamation marks, on "H.264" and "MSE & H.264".

Okay, for some reason, your Firefox is not hooking up with Media Foundation, the Microsoft software needed to decode MPEG-encoded media. Could you check this article: Fix video and audio playback problems on Firefox for Windows.

Firefox does not support CAF files, but the issue that you are having is with the MP3 files. That should be supported by Firefox.

Try resetting some of the Firefox preferences related to these codecs. Do the following:

  1. Type about:config in the Firefox address bar
  2. Find the media.gmp.decoder.h264 integer
  3. Right click it and select Reset

Repeat these steps for the media.navigator.video.h264.max_br and media.navigator.video.h264.max_mbps values as well.

Also, make sure that the media.mediasource.webm.audio.enabled boolean is set to true.

jscher2000 said

Okay, for some reason, your Firefox is not hooking up with Media Foundation, the Microsoft software needed to decode MPEG-encoded media. Could you check this article: Fix video and audio playback problems on Firefox for Windows.

Thank you jscher2000. Apparently I needed to instal the Media Feature Pack. I think this is because I've got Windows 10 Education N version. I don't understand why something so straightforward has been so difficult to resolve! Everyone using an N version must be in the same boat.

Regarding the second (Youtube) test site you gave me, there is now a red exclamation mark on "MSE & WebM VP9". Does this matter?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi john40, yes, due to an antitrust settlement, everyone with an N version of Windows has to get the Media Feature Pack separately. I don't know whether Mozilla can integrate that information more obviously in Firefox rather than people finding their way eventually to that support article.

Regarding WebM VP9, as far as I know, YouTube uses it in certain cases, possibly including very high frame rate videos. If you like, you can enable that in settings, but if if you notice YouTube slowing down a lot, you may prefer to turn it back off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to switch the value from false to true (if you change your mind later, you can double-click to flip it back)

Thank you to all who helped. It's much appreciated.