X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Can't watch ANY videos in Firefox

  • 4 replies
  • 3 இந்த பிரச்னைகள் உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

I'm running Firefox 59.0.2 64-bit on my PC. I have extensions for AdBlock, Honey, and LastPass. In addition to the two plug-ins provided by Mozilla in this version of Firefox, I have added Flash Player (re-installed several times).

I can't see ANY videos at all. No YouTube, no types of video at all.

I've refreshed my Firefox totally (and don't want to do that again any time soon!).

I've looked at "solutions" provided online, and nothing has worked.

Will someone give me the exact setup that should allow me to watch videos? Right now, when they come up, I get a spinning circle until finally some type of error message appears. The error message differs depending on where I'm watching the video. For example, If I'm trying to watch a YouTube video, I see the still picture that accompanies the video. When I click on the "play" arrow, I get: "An error occurred. Please try again later. Playback ID: pcGJXEDjuz-BRuBz" If I try to watch something on, say, the Weather Channel site, I first see the still picture. When I click to "play", I see a black screen with a small blue square in the center with the Weather Channel logo.

I did have a big Microsoft update a few nights ago, but I have no idea what changed there.

Bottom line: I have no idea what has happened to my video. What has changed since Firefox 58?

I'm running Firefox 59.0.2 64-bit on my PC. I have extensions for AdBlock, Honey, and LastPass. In addition to the two plug-ins provided by Mozilla in this version of Firefox, I have added Flash Player (re-installed several times). I can't see ANY videos at all. No YouTube, no types of video at all. I've refreshed my Firefox totally (and don't want to do that again any time soon!). I've looked at "solutions" provided online, and nothing has worked. Will someone give me the exact setup that should allow me to watch videos? Right now, when they come up, I get a spinning circle until finally some type of error message appears. The error message differs depending on where I'm watching the video. For example, If I'm trying to watch a YouTube video, I see the still picture that accompanies the video. When I click on the "play" arrow, I get: "An error occurred. Please try again later. Playback ID: pcGJXEDjuz-BRuBz" If I try to watch something on, say, the Weather Channel site, I first see the still picture. When I click to "play", I see a black screen with a small blue square in the center with the Weather Channel logo. I did have a big Microsoft update a few nights ago, but I have no idea what changed there. Bottom line: I have no idea what has happened to my video. What has changed since Firefox 58?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Read this answer in context 2

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 29.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Follow up: I started Firefox in Safe Mode, and videos play fine. I looked (in safe mode) at the extensions and plug-ins. My plug-ins in safe mode are exactly as they are in normal start mode. In safe mode, all extensions are disabled. I went back to normal start mode, and then disabled all extensions. Still no videos. Also, all "settings" are the same in Safe Mode and Normal Start Mode. I'm so confused!

Follow up: I started Firefox in Safe Mode, and videos play fine. I looked (in safe mode) at the extensions and plug-ins. My plug-ins in safe mode are exactly as they are in normal start mode. In safe mode, all extensions are disabled. I went back to normal start mode, and then disabled all extensions. Still no videos. Also, all "settings" are the same in Safe Mode and Normal Start Mode. I'm so confused!
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59419 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link} -------------- Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I made the performance changes as suggested, and it appears to have solved the issue. Thanks for the help. Now ... I'll dig into the graphics driver upgrade issues.

I made the performance changes as suggested, and it appears to have solved the issue. Thanks for the help. Now ... I'll dig into the graphics driver upgrade issues.
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59419 பதில்கள்
பதிவிடப்பட்டது

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.