Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why my default fonts in Firefox looks so ugly?

  • 12 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 13758 views
  • Last reply by FredMcD

Why the default fonts are looking so ugly? It is working fine on Edge. I am on Windows 10.

Please find the screenshots bellow.

https://imgur.com/a/Gke2K

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Issue finally resolved.

https://imgur.com/a/QF3VP

Solution : In case if you are also having same problem, please execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it will fix the issue.

https://imgur.com/a/YO6od

Read this answer in context 👍 0

All Replies (12)

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

It is already there, page with fonts are working fine, for eg. https://technochat.in

Only issue with those pages where no fonts configured, like this support forum. and this text box.

https://imgur.com/a/o2a5v

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

No luck, having same issue. It is really wired.

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

FredMcD said

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

I really don't understant what do you mean by public link? It is happening in every single page I browse without any custom font configured.

I have AnyDesk install on my system, and if you want to access, do let me know, I will share my ID.

Hi,

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering.

When Direct2D on Windows isn't used, Skia is used for content rendering

Would you please try this :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar gfx.canvas and look for the preference :

gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia

Type in the search bar gfx.content and look for the preference :

gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia

Then close and restart Firefox in order for the change to take effect.

If this doesn't make a difference, change the values back to their default by clicking 'Reset'.

Happy112 said

Hi, Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type in the search bar gfx.canvas and look for the preference : gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia Type in the search bar gfx.content and look for the preference : gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'.

I have updated as instructed, but unfortunately it didn't work. Pleas find the screenshot bellow. https://imgur.com/a/f1WJi

Oppps

RexaFire மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Issue finally resolved.

https://imgur.com/a/QF3VP

Solution : In case if you are also having same problem, please execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it will fix the issue.

https://imgur.com/a/YO6od

That was very good work. Well done.