X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Why my default fonts in Firefox looks so ugly?

  • 12 replies
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

Why the default fonts are looking so ugly? It is working fine on Edge. I am on Windows 10.

Please find the screenshots bellow.

https://imgur.com/a/Gke2K

Why the default fonts are looking so ugly? It is working fine on Edge. I am on Windows 10. Please find the screenshots bellow. https://imgur.com/a/Gke2K

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Issue finally resolved.

https://imgur.com/a/QF3VP

Solution : In case if you are also having same problem, please execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it will fix the issue.

https://imgur.com/a/YO6od

Read this answer in context 0

Additional System Details

பயன்பாடு

  • Firefox 58.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
  • Support URL: https://support.mozilla.org/1/firefox/58.0.2/WINNT/en-US/

நீட்சிகள்

  • LastPass: Free Password Manager 4.2.3.20 (support@lastpass.com)
  • uBlock Origin 1.15.4 (uBlock0@raymondhill.net)
  • IDM Integration Module 6.30.3 (mozilla_cc3@internetdownloadmanager.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce 820M
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2: 0x1140
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2: C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvltwu.inf_amd64_0221ce4ec0827f74\nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 397817aa
  • adapterSubsysID2: 381617aa
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.16299.15
  • driverDate: 3-28-2017
  • driverDate2: 12-29-2016
  • driverVersion: 20.19.15.4642
  • driverVersion2: 21.21.13.7654
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_robust_resource_initialization GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.db3422764a9b)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000e96f) EGL_VERSION: 1.4 (ANGLE 2.1.0.db3422764a9b) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_ANGLE_display_robust_resource_initialization
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4271 தீர்வுகள் 59904 பதில்கள்
பதிவிடப்பட்டது

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD said

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

It is already there, page with fonts are working fine, for eg. https://technochat.in

Only issue with those pages where no fonts configured, like this support forum. and this text box.

https://imgur.com/a/o2a5v

''FredMcD [[#answer-1076474|said]]'' <blockquote> Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 </blockquote> It is already there, page with fonts are working fine, for eg. https://technochat.in Only issue with those pages where no fonts configured, like this support forum. and this text box. https://imgur.com/a/o2a5v
FredMcD
  • Top 10 Contributor
4271 தீர்வுகள் 59904 பதில்கள்
பதிவிடப்பட்டது

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

No luck, having same issue. It is really wired.

''FredMcD [[#answer-1076683|said]]'' <blockquote> [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia </blockquote> No luck, having same issue. It is really wired.
FredMcD
  • Top 10 Contributor
4271 தீர்வுகள் 59904 பதில்கள்
பதிவிடப்பட்டது

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

Please provide public link(s) (no password) that we can check out. '''No Personal Information Please ! '''
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD said

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

I really don't understant what do you mean by public link? It is happening in every single page I browse without any custom font configured.

I have AnyDesk install on my system, and if you want to access, do let me know, I will share my ID.

''FredMcD [[#answer-1076749|said]]'' <blockquote> Please provide public link(s) (no password) that we can check out. '''No Personal Information Please ! ''' </blockquote> I really don't understant what do you mean by public link? It is happening in every single page I browse without any custom font configured. I have AnyDesk install on my system, and if you want to access, do let me know, I will share my ID.
FredMcD
  • Top 10 Contributor
4271 தீர்வுகள் 59904 பதில்கள்
பதிவிடப்பட்டது

I called for more help.

I called for more help.
Happy112 561 தீர்வுகள் 5694 பதில்கள்
பதிவிடப்பட்டது

Hi,

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering.

When Direct2D on Windows isn't used, Skia is used for content rendering

Would you please try this :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar gfx.canvas and look for the preference :

gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia

Type in the search bar gfx.content and look for the preference :

gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia

Then close and restart Firefox in order for the change to take effect.

If this doesn't make a difference, change the values back to their default by clicking 'Reset'.

Hi, Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type in the search bar '''gfx.canvas''' and look for the preference : '''gfx.canvas.azure.backends''' and set its value to '''direct2d1.1,cairo,skia''' Type in the search bar '''gfx.content''' and look for the preference : '''gfx.content.azure.backends''' and set its value to '''direct2d1.1,cairo,skia''' Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Happy112 said

Hi, Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type in the search bar gfx.canvas and look for the preference : gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia Type in the search bar gfx.content and look for the preference : gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'.

I have updated as instructed, but unfortunately it didn't work. Pleas find the screenshot bellow. https://imgur.com/a/f1WJi

''Happy112 [[#answer-1076958|said]]'' <blockquote> Hi, Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type in the search bar '''gfx.canvas''' and look for the preference : '''gfx.canvas.azure.backends''' and set its value to '''direct2d1.1,cairo,skia''' Type in the search bar '''gfx.content''' and look for the preference : '''gfx.content.azure.backends''' and set its value to '''direct2d1.1,cairo,skia''' Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'. </blockquote> I have updated as instructed, but unfortunately it didn't work. Pleas find the screenshot bellow. https://imgur.com/a/f1WJi
RexaFire 0 தீர்வுகள் 100 பதில்கள்
பதிவிடப்பட்டது

Oppps

Oppps

RexaFire மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Issue finally resolved.

https://imgur.com/a/QF3VP

Solution : In case if you are also having same problem, please execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it will fix the issue.

https://imgur.com/a/YO6od

Issue finally resolved. https://imgur.com/a/QF3VP Solution : In case if you are also having same problem, please execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it will fix the issue. https://imgur.com/a/YO6od
FredMcD
  • Top 10 Contributor
4271 தீர்வுகள் 59904 பதில்கள்
பதிவிடப்பட்டது

That was very good work. Well done.

That was very good work. Well done.