Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

how can I minimize firefox

  • 5 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 2069 views
  • Last reply by rolf.taylor

The exisiting thread on this topic is next to worthless. Has a whole bunch of unrelated "try this " stuff. Then there is a suggestion that sounds promising (tablet versus desktop mode) but no indication on how to switch between the two. If I can prevent this firefox window from hijacking my screen I may stay with it, but I am dissapointed the default seems to violate apple UI guidelines and also seems to be hard to change (e.g "act like a normal window" should be a prominent option in preferences.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Make sure you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

Read this answer in context 👍 1

All Replies (5)

What do you mean by minimize firefox? Is there a specific task that causes the problem or what steps you did that caused that specific problem. The Browser can't hijack your Windows O/S - until you can give a more clear request what your asking - has no concrete diagnosing for anyone to see what is going on. Browsers are not like a normal Windows Explorer.

Are you a DOS user unfamiliar with windowed OSes?

All modern GUI OSes have buttons on each window to control it. One "maximixes" the window (makes it take up the entire screen) and another "minimizes" the window (e.g. allows the user to set the size and shape by dragging the corners).

There are no longer these standard buttons on the Firefox window, meaning it has taken over a function that should be the domain of the user. I need to be able to control it. For example I would never have it cover the menu bar at the top of the screen!

In MacOS the button would yellow and have a "-" symbol. In Windows the symbol is a line.

Presumably there is some way to turn this behavior off, but I cannot find it. The default setting for this new "feature" should be "off" not "on". Wresting control from the user is very poor program etiquette. I suspect it is in violation of the Apple GUI guidelines.

I just remembered the minimize function is also available via the menu bar "window" option. I am astounded to discover the minimize option does not work!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Make sure you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

I found the answer. From the menu bar VIEW option there is a "Enter Full Screen" option that was checked. I unchecked this an all is well. Very odd that this is the default.