Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remember zoom per site no longer works in version 56

  • 2 பதிலளிப்புகள்
  • 8 இந்த பிரச்னைகள் உள்ளது
  • 797 views
  • Last reply by mizalinux

For many years, I've been using the great feature "zoom" to view websites, it was simply amazing that firefox would remember the zoom level of each individual site, so when I re-visited the sites would instantly appear great on my monitor.

Unfortunately, this worked up until firefox 54, once I upgraded to firefox 56, the zoom feature no longer remembers each websites zoom level :( now I have to manually re-zoom each site over and over again.

I know that there are plugins out there to do simulate this feature, but I don't trust 3rd-party plugins and I would prefer to have this feature native in firefox like before.

Thank you.


PS: I'm using Fedora 26 Linux, the affected package is: firefox-56.0-2.fc26.x86_64 and browser.zoom.siteSpecific is set to true (the default).

mizalinux மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I haven't tested the official version, but I did manage to trace the problem to this setting: privacy.resistFingerprinting

Apparently, the behavior of this setting changed from version 54 to 56 and now, when it is enabled, it disables browser.zoom.siteSpecific :(

Not exactly a solution to my problem but at least I know what caused this.

Oh well...

Read this answer in context 👍 2

All Replies (2)

Does this also happen with the Firefox version from the official Mozilla server? For issues with a version from the repositories toy need to contact the website of your distribution for support.

Make sure that you aren't using private browsing mode and that you aren't clearing the Site Preferences.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I haven't tested the official version, but I did manage to trace the problem to this setting: privacy.resistFingerprinting

Apparently, the behavior of this setting changed from version 54 to 56 and now, when it is enabled, it disables browser.zoom.siteSpecific :(

Not exactly a solution to my problem but at least I know what caused this.

Oh well...

mizalinux மூலமாக திருத்தப்பட்டது