Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox process remainds and cannot be killed by any means

  • 17 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Tonnes

Using Windows Vista. It happens many times. It becomes impossible to open any link. Nothing happens. Then closing Firefox a process remains. Using "end process" in task manager does not kill it and there is no message. Core dump from task manager attached.

All Replies (17)

(no attachment, I though I can but only images can be attached)

Please update FF to ver 54 and lets see if that helps you out. If this solves your problem please com back and let us know and mark as solved.

Be aware that it is possible it is one of your numerious plugins that is causing this issue and Ver 54 will disable some if not most of these. And you may still have to go through this process.

Thanks. How can I update to version 54? In the "About Firefox" window it says that my version 52.2.0 (32-bit) is the most up-to-date...

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive. Try to disable multi-process windows in Firefox to see if that has effect.

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Thanks cor-el. I have already tried all the above. Now I have uninstalled FF and deleted the program and data folders and reinstalled. Let's wait and see if it helps. Previous simple uninstall and reinstall did not help.

I have uninstalled FF and deleted the program and data folders and reinstalled. It did not help. It still happens. I have a core dump, can I attach it somehow and can someone do anything with it? Looks to me this is a bug. Is there any chance of getting a fix for Vista? Is there a chance of knowing when this has began and be able to install a certain previous version that works?

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

cor-el said

What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

I use Avira anti-virus. It would not be really feasible to try it in safe mode, because then I will have to work in safe mode for a whole day until this happens.

Personally I would create a new Firefox profile, see if that runs fine, and then copy the most important data from the current profile. Refreshing Firefox is another way of doing this.

When deleting Firefox’s program and data folders (manually?) as you described, note that there is also a caching folder involved (AppData\Local), and that the best way to remove profile data is to use the Profile manager as outlined in these articles. If not (and when using only one profile), some profile data may remain and make an issue persist. Of course, if you need to keep some data such as bookmarks, passwords etc., back up your current profile folder. Refreshing Firefox will do this automatically for you.

Another thing you could do is remove your Avira product entirely and reboot the system to see if that makes any difference to the current setup.

Note that Firefox 54 is no longer supported in Windows Vista, so that explains why 52 displays as up-to-date.

If nothing helps, when did the issue start occurring, and could you trace that back to a particular Firefox version?

Found it! What the heck were they thinking when making such an option the default?! See attached.

Thanks for feeding back. Does it also fix the issue of Firefox not responding to links? If so, could you please mark your reply as a solution?

I am now thinking that in the attached snapshot "the program" is or supposed to be only the anti-virus itself. So let's see if this is indeed the problem.

It was not that. Unchecking the options in Avira anti virus does not change the situation. Both the inability to end the process, and the reason to kill the process are there.

Some new idea: Maybe this has something to do with the fact that I have 2 Firefox running, each under a different Windows user? One is for work and one is for home use, and I am switching between them from time to time.

P.S. I am working with these 2 user accounts for years. That has never been a problem. So if this for itself is a problem, it must be due to recent changes in Firefox.

Unfortunately, that is not it either. I tried without having Firefox running for the other user.

Just some thoughts: note that if you deleted the data folders and reinstalled Firefox as a last step, multi-process will be enabled again in a new profile. Of course, make sure it is really disabled by checking about:support (Help > Troubleshooting Information) after changing the required preferences. Since several Vista users seem to have issues with multi-process (and resolved them this way), I would leave it disabled it while continuing to troubleshoot for a possible second cause of your problem.

If you can’t use Windows in its Safe Mode for a day, the alternative would be to temporarily remove Avira entirely instead. Don’t forget to reboot.

Multiple copies of Firefox for different user accounts should not be an issue at all.