X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox automatically downloads .exe files to Temp and opens them without prompting anything, help!

  • 13 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

Guys, I can't seem to find out the reasons for such behavior and the search returned nothing, can anyone help?

Guys, I can't seem to find out the reasons for such behavior and the search returned nothing, can anyone help?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

TornaD-oz said

in Safe Mode there is a prompt to save or cancel .exe downloads.

Firefox save or computer safe?

If Firefox; It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 2

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

உதவிகரமான பதில்

In "Options", .exe files are set to save. I have deleted any Malware present with ADWCleaner, but the issue persists - Firefox automatically saves and opens .exe files.

In "Options", .exe files are set to save. I have deleted any Malware present with ADWCleaner, but the issue persists - Firefox automatically saves and opens .exe files.
FredMcD
  • Top 10 Contributor
4272 தீர்வுகள் 59922 பதில்கள்
பதிவிடப்பட்டது

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

Deleting the '''mimeTypes.rdf''' will reset all download actions to the default settings. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the above file. Then rename or delete it. Restart Firefox.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks, FredMcD, I've located the file you mentioned, deleted it and restarted Firefox. The behavior didn't change, it's still downloading .exe files automatically to the Temp folder and launches them.

Thanks, '''FredMcD''', I've located the file you mentioned, deleted it and restarted Firefox. The behavior didn't change, it's still downloading .exe files automatically to the Temp folder and launches them.
FredMcD
  • Top 10 Contributor
4272 தீர்வுகள் 59922 பதில்கள்
பதிவிடப்பட்டது

What website is doing this? What is the name of the file?

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

What website is doing this? What is the name of the file? You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Every .exe file that can be downloaded is downloaded automatically and launched after that, regardless of the website or filename. I'll try the malware scanners next, thanks for the tip.

Every .exe file that can be downloaded is downloaded automatically and launched after that, regardless of the website or filename. I'll try the malware scanners next, thanks for the tip.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD, I've tried all the Malware Scanners mentioned in the article, they found some tracking cookies and some Malware in my "User.js" file, all of those being removed, the behavior persists.

The "Applications" tab in the Options now doesn't even list the .exe rule now, but nothing has changed.

'''FredMcD''', I've tried all the Malware Scanners mentioned in the article, they found some tracking cookies and some Malware in my "User.js" file, all of those being removed, the behavior persists. The "Applications" tab in the Options now doesn't even list the .exe rule now, but nothing has changed.
FredMcD
  • Top 10 Contributor
4272 தீர்வுகள் 59922 பதில்கள்
பதிவிடப்பட்டது

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ------------------ Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD, no, in Safe Mode there is a prompt to save or cancel .exe downloads.

'''FredMcD''', no, in Safe Mode there is a prompt to save or cancel .exe downloads.
FredMcD
  • Top 10 Contributor
4272 தீர்வுகள் 59922 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

TornaD-oz said

in Safe Mode there is a prompt to save or cancel .exe downloads.

Firefox save or computer safe?

If Firefox; It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

''TornaD-oz [[#answer-949734|said]]'' <blockquote> in Safe Mode there is a prompt to save or cancel .exe downloads. </blockquote> Firefox save or computer safe? If Firefox; It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FredMcD, after several minutes of detective work, I've managed to identify the suspect - it was the "Do It Automatically" extension. God knows how it got into my Firefox and silly me that didn't notice it in the Extensions this whole time.

Thanks for your great help, Fred!

'''FredMcD''', after several minutes of detective work, I've managed to identify the suspect - it was the "Do It Automatically" extension. God knows how it got into my Firefox and silly me that didn't notice it in the Extensions this whole time. Thanks for your great help, Fred!
FredMcD
  • Top 10 Contributor
4272 தீர்வுகள் 59922 பதில்கள்
பதிவிடப்பட்டது

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
James
  • Top 25 Contributor
  • Moderator
1602 தீர்வுகள் 11345 பதில்கள்
பதிவிடப்பட்டது

TornaD-oz said

it was the "Do It Automatically" extension. God knows how it got into my Firefox and silly me that didn't notice it in the Extensions this whole time.

You may have installed the extension sometime back. https://addons.mozilla.org/firefox/addon/do-this-automatically/

''TornaD-oz [[#answer-949833|said]]'' <blockquote>it was the "Do It Automatically" extension. God knows how it got into my Firefox and silly me that didn't notice it in the Extensions this whole time. </blockquote> You may have installed the extension sometime back. https://addons.mozilla.org/firefox/addon/do-this-automatically/
cor-el
  • Top 10 Contributor
  • Moderator
17585 தீர்வுகள் 159079 பதில்கள்
பதிவிடப்பட்டது

If you didn't uninstall/remove the extension, but only disabled it then you can check the extensions.json file for its install date.

If you didn't uninstall/remove the extension, but only disabled it then you can check the extensions.json file for its install date.