X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

In Firefox 50.0.2 I can't disable flashplayer anymore. How do I disable flash so it aks to be activated wen needed.

  • 5 replies
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Guido64
பதிவிடப்பட்டது

Since Firefox 5.0 I think i can't disable plashplayer anymore. The setting is still set to "ask to activate" but wen I enter a site with flash content it is played right away it doesn't ask anymore.

How do I fix this? So Flash is not started automatically anymore?

Since Firefox 5.0 I think i can't disable plashplayer anymore. The setting is still set to "ask to activate" but wen I enter a site with flash content it is played right away it doesn't ask anymore. How do I fix this? So Flash is not started automatically anymore?
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Also -- you may already be aware of this but just in case -- many sites now use Firefox's built-in HTML5 video player, so it might not be a Flash issue. Usually you can distinguish by right-clicking the player and checking the context menu. Flash's menu nearly always is short and mentions Flash somewhere.

The HTML5 video player doesn't have the same Ask to Activate permission setting, but there are some things you can do:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media*play and pause while the list is filtered

(3) To delay media from auto-starting in background tabs, I suggest: double-click the media.block-play-until-visible preference to switch the value from false to true

(4) To prevent media from auto-starting in any tabs: double-click the media.autoplay.enabled preference to switch the value from true to false -- this can cause some issues:

  • On some sites there is a strange side effect where Firefox starts buffering the video and blocks playback without changing the pause button back into a play button. So on those sites, when you do want to start the video, you have to click twice.
  • Some sites will assume you can't play HTML5 video and their player will just fail.
Read this answer in context 2

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Version 5.41.3.0
  • Google Update
  • MediaPlguin-v-3.3.2861.279101
  • Shockwave Flash 24.0 r0
  • 5.1.50901.0
  • npTimeGrid-v-3.1.0.295974
  • VLC media player Web Plugin
  • npIPCReg DLL - 3.1.0.10
  • npmedia-v-3.1.0.295974

பயன்பாடு

  • Firefox 50.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0.2/WINNT/nl/

நீட்சிகள்

  • ADB Helper 0.9.0 (adbhelper@mozilla.org)
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Valence 0.3.5 (fxdevtools-adapters@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 650
  • adapterDescription2:
  • adapterDeviceID: 0x0fc6
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY1 [ Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY2 [ Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ]
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 9-13-2014
  • driverDate2:
  • driverVersion: 9.18.13.4411
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
John99 971 தீர்வுகள் 13138 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Possibly this is because you are allowing Firefox to remember the setting for the site, so that when you visit a site a 2nd time FlashPlayer is activated. That can be changed for each individual domain by using the page-info button to navigate to the permissions (see lower down in this post).

 but wen I enter a site with flash content it is played right away 
 it doesn't ask anymore. 

I tested to check FlashPlayer was behaving as expected using http://www.bbc.co.uk/news and was interested to discover that now supports video apparently without the FlashPlayer plugin being used so is it either using HTML5 or a native embedded swf player.

Check with the Adobe Test page

I had not noticed before but the setting per site now seems to take precedence over the Plugin's settings in about:addons If I set Flash Player to never activate in about:addons It will still activate from a webpage such as adobe's page, if that is set to play.

Note these permissions may be checked from each individual domain's webpage's page info button on the left of the addressbar.

If you renamed permissions.sqlite whilst Firefox was closed Firefox would regenerate a file on restarting that would have default values. However you would have other changes, a better solution would be to edit the database itself to reset specific permissions.


P.S. Click on the Lego Brick icon on the left of the addressbar between the (i) button and the URL to see the FlashPLayer status.

Possibly this is because you are allowing Firefox to remember the setting for the site, so that when you visit a site a 2nd time FlashPlayer is activated. That can be changed for each individual domain by using the page-info button to navigate to the permissions (see lower down in this post). * see also [[Why do I have to click to activate plugins?#w_how-to-always-activate-a-plugin-for-a-trusted-website]]_how-to-always-activate-a-plugin-for-a-trusted-website but wen I enter a site with flash content it is played right away it doesn't ask anymore. I tested to check FlashPlayer was behaving as expected using http://www.bbc.co.uk/news and was interested to discover that now supports video apparently without the FlashPlayer plugin being used so is it either using HTML5 or a native embedded swf player. Check with the Adobe Test page * http://www.adobe.com/software/flash/about/ I had not noticed before but the setting per site now seems to take precedence over the Plugin's settings in ''about:addons'' If I set Flash Player to ''never activate'' in about:addons It will still activate from a webpage such as adobe's page, if that is set to play. Note these permissions may be checked from each individual domain's webpage's page info button on the left of the addressbar. * [[Page Info window - View technical details about the page you are on#w_activate-plugins]]'''_activate-plugins''' * The values themselves are not as easy to see they are in a database permissions.sqlite (May view with a suitable tool such as [https://addons.mozilla.org/firefox/addon/sqlite-manager/ SQLite Manager ] ) If you renamed ''permissions.sqlite'' whilst Firefox was closed Firefox would regenerate a file on restarting that would have default values. However you would have other changes, a better solution would be to edit the database itself to reset specific permissions. ------- P.S. Click on the ''Lego Brick'' icon on the left of the addressbar between the (i) button and the URL to see the FlashPLayer status.

John99 மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8787 தீர்வுகள் 71865 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Also -- you may already be aware of this but just in case -- many sites now use Firefox's built-in HTML5 video player, so it might not be a Flash issue. Usually you can distinguish by right-clicking the player and checking the context menu. Flash's menu nearly always is short and mentions Flash somewhere.

The HTML5 video player doesn't have the same Ask to Activate permission setting, but there are some things you can do:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media*play and pause while the list is filtered

(3) To delay media from auto-starting in background tabs, I suggest: double-click the media.block-play-until-visible preference to switch the value from false to true

(4) To prevent media from auto-starting in any tabs: double-click the media.autoplay.enabled preference to switch the value from true to false -- this can cause some issues:

  • On some sites there is a strange side effect where Firefox starts buffering the video and blocks playback without changing the pause button back into a play button. So on those sites, when you do want to start the video, you have to click twice.
  • Some sites will assume you can't play HTML5 video and their player will just fail.
Also -- you may already be aware of this but just in case -- many sites now use Firefox's built-in HTML5 video player, so it might not be a Flash issue. Usually you can distinguish by right-clicking the player and checking the context menu. Flash's menu nearly always is short and mentions Flash somewhere. The HTML5 video player doesn't have the same Ask to Activate permission setting, but there are some things you can do: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media*play''' and pause while the list is filtered (3) To delay media from auto-starting in background tabs, I suggest: double-click the '''media.block-play-until-visible''' preference to switch the value from false to true (4) To prevent media from auto-starting in any tabs: double-click the '''media.autoplay.enabled''' preference to switch the value from true to false -- this can cause some issues: * On some sites there is a strange side effect where Firefox starts buffering the video and blocks playback without changing the pause button back into a play button. So on those sites, when you do want to start the video, you have to click twice. * Some sites will assume you can't play HTML5 video and their player will just fail.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello John99 and jscher2000,

You were right the newest version of Firefox remember your choices if you allow flash or not. i don't want that i want to be asked everytime because one time i do need the flash player another time i don't. Since i don't trust flash i only want to run it wen absolutly needed.

I know about HTML5 player and right click to discover of its flash or not ;)

The behavior of the browser changed in the last new versions i geus zo i have to get to use to it. also other plugin have the same behavior i don't want always use surten plugins if i not need them i ant to be asked for it everytime.

I'm going to figure out how to set it so that it is nog saved anymore wen i do allow flash. I want the next time te be asked again. If you know how to configure this please let me know.

Thank you guys for clearing this up. I thought it was a bug in Firefox but it is not.

Hello John99 and jscher2000, You were right the newest version of Firefox remember your choices if you allow flash or not. i don't want that i want to be asked everytime because one time i do need the flash player another time i don't. Since i don't trust flash i only want to run it wen absolutly needed. I know about HTML5 player and right click to discover of its flash or not ;) The behavior of the browser changed in the last new versions i geus zo i have to get to use to it. also other plugin have the same behavior i don't want always use surten plugins if i not need them i ant to be asked for it everytime. I'm going to figure out how to set it so that it is nog saved anymore wen i do allow flash. I want the next time te be asked again. If you know how to configure this please let me know. Thank you guys for clearing this up. I thought it was a bug in Firefox but it is not.

Guido64 மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8787 தீர்வுகள் 71865 பதில்கள்
பதிவிடப்பட்டது

The "Allow Now" should forget after a while. I don't know how long "a while" is because I don't use a lot of sites that use Flash. If you want to have more control after clicking "Allow Now", try the following extension:

https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

I haven't tested it in a while but it might do what you want.

The "Allow Now" should forget after a while. I don't know how long "a while" is because I don't use a lot of sites that use Flash. If you want to have more control after clicking "Allow Now", try the following extension: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/ I haven't tested it in a while but it might do what you want.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Ow yes I see what you mean allow now or allow forever. Why didn´t i see that ;)

Thank you again, problem totaly solved now ;)

Ow yes I see what you mean allow now or allow forever. Why didn´t i see that ;) Thank you again, problem totaly solved now ;)