Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change desktop icon to open with firefox

  • 11 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 1654 views
  • Last reply by Happy112

Hello Everyone, I have opera as a backup browser only, but i had to reinstall firefox and after i did i noticed when i went to my desktop icon to see the video of the weather, it opened in opera, i want it to open in firefox like i use to have it open. any suggestions, Thank You

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi, try deleting the shortcut (right click > Delete) and creating a new one. Create a desktop shortcut to a website

Read this answer in context 👍 1

All Replies (11)

hi, you might have to set firefox as the default browser of your system again: Make Firefox your default browser

Thanks Philip, but i noticed it was already the default browser and the check mark was already in the box! what do you think i can try now? Thanks

you could see if it is making a difference when you set firefox as a default program within your windows control panel:

Default - Win8 pt 2

philipp மூலமாக திருத்தப்பட்டது

Thanks but it did not make a difference, then i did something dumb, i dragged the weather icon down and placed it on top of the firefox icon, now the weather icon is gone, what happens to an icon when you accidentally put one on top of the other, do you know?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hi, try deleting the shortcut (right click > Delete) and creating a new one. Create a desktop shortcut to a website

Scribe said

Hi, try deleting the shortcut (right click > Delete) and creating a new one. Create a desktop shortcut to a website

Scribe's absolutely right   ! But are you 100% sure that you made Firefox your default browser   ? Just   ' checking the box'   (3-bar menu > Options)   isn't enough;   there's one more   'click'  to go there. Did you do that   ? If so;   Firefox should definately be your default browser   ! Good luck   !

Thanks Guys, the delete and make a new icon worked great.

tomsff said

Thanks Guys, the delete and make a new icon worked great.

Yippee   !!! Thanks for letting us know   ! Have a lovely weekend   !

Hi   tomsff,
Inadvertently my answer has been marked   chosen solution,   while in fact it is  Scribe   who deserves the credit.
Would you please be a sweetheart and rectify that    ? Thanks in advance   !

Cheers,
Happy112.

Chosen Solution: Scribe, Thank You Very Much that did the trick.

tomsff said

Chosen Solution: Scribe, Thank You Very Much that did the trick.

That's sweet, but now: could you remove the   chosen solution   from my post and put it where it belongs   ?
I would do it,  but you see:  since your the Question Owner, only you can do it.
Would you, please   ?