Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

FIrefox Hangs on Start - No I/O

  • 14 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by John99

Frequently when I re-start Firefox (it seems to crash about once a day), the firefox exe process hangs with NO I/O. Firerfox does not even get to the point of asking me if I really want to start in safe mode. I tried getting a dump via the Task Manager, but taskmgr tells me "permission denied". Attached is a screen capture of the latest occurrence. This is the latest FF 46.0.1 on Windows 7 Professional 32-bit.

--Barry Finkel

Attached screenshots

All Replies (14)

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

This evening i did the following:

C:\Program Files>rename "Mozilla Firefox" Mozilla.Frefox.old

Download and re-install Firefox 46.0.1 .

I will check on each restart if FF starts and hangs with no I.O.

--Barry Finkel

I had a recurrence today with FF 47.0. I Exited FF prior to a Patch Tuesday reboot. FF crashed during the Exit process (seer another of my FF trouble tickets). When it restarted after the reboot, FF started and hung with no I/O, It had not gotten to the the point of displaying the message "Do you really want to start in safe mode?". When I tried to use the Task Manager to create a dump, taskmgr.exe said that I did not have permission. I have two screenshots of tabs in ProcessExplorer.

Note that I installed 47.0 via a regular FF update, replacing 46.0.1 .

--Barry Finkel

bsfinkel said

. . . . . I Exited FF prior to a Patch Tuesday reboot . . . .

If you do something like that, the program is not properly installed/updated. Go above and follow the instructions for Let’s do a full clean re-install;

I do not understand your reply"

"If you do something like that, the program is not properly installed/updated."

What did I do wrong? I updated FF via the normal method. I saw the window about the 47.0 update, and I followed the instruction to install the update and then re-started Firefox. If updating FF using this method is wrong, then why does FF suggest/allow this method? If a full install is the correct method, then FF should not suggest the method I used?

What I did today is standard procedure, I believe. In FF, before I rebooted, I clicked "File - Exit" to terminate FF. If I do not do this, then the reboot process will cancel the firefox.exe process, and the cancellation might leave the restore files in a bad state. Today, when I clicked "File - Exit", FF began its shutdown process, and during that process FF crashed.

--Barry Finkel

The way you described your actions, you stopped the updater before its work was done.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.


There were two actions at two DIFFERENT times. I updated FF from 46.0.1 to 47.0 on 06/08 at 8:22AM. I Exited FF prior to the Patch Tuesday reboot today (06/14) at 13:11. I have been running FF 47.0 since it was released on 06/08.

Here are my recent crash reports. Note that I have NOT cleared any crash reports.

Report ID Date Submitted bp-67c134d0-d482-4947-a90e-968762160614 6/14/2016 1:22 PM bp-4a0a07b0-7261-4910-87ba-0d2382160609 6/9/2016 3:04 PM b7d4d1c1-a160-48e4-b150-d3f31c65fc64 6/9/2016 3:01 PM bp-0e7778f3-7ebf-4eb8-b455-4aee42160608 6/7/2016 8:03 PM bp-6733752c-54d0-4219-bb18-0cc122160607 6/7/2016 12:01 AM bp-881e8251-d238-4b38-9602-c174d2160603 6/3/2016 8:23 AM bp-4f253176-e21e-4190-bb72-1f8c82160602 6/2/2016 1:37 PM bp-ecf62ebd-7c10-45a3-8603-892562160531 5/30/2016 8:31 PM

--Barry Finkel

Product Firefox Version 47.0 Build ID 20160604131506 Release Channel release OS Windows 7 OS Version 6.1.7601 Service Pack 1


Signature: shutdownhang | NtAllocateVirtualMemory

DropboxExt.34.dll = Dropbox

WRusr.dll = Webroot SecureAnywhere +++++++++++++++++++++++++++++++++++++++++++ bp-4a0a07b0-7261-4910-87ba-0d2382160609

Signature: shutdownhang | PLDHashTable::~PLDHashTable | mozilla::CSSVariableDeclarations::`scalar deleting destructor

DropboxExt.34.dll = Dropbox

WRusr.dll = Webroot SecureAnywhere +++++++++++++++++++++++++++++++++++++++++++ Product Firefox Version 46.0.1 Build ID 20160502172042 Release Channel release OS Windows 7 OS Version 6.1.7601 Service Pack 1


Signature: hang | BaseGetNamedObjectDirectory | MsgWaitForMultipleObjects | F_1152915508

Process Type plugin Shockwave Flash Version:

As I told you on another post, update / disable Webroot

I have temporarily disabled Webroot. I do not know if my three active trouble tickets are related, so I do not generally post the same status update on each trouble ticket. My (then-) recent crashes were posted to this trouble ticket because someone requested them. They are technically not part of this trouble ticket, as I have no real documentation on the problem other than what I see in the Task Manager. When I see a firefox .exe task in the hung state with no I/O, the Task Manager will not allow me to take a dump. I have .jpg images

    05/27 10:35
    06/14 14:30

and I disabled Webroot 06/15 13:29. I have not seen a recurrence since 06/14, so I cannot tell if Webroot is involved in this 0 I/O problem. I am about to update my other trouble tickets.

--Barry Finkel


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Fred, did you see the screenshot I posted when I opened this trouble ticket? Do you need another screenshot?

--Barry Finkel

That last post said; I have .jpg images

05/27 10:35
06/14 14:30

The 05/27 jpg was included in my initial problem report. TI posted two other images on 06/14 02:24PM Those are the only images I have on this problem. I see no need to get another image of the task manager showing 0 I/O counts. And one of the images from 06/14 shows a tab from ProcessExplorer; it shows the process hung at ntdll.dll!Rtl UserThreadStart . Is there another tab from ProcessExplorer that you need to see?

--Barry Finkel

I will close this thread. Multiple questions exist already as listed in /questions/1110344