Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla now is worse than dial up because it's so secure, you can no longer access the internet.

  • 8 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 20 views
  • Last reply by jscher2000

I get "This site is untrusted" Verifying and adding an exception takes about one minute. For Every Page Load! This make firefox on ultra-high-speed broadband now SLOWER than an apple ][e from 1980 on a 300 baud modem!

Solution? Delete firefox. There doesn't seem to be another one.

This is a problem with firefox on windows vista.

All Replies (8)

hi, this is not a normal behaviour & something is apparently tampering with or intercepting your encrypted connections. you shouldn't create manual exceptions in that situation but address the underlying issue - please see How to troubleshoot security error codes on secure websites

See also https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

The usual reasons for having trouble viewing secure connections in a version of Firefox if often due to a software Firewall, Antivirus (inserting its own certificate), or even the date/time is wrong on the computer.

If you can't inspect the certificate via Advanced (I Understand the Risks) then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website with the https:// protocol prefix (https://xxx.xxx).

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer with the issuer.

In your other thread you mentioned that Firefox thinks many sites are attack sites. Please run some malware scans in case your links are being hijacked. This article suggest free cleaning programs to supplement your regular security software: Troubleshoot Firefox issues caused by malware. Those programs are free and may take considerable time to run. If they finish quickly and especially if they demand payment before cleaning, your system may have a more serious infection. Please try one of the specialized malware forums listed in the article for help with that kind of problem.

Thanks everyone for your replies. I have a lot to try tomorrow, clearly.

I can clear a few things up and put some bugbears to bed first:

I'm sure it's not malware. Windows Vista runs so slowly that when you put out an atom machine like the Vaio P with Vista on it, it's like asking a Geo Metro to tow a tractor trailer. This also means that if there were any malware, it would grind to a halt.

The flaw in Vista is its memory manager, which has its priorities backwards, pushing content to disk cache, and why someone hasn't just put out a fix that reverts to the XP mem manager, IDK.

2) the machine has not been used in any way that would lead to a virus or malware, it handles data on a secure network, for a business, only now it doesn't, it handles it via a USB drive to a macbook, which is annoying, because it should be able to access the cloud directly.

Now, that said, something went wrong. It's clearly related to the Firefox update, and the fact that this is a Vista machine. If Vaio P didn't have so many device specific drivers on it, I'd just install a different OS, but there's that, and also I don't want to lose the software that is on it.

The reason I still use a Vaio P for this is that, on the go, I need something portable that I can type on, and the Vaio P beats a cell phone in that dept.

My apologies for the duplicate thread. My first one (this one) didn't appear until after the second thread was posted, because I never got the confirmation email, idk why, but I checked, and it said "sent" but it was never received (this is being written from my mac, since the vaio can't access the internet)

I tried adding acceptions, but i had to do it for every page, so google.com, gmail, any other google page, etc. and I still get the attack site. That's what I meant by "slower than dial up" <- that whole process takes about a minute and a half to get a page to load, and I have to go through it for every single page.

Now, the other issue is that everything was fine until this update, which came when I opened firefox, which auto-updated. I thought I'd turned all of that off.

I'm sure it will turn out that it is something that has been done to the security system protocol that creates some sort of short circuit in Vista, and yes, I know Vista is a sucky OS, and if I had a choice, but I don't. Anyway, I'll check back after I try some of this, thanks.

Jon

How much physical memory does that computer have?

Windows Vista should be much better when it comes to memory management than XP, but any OS will slow down to a crawl if there isn't enough free memory and the OS starts paging to disk. So if you are low on free memory then make sure to only start as less programs as possible and close down necessary software. A slower processor isn't as worse as an OS that needs to use the page file all the time.

You can use the MSConfig program or the Autoruns utility to see what software is getting started (be cautious with disabling services).

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

dreamtrove said

I tried adding acceptions, but i had to do it for every page, so google.com, gmail, any other google page, etc. and I still get the attack site.

Could you look at some of the exceptions you saved and see whether there is any pattern to the Issued by information for those certificates? You can call up the Certificate Manager on the Options page. Either:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced, then on the right side make sure the Certificates mini-tab is selected at the top. Finally, click View Certificates to launch the Certificate Manager.

In this dialog, click Servers. The ones where a * is listed as the server are built-in blockers, so ignore those and check the ones you think you have saved. Any pattern?