Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot by any suggested means change language from Greek to English (British)

  • 7 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 29 views
  • Last reply by cor-el

I had the misfortune to buy a laptop running Windows 10 in Greece (it was an emergency). When I downloaded Firefox, it turned out to be in Greek, and nothing seems able to change that

I have downloaded Firefox Setup 46.0 (British English) three times so far, and run it. My version stubbornly remains Greek. I have also downloaded and run the British English language pack, only to be told, when I next loaded Firefox, that it was incompatible with the current (presumably latest) version of Firefox ans was therefore being deleted.

Can anybody suggest anything sensible, before I erase this program and revert to a Microsoft product?

All Replies (7)

Hey there. This behaviour sounds odd to say the least, but there is an actual setting for this.

How to change the setting manually: https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack#w_how-to-change-the-language-of-the-user-interface. Having the value True for that setting might be the cause here, but the value should be False by default. When you flip the value, is it listed in bold or regular font?

You can find the full version of the current Firefox release (46.0) in all languages and all operating systems here:

Thanks, Phoxuponyou. That should have solved the problem, but sadly, it seems to be persistent.

When I followed step 1 of the manual setting procedure, I found that the intl.locale.matchOS preference was already set to FALSE, while the the general.useragent.locale preference was also already set to en-gb, presumably due to my earlier efforts (see image).

It's beginning to look as though the preference for Greek is hardwired? Can this even be possible?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Hello Akominatus, try to download from cor-el link, but do a Clean reinstall.

This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from above cor-el's link (it is the full installer) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29 ).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

Μάλλον δεν θα έχεις πρόβλημα και θα γίνει κανονικά η εγκατάσταση στην Αγγλική γλώσσα που θέλεις. :-)


Thank you.

Oy vey (sorry, I don't know any Greek sayings)... This definitely smacks of external interference, if the internal setting is correct. Did you try flipping it at least?

Fred raises a good point: something may have locked you into the language version or pack that was originally installed or selected by locking configuration files. Hopefully rummaging through the files, preferences and programs (and their kin) indicated in the KB article will provide relief; ideato has kindly described the clean reinstall procedure, if tweaking your profile is not enough.

Did you check the general.useragent.locale pref on the about:config page?


Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.