Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

YouTube does not load properly in Firefox, but does in other browsers.

  • 6 பதிலளிப்புகள்
  • 16 இந்த பிரச்னைகள் உள்ளது
  • 24293 views
  • Last reply by FredMcD

Yesterday or the day before, I tried going onto YouTube using Firefox, as I usually do, and this happened (see attached image). I tried clearing the cache and cookies, and restarted my whole computer, and nothing changed. Firefox loads all other websites I frequently use just fine, and Chrome works just fine with YouTube, but for some reason, Firefox and YT are not mixing right now. Anyone have any suggestions?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See also: Adblock Plus • View topic - [fixed][Malware Domains List issue] breaks YouTube layout:

Read this answer in context 👍 1

All Replies (6)

What is your computer system and Firefox? What happens when you try?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Safe Mode appears to have resolved it. I wonder if it is a problem with one of my add-ons?

Figured out that it was AdblockPlus that was causing it. I wonder how to fix that. I want to keep using ad blockers, but not if it makes YouTube act like shit.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See also: Adblock Plus • View topic - [fixed][Malware Domains List issue] breaks YouTube layout:

Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <web site>.