Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript always hangs Firefox, and none of the "solutions" offered (don't visit that site, don't use all the site's features)is acceptable.

  • 3 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 9 views
  • Last reply by jscher2000

The "solutions" offered do not begin even ADDRESS the problem. Problem is that Javascript always hangs Firefox, and the websites that use Javascript do not function fully if I block it using the Java blocker.

"Stop script" does not do anything but insult me for clicking it. Site still hangs. What is the purpose of a button that does not do anything?

"Debug script" does not "debug the script," it just shows me a bunch of code that does not mean anything to me.

I have visited this help site a bunch of times to try to solve this problem. Javascript and Firefox are both common platforms, SO WHY CAN'T THE TWO COME TO AN AGREEMENT TO WORK TOGETHER?

All Replies (3)

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 66 Release date November 16, 2015 http://java.com/en/download/manual.jsp

https://java.com/en/download/help/ Java Help Center

Do you have nvidia's network access manager or forceware network manager software installed? Disable / remove it. https://support.mozilla.org/en-US/kb/connectivity-crashing-firefox-43-update

I assume you already saw our general article on this: Warning Unresponsive script - What it means and how to fix it.

The unresponsive script dialog can appear for reasons unrelated to the site's own scripts, including (1) scripts that are part of an add-on (e.g., the Skype Click-to-call extension), and/or (2) interaction with the protected mode feature of the Flash plugin.

For #1, do you notice any pattern to the URLs of the unresponsive scripts? In particular, those that start with chrome:// indicate an internal Firefox script or an add-on script rather than a website script.

For #2, the protected mode feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.