Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open any web pages but gives no error message. It just flashes and then stays on the home tab.

  • 7 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 293 views
  • Last reply by streamfisher

I just upgraded to Windows 10 from Windows 7 on the same machine. Right at first Firefox worked ok but then it wouldn't load a web page anymore. I've uninstalled it several times, including the profile folder, but that had made no difference. Doesn't matter if you type in an address in the URL bar at the top or the search box on the home page, the screen just flashed really quickly and then is still on the default home page. Any help? Below is the text from the troubleshooting page. {

 "application": {
   "name": "Firefox",
   "version": "43.0.2",
   "buildID": "20151221130713",
   "userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0",
   "safeMode": false,
   "updateChannel": "release",
   "supportURL": "https://support.mozilla.org/1/firefox/43.0.2/WINNT/en-US/",
   "numTotalWindows": 1,
   "numRemoteWindows": 0,
   "remoteAutoStart": false
 },
 "modifiedPreferences": {
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.capacity": 1048576,
   "browser.cache.disk.filesystem_reported": 1,
   "browser.cache.frecency_experiment": 1,
   "browser.download.importedFromSqlite": true,
   "browser.places.smartBookmarksVersion": 7,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20151221130713",
   "browser.startup.homepage_override.mstone": "43.0.2",
   "browser.startup.homepage_override.buildID": "20151221130713",
   "dom.apps.reset-permissions": true,
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "43.0.2",
   "gfx.crash-guard.d3d11layers.appVersion": "43.0.2",
   "gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11": true,
   "gfx.direct3d.last_used_feature_level_idx": 1,
   "gfx.crash-guard.d3d11layers.feature-d3d11": true,
   "gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11": false,
   "gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp": false,
   "gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle": true,
   "gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle": true,
   "gfx.crash-guard.d3d11layers.feature-d2d": true,
   "gfx.crash-guard.status.glcontext": 2,
   "gfx.crash-guard.d3d11layers.driverVersion": "8.15.10.2900",
   "gfx.crash-guard.d3d11layers.deviceID": "0x0046",
   "gfx.crash-guard.status.d3d9video": 2,
   "gfx.crash-guard.status.d3d11layers": 2,
   "media.hardware-video-decoding.failed": false,
   "network.cookie.prefsMigrated": true,
   "places.history.expiration.transient_current_max_pages": 101870,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "privacy.sanitize.migrateFx3Prefs": true,
   "ui.osk.debug.keyboardDisplayReason": "IKPOS: Touch screen not found."
 },
 "lockedPreferences": {},
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 11",
   "windowLayerManagerRemote": true,
   "supportsHardwareH264": "Yes",
   "adapterDescription": "Intel(R) HD Graphics",
   "adapterVendorID": "0x8086",
   "adapterDeviceID": "0x0046",
   "adapterSubsysID": "10331462",
   "adapterRAM": "Unknown",
   "adapterDrivers": "igdumd64 igd10umd64 igdumdx32 igd10umd32",
   "driverVersion": "8.15.10.2900",
   "driverDate": "11-26-2012",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterSubsysID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "10.0.10586.0",
   "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_0 ps_4_0)",
   "info": {
     "AzureCanvasBackend": "direct2d 1.1",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d 1.1"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.10",
     "version": "4.10.10"
   },
   "NSS": {
     "minVersion": "3.20.2 Basic ECC",
     "version": "3.20.2 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.20.2",
     "version": "3.20.2"
   },
   "NSSSSL": {
     "minVersion": "3.20.2 Basic ECC",
     "version": "3.20.2 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.20.2 Basic ECC",
     "version": "3.20.2 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "extensions": [
   {
     "name": "HP Smart Web Printing",
     "version": "4.51",
     "isActive": false,
     "id": "smartwebprinting@hp.com"
   },
   {
     "name": "Media Player",
     "version": "1.1",
     "isActive": false,
     "id": "ext@MediaPlayerV1alpha5628.net"
   },
   {
     "name": "Media View",
     "version": "1.1",
     "isActive": false,
     "id": "ext@MediaViewV1alpha4415.net"
   },
   {
     "name": "Media View",
     "version": "1.1",
     "isActive": false,
     "id": "ext@MediaViewV1alpha2256.net"
   },
   {
     "name": "Media Watch",
     "version": "1.1",
     "isActive": false,
     "id": "ext@MediaWatchV1home9979.net"
   },
   {
     "name": "Norton Identity Safe",
     "version": "2015.5.6.86",
     "isActive": false,
     "id": "{C1A2A613-35F1-4FCF-B27F-2840527B6556}"
   },
   {
     "name": "Rich Media View",
     "version": "1.1",
     "isActive": false,
     "id": "ext@RichMediaViewV1release7812.net"
   },
   {
     "name": "Video Player",
     "version": "1.1",
     "isActive": false,
     "id": "ext@VideoPlayerV3beta10668.net"
   }
 ],
 "experiments": []

}

தீர்வு தேர்ந்தெடுக்கப்பட்டது

then please run a full scan of your system with different security tools like the free version of malwarebytes, adwcleaner, microsoft safety scanner & kaspersky security scan as well. many extensions in your profile folder appear to be malicious...

Read this answer in context 👍 0

All Replies (7)

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

hi, please go into the programs section of your system control panel and uninstall nvidia forceware network access manager in case you have that present.

Connectivity or crashing issues after Firefox 43 update

I have tried both of these ideas but neither worked. Anything else? And thanks for the replies!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

then please run a full scan of your system with different security tools like the free version of malwarebytes, adwcleaner, microsoft safety scanner & kaspersky security scan as well. many extensions in your profile folder appear to be malicious...

I have Norton installed already. Would those programs you mentioned do a better job than what I already have?

Malware programs need deep probing scanners to be found.

philipp said

then please run a full scan of your system with different security tools like the free version of malwarebytes, adwcleaner, microsoft safety scanner & kaspersky security scan as well. many extensions in your profile folder appear to be malicious...

Thanks for suggesting that I run one of these programs, Phillipp! I used adwcleaner and it found one thing which when it was cleaned up allowed Firefox to run normally! Thanks again! I was not enjoying using Edge!