X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Disable tabs being placed one over another

  • 17 replies
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

I ofter work with lots of tabs, and I have to say, this 'feature' is pretty annoying.

To see what I'm talking about, see this comparison image: http://i.imgur.com/GviGxyG.png?1

I ofter work with lots of tabs, and I have to say, this 'feature' is pretty annoying. To see what I'm talking about, see this comparison image: http://i.imgur.com/GviGxyG.png?1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Intel web components updater - Installs and updates the Intel web components
  • GEPlugin
  • Google Update
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 20.0 r0

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

கூடுதல் தகவல்

jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

Are those "pinned" tabs which show only the icon by default, or are you using an add-on to modify how regular tabs appear?

Pinned Tabs - keep favorite websites open and just a click away

Well, either a custom style rule or add-on would be needed to modify the sides of the tabs from curved to straight...

Are those "pinned" tabs which show only the icon by default, or are you using an add-on to modify how regular tabs appear? [[Pinned Tabs - keep favorite websites open and just a click away]] Well, either a custom style rule or add-on would be needed to modify the sides of the tabs from curved to straight...
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I never use pinned tabs. It's all addons.

I never use pinned tabs. It's all addons.
jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

Could you be more specific about what the add-ons are? Also, Firefox 43 enforces the requirement for extensions to be signed. If an unsigned extension was responsible for changing the tab appearance, it may need to be updated.

You can review your extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. On the right side, enabled extensions are listed first in alpha order, then the disabled extensions below those.

Could you be more specific about what the add-ons are? Also, Firefox 43 enforces the requirement for extensions to be signed. If an unsigned extension was responsible for changing the tab appearance, it may need to be updated. You can review your extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. On the right side, enabled extensions are listed first in alpha order, then the disabled extensions below those.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Classic Theme Restorer, Custom Tab Width and Remove New Tab Button.

Classic Theme Restorer, Custom Tab Width and Remove New Tab Button.
jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

Okay, I don't use any of those.

Can you verify that they are all up-to-date? One method is to use the update checker on the Add-ons page. Above the list is a "gear" button, click that and then Check for Updates.

Some of those extensions have settings; perhaps they need some tweaking. Usually for that there is an Options button for the specific extension (to the left of the Disable button).

Okay, I don't use any of those. Can you verify that they are all up-to-date? One method is to use the update checker on the Add-ons page. Above the list is a "gear" button, click that and then Check for Updates. Some of those extensions have settings; perhaps they need some tweaking. Usually for that there is an Options button for the specific extension (to the left of the Disable button).
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

All the addons are up to date.

And unfortunately, there doesn't seem to be anything relevant in the addon options.

All the addons are up to date. And unfortunately, there doesn't seem to be anything relevant in the addon options.
jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

What if you undo and redo the settings. So maybe it's in Classic Theme Restorer where you are suppressing the text on the tab? Try turning that back on and reselecting the shape of the tab, since it doesn't look as square as the one you have in the other image. Once the tab shape/margins look correct, try removing the text again.

What if you undo and redo the settings. So maybe it's in Classic Theme Restorer where you are suppressing the text on the tab? Try turning that back on and reselecting the shape of the tab, since it doesn't look as square as the one you have in the other image. Once the tab shape/margins look correct, try removing the text again.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The second image is not taken from the browser I'm currently using, but from a pre-Australis Firefox, where everything worked just fine without having to use Classic Theme Restorer (for obvious reasons).

Unfortunately, I was unable to reproduce the style of the old browser using Classic Theme Restorer. I do plan to do some more tweaking and make the tabs look as they did in the old browser later on, but I'd like to solve the problem at hand first.

"So maybe it's in Classic Theme Restorer where you are suppressing the text on the tab?"

No, that's just Custom Tab Width doing its job. Minimum size is set at 25px. And the smaller the tabs become, the bigger the overlap...

The second image is not taken from the browser I'm currently using, but from a pre-Australis Firefox, where everything worked just fine without having to use Classic Theme Restorer (for obvious reasons). Unfortunately, I was unable to reproduce the style of the old browser using Classic Theme Restorer. I do plan to do some more tweaking and make the tabs look as they did in the old browser later on, but I'd like to solve the problem at hand first. "So maybe it's in Classic Theme Restorer where you are suppressing the text on the tab?" No, that's just Custom Tab Width doing its job. Minimum size is set at 25px. And the smaller the tabs become, the bigger the overlap...
jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

If you don't find a solution, maybe I can install those extensions next week.

If you don't find a solution, maybe I can install those extensions next week.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The same behavior persists even with Classic Theme Restorer disabled.

I guess it's just how those huge rounded Australis tabs work... They're so big that the developers had to code in some overlapping to reduce space. But unfortunately, when reducing the tab width to a size unintended by the developers, the tabs end up overlapping each other in a really annoying way.

And of course, the developer of Classic Theme Restorer didn't bother to remove the overlapping either...

The same behavior persists even with Classic Theme Restorer disabled. I guess it's just how those huge rounded Australis tabs work... They're so big that the developers had to code in some overlapping to reduce space. But unfortunately, when reducing the tab width to a size unintended by the developers, the tabs end up overlapping each other in a really annoying way. And of course, the developer of Classic Theme Restorer didn't bother to remove the overlapping either...
cor-el
  • Top 10 Contributor
  • Moderator
17677 தீர்வுகள் 159899 பதில்கள்
பதிவிடப்பட்டது

Classic Theme Restorer has settings for the tab appearance, so you can check out its settings. This extension also has a setting for the width of a tab, so you may not need the Custom Tab Width extension.

Classic Theme Restorer has settings for the tab appearance, so you can check out its settings. This extension also has a setting for the width of a tab, so you may not need the Custom Tab Width extension.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I've tried disabling Custom Tab Width, but it's even worse. Certainly, Classic Theme Restorer does its job and reduces the tab width to 25px, but it places the tab icon to the right of the tab, where the right border is 'eating' the icon. Whereas with Custom Tab Width enabled, the icon is positioned correctly, in the middle of the tab.

Fortunately there don't seem to be any side effects from running the two addons at the same time, since it seems Firefox gives priority to Custom Tab Width over Classic Theme Restorer for some reason.

I've tried disabling Custom Tab Width, but it's even worse. Certainly, Classic Theme Restorer does its job and reduces the tab width to 25px, but it places the tab icon to the right of the tab, where the right border is 'eating' the icon. Whereas with Custom Tab Width enabled, the icon is positioned correctly, in the middle of the tab. Fortunately there don't seem to be any side effects from running the two addons at the same time, since it seems Firefox gives priority to Custom Tab Width over Classic Theme Restorer for some reason.

BurningFox மூலமாக திருத்தப்பட்டது

Scribe 734 தீர்வுகள் 3498 பதில்கள்
பதிவிடப்பட்டது

Hi, try this: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.tabs.tabClipWidth then right click > Modify, and enter a smaller number - try 80 as a starting point.

Hi, try this: Type '''about:config''' into the address bar, press Enter, accept the warning, scroll down to '''browser.tabs.tabClipWidth''' then right click > Modify, and enter a smaller number - try 80 as a starting point.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I've set it to 80, 25, 0 and 999. Nothing changed.

I've set it to 80, 25, 0 and 999. Nothing changed.

BurningFox மூலமாக திருத்தப்பட்டது

Scribe 734 தீர்வுகள் 3498 பதில்கள்
பதிவிடப்பட்டது

It should work, so try temporarily disabling your add-ons and any theme (Ctrl+Shift+A) in case they are interfering.

It should work, so try temporarily disabling your add-ons and any theme (Ctrl+Shift+A) in case they are interfering.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Anyway, I managed to obtain the desired effect (somewhat) by using an addon called PreventTabOverflow.

Unfortunately if offers 3 tab size presets, and the smallest size available is only 40px...

I tried editing the addon and changed the 40px setting to 25px. It worked, but guess what: the tabs started overlapping...

Anyway, I managed to obtain the desired effect (somewhat) by using an addon called PreventTabOverflow. Unfortunately if offers 3 tab size presets, and the smallest size available is only 40px... I tried editing the addon and changed the 40px setting to 25px. It worked, but guess what: the tabs started overlapping...
jscher2000
  • Top 10 Contributor
8837 தீர்வுகள் 72222 பதில்கள்
பதிவிடப்பட்டது

Hi BurningFox, I was traveling for a couple weeks, so just saw your reply now. Maybe you could suggest to the author of the PreventTabOverflow extension to support a smaller size...

Hi BurningFox, I was traveling for a couple weeks, so just saw your reply now. Maybe you could suggest to the author of the PreventTabOverflow extension to support a smaller size...