X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

why can't I access my add-ons

  • 19 replies
  • 6 இந்த பிரச்னைகள் உள்ளது
  • Last reply by FredMcD
பதிவிடப்பட்டது

When I click the add-on button Firefox opens on a blank page with my add-on links on the left hand side. It opens selecting 'get add-ons' and all that shows is a box saying 'loading' and the rotating icon. They never load. Going down the links the next is 'extensions' resulting in a blank page and nothing else. Next is appearance where it show's a default and 3 other inactive links. Finally plugins where nothing seems wrong. All there as I remember. Some of my extensions seem to be working properly but others don;t How can I access these extensions and how do I get onto the add-on page?

When I click the add-on button Firefox opens on a blank page with my add-on links on the left hand side. It opens selecting 'get add-ons' and all that shows is a box saying 'loading' and the rotating icon. They never load. Going down the links the next is 'extensions' resulting in a blank page and nothing else. Next is appearance where it show's a default and 3 other inactive links. Finally plugins where nothing seems wrong. All there as I remember. Some of my extensions seem to be working properly but others don;t How can I access these extensions and how do I get onto the add-on page?

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Adobe PDF Plug-In For Firefox and Netscape
  • Google Update
  • NMP Browser Plugin 2.8.0.0
  • LastPass Plugin
  • Shockwave Flash 20.0 r0
  • 5.1.41105.0
  • NPWLPG

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

கூடுதல் தகவல்

cor-el
  • Top 10 Contributor
  • Moderator
17690 தீர்வுகள் 160039 பதில்கள்
பதிவிடப்பட்டது

It is possible that there is a problem with files in the profile folder that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this didn't help then delete addons.json and possibly prefs.js in case there is a problem with preferences.

You can use this button to go to the current Firefox profile folder:

It is possible that there is a problem with files in the profile folder that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available. If this didn't help then delete addons.json and possibly prefs.js in case there is a problem with preferences. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I hope these screen shots help.

I hope these screen shots help.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17690 தீர்வுகள் 160039 பதில்கள்
பதிவிடப்பட்டது

Did you check for issues with the extensions files in the profile folder like I posted above?

Did you check for issues with the extensions files in the profile folder like I posted above?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

As I said before some are working some not it's only visibility that's the problem. If I turn them off and start in safe mode and it doesn't change how do I turn them back on. I am not very experienced with computer workings only a tinkerer.

As I said before some are working some not it's only visibility that's the problem. If I turn them off and start in safe mode and it doesn't change how do I turn them back on. I am not very experienced with computer workings only a tinkerer.
cor-el
  • Top 10 Contributor
  • Moderator
17690 தீர்வுகள் 160039 பதில்கள்
பதிவிடப்பட்டது

This is likely a problem with the extensions.* files in the Firefox profile folder, so you would have to check this out.

You can use this button to go to the current Firefox profile folder:

Note that "AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu or have the File type column visible.

This is likely a problem with the extensions.* files in the Firefox profile folder, so you would have to check this out. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox Note that "AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder. *http://kb.mozillazine.org/Show_hidden_files_and_folders Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows Explorer via the right-click context menu or have the File type column visible.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

As already stated I am not very experienced with computer workings only a tinkerer. cor-el I thank you for your help but this is a little deep and before I thy it I need to make sure I have back-ups to do first in the next few days. My problem is not presently causing difficulties so I am not going to rush into an area I'm not comfortable with.

As already stated I am not very experienced with computer workings only a tinkerer. cor-el I thank you for your help but this is a little deep and before I thy it I need to make sure I have back-ups to do first in the next few days. My problem is not presently causing difficulties so I am not going to rush into an area I'm not comfortable with.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

Do not worry. Those files will be re-created by Firefox.

Do not worry. Those files will be re-created by Firefox.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank you cor-el and FredMcD. I have done nothing with this due to personal problems at home and as most of the add-on were working I didn't rush to try your suggestions but an update on Facebook yesterday took care of that and wiped all my customization and add-ons so now I do have to do something. Will let you know the result.

Thank you cor-el and FredMcD. I have done nothing with this due to personal problems at home and as most of the add-on were working I didn't rush to try your suggestions but an update on Facebook yesterday took care of that and wiped all my customization and add-ons so now I do have to do something. Will let you know the result.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

An update on Facebook should not affect Firefox.

An update on Facebook should not affect Firefox.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Sorry I meant Firefox.

Sorry I meant Firefox.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Are you saying you updated Firefox, and lost your profile?

Look on your desktop. Do you see a folder called; Old Firefox?

https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Are you saying you updated Firefox, and lost your profile? Look on your desktop. Do you see a folder called; '''Old Firefox?''' '''https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile''' '''https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles'''
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I think I found this problem. The update didn't cause loss of anything. What it did was turned off the add-on toolbar at the bottom of the page and what confused me was the Icon for add-on called Autofill forms was repositioned. It's usually in that toolbar.

I think I found this problem. The update didn't cause loss of anything. What it did was turned off the add-on toolbar at the bottom of the page and what confused me was the Icon for add-on called Autofill forms was repositioned. It's usually in that toolbar.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

Do you mean the add-ons bar at the bottom of the Firefox windows? The add-on bar was removed during one update by Mozilla for reasons no one understands. In some cases leaving lots of icons homeless.

Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for an add-on bar.

Many of us are using; Classic Theme Restorer (Customize Australis) {web link} Restore squared tabs, appmenu, add-ons bar, small button view and more on Australis UI (Windows/MacOSX/Linux + Fx 29+).

This will restore many of the things the last upgrades took away.

http://forums.mozillazine.org/viewtopic.php?f=48&t=2827985 Classic Theme Restorer - Discussion Thread (v2)

Do you mean the add-ons bar at the bottom of the Firefox windows? The add-on bar was removed during one update by Mozilla for reasons no one understands. In some cases leaving lots of icons homeless. Go to the '''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''' {web link} (There’s a lot of good stuff here) and search for an add-on bar. Many of us are using; '''[https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ Classic Theme Restorer (Customize Australis)]''' {web link} Restore squared tabs, appmenu, add-ons bar, small button view and more on Australis UI (Windows/MacOSX/Linux + Fx 29+). This will restore many of the things the last upgrades took away. '''http://forums.mozillazine.org/viewtopic.php?f=48&t=2827985''' Classic Theme Restorer - Discussion Thread (v2)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

no. the add-on bar was turned off by the update. all I did was turn it on again. This is the second time this has happened.Classic theme restorer is one of my original add-on that I can't access which started this question thread.

no. the add-on bar was turned off by the update. all I did was turn it on again. This is the second time this has happened.Classic theme restorer is one of my original add-on that I can't access which started this question thread.
FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

You should be able to access it's settings thru the Add-ons Manager.

You should be able to access it's settings thru the Add-ons Manager.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

My original post started "When I click the add-on button Firefox opens on a blank page with my add-on links on the left hand side. It opens selecting 'get add-ons' and all that shows is a box saying 'loading' and the rotating icon. They never load. Going down the links the next is 'extensions' resulting in a blank page and nothing else" This is the add-on manager you mention and I have already it doesn't allow access. I am starting to feel as if we have gone full circle. I will try your solution in the next few days and let you know the outcome.

My original post started "When I click the add-on button Firefox opens on a blank page with my add-on links on the left hand side. It opens selecting 'get add-ons' and all that shows is a box saying 'loading' and the rotating icon. They never load. Going down the links the next is 'extensions' resulting in a blank page and nothing else" This is the add-on manager you mention and I have already it doesn't allow access. I am starting to feel as if we have gone full circle. I will try your solution in the next few days and let you know the outcome.

dexrek மூலமாக திருத்தப்பட்டது

FredMcD
  • Top 10 Contributor
4308 தீர்வுகள் 60512 பதில்கள்
பதிவிடப்பட்டது

Type chrome://mozapps/content/extensions/extensions.xul?<enter> in the address bar. Are the add-ons displayed? Disable Everything. Then restart Firefox. Is the manager working not?

Type '''chrome://mozapps/content/extensions/extensions.xul?'''<enter> in the address bar. Are the add-ons displayed? Disable '''Everything.''' Then restart Firefox. Is the manager working not?