Search Support

Firefox fails to go full screen - tabs & URL still visible

  • 4 பதிலளிப்புகள்
  • 12 இந்த பிரச்னைகள் உள்ளது
  • 119 views
  • Last reply by cor-el

I cannot get Firefox to go full screen. The URL bar and the tabs always remain, only the menus hide correctly.

Toolbars are already set to hide, browser.fullscreen.autohide setting is true, and restart in Safe Mode did nothing.

Can you think of anything else I should try? Would be great to finally enjoy a true full screen Firefox.

All the best

All Replies (4)

¡Hola!

I believe you've disabled "Hide Toolbars" in "Full screen mode".

Please follow How to make Firefox and websites go full screen then right click on an empty section of the tabs area, just right to _ [ ] X buttons on the Firefox window, and check "Hide Toolbars".

Let us know if this works.

¡Gracias!

@ Alex: Thanks for the reply. Hide toolbars was already activated. That's why I was flustered. So was the autohide setting in config.

@cor-el: I don't understand why the default behavior of FF is so unexpected. Would have thought something akin to the add-on you recommended should be the built-in standard behavior of FF.

The developers seem to think that showing toolbars is a convention on Mac that takes prevalence over the Full Screen mode behavior on Windows and Linux.

  • bug 1066282 - Turn FullScreen.useLionFullScreen into a about:config pref
  • bug 1016361 - [UX] Design for a toolbar-less fullscreen mode on Mac

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

You can vote for a bug to show your interest
https://bugzilla.mozilla.org/page.cgi?id=voting.html