Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why isn't Firefox browser version 42 compatible with Java Version J8U65 and Windows 10?

  • 2 பதிலளிப்புகள்
  • 10 இந்த பிரச்னைகள் உள்ளது
  • 68 views
  • Last reply by shirleyone

Games played on Pogo.com and IWin.com are slow, crash, jerky and erratic. Games load larger than screen and cannot be adjusted.

All Replies (2)

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 65 Release date October 20, 2015 http://java.com/en/download/manual.jsp

So sorry, but this doesn't answer the question. Pogo.com is posting this at the top of their games:

Firefox browser version 42 is not working well with Java Version J8U65. We recommend using the latest version of Internet Explorer 11

I haven't updated to 42 for the reason above. Many of us do Pogo games on their site. My question is:

Is Firefox browser version 42 compatible with Java version J8U65 and Java Version J8U66?

Thank you for your research and answering this question.  :-)