Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my history will not delete

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by happy80

I try to delete my history via the normal method and when checked, it did not do anything, everything is still there.

All Replies (14)

You can check for problems with the places.sqlite database file (bookmarks, history) in the Firefox profile folder.

If the Places Maintenance extension can't repair the places.sqlite database file then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database file from the most recent JSON backup in the bookmarkbackups folder.

removing the places file only works to remove the previous history. Once I browse and create a history it will not delete again unless I go in and delete the places file again. What else could this be?

What specific history are you trying to delete?

Is this probably the location bar history?

What ways are you using to delete the history?

I am using the normal clear history function (control+shift+del). I have "everything" in the time range to clear. All the boxes are checked, then I select clear. I close out Firefox. I then open it back up and check my history and everything is still there like I never cleared it. The only way I have gotten results is the original way you described, but that is the only way to clear the history. After, it operates just like before.

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

The machine I'm having problems with is an old xp laptop. to my knowledge I do not have any such programs. I noticed all my machine just recently did an update. None of the other computers I use are having this problem so i doubt it was due to the update.

Do you still see history in the History Manager (Library) after you have cleared the history?

You aren't running Firefox in Private Browsing mode?

Is this only abut history or also about other kinds of data (cookies, disk cache)?

Note that Firefox stores session data in the sessionstore.js file, so if you close Firefox with tabs still open then you create new history items on the next start as there is no cache as well.

I see all the places I have been in the History drop down menu. Im not sure if that is what you mean. I am now using the Private Browsing mode since I can't fix my problem. I am after being able to delete everything easily in the History drop down menu as I always did. If I use the browser out of Private mode it store the locations and the only way to delete is to go in and delete the places.sqlite files. That is the only way I can delete them. The normal History drop down menu does not seem to actually delete anything. Unfortunately I'm not so savvy with computers so I do not understand what your last sentence is stating. Thank you everyone for trying to help. This is a very annoying issue.

I am having the same problem..I have tried to delete my browsing history in the normal says my cache is currently using 5.5 mb and that won't clea either. I uninstalled firefox and reinstalled it..twice...rebooted the computer and the history is still there. As far as I know, I am not using in private browsing. I have been really having trouble with flash this last week or was trying to clear everything in hope that it would start working right. When I ran my Spybot was scanning Firefox browser, even though it had been deleted from the computer..??? Everything including the old firefox data file...did not show up in the programs and features..what can I do. Spybot and Windows defender both came up as no problems found. I tried the first suggestion, added places is there, but doesn't have a button to get it to do anything???? help. I will try the next protection and see if that works. Any suggestion are appreciated. Merry Christmas all.

Make sure that you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

rechecked again and found that I had somehow clicked custom instead of never remember that's fixed....still trouble with flash..slowness and crashing. Thanks.

Some of your crash reports weren’t sent to the Mozilla Servers.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.


hasnfefr said

I try to delete my history via the normal method and when checked, it did not do anything, everything is still there.

hasnfefr said

I try to delete my history via the normal method and when checked, it did not do anything, everything is still there.

I had the same problem tried all sorts of ways and it just jammed up saw couple answers in the forum but they didn't work

so I tried again clicked on the days I wanted to delete but a black screen came up which was happening before I clicked on this and microsoft came up and said firefox not responding will search and look for a solution , so I just left it like that and eventually microsoft solved and and it was deleted , I did this for all the history some of it was last years so have a go and see it it does it for you