Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

New Tab Button is Re-Located

  • 21 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 43 views
  • Last reply by cor-el

For some reason the "new tab" button was relocated all the way to the right of the screen as shown in the below screenshot. How do I move it back to the old setting where it used to be right next to the open tab?

Attached screenshots

All Replies (20)

Type about:customizing<Enter> in the address bar. In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but some icons are locked in place.

If you can, try dragging the gear icon to the right of the + icon and the downward-pointing triangle that usually is next to it and see whether that works better.

Try to click the Restore Defaults button in the Customize palette if you can't swap the two buttons at the right end of the Tab bar.

  • "3-bar" menu button > Customize
  • View > Toolbars > Customize

jscher2000 said

If you can, try dragging the gear icon to the right of the + icon and the downward-pointing triangle that usually is next to it and see whether that works better.

I tried that but nothing happened it stays the same

cor-el said

Try to click the Restore Defaults button in the Customize palette if you can't swap the two buttons at the right end of the Tab bar.
  • "3-bar" menu button > Customize
  • View > Toolbars > Customize

I also tried this and it didn't work

What is that cogwheel button to the left of the plus?

Is that added by an extension?

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

cor-el said

What is that cogwheel button to the left of the plus? Is that added by an extension? Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

No that's just the Firefox settings. No addons it's just brings you to the settings.

What does it look like now after using Restore defaults?

jscher2000 said

What does it look like now after using Restore defaults?

It is the same setup I had before except without the menu bar, or the bookmarks bar.

Try to reset the browser.uiCustomization.state pref on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

cor-el said

Try to reset the browser.uiCustomization.state pref on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

I reset it and nothing happened all of my customized tool bars are still there... and so is the new tab button

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

cor-el said

Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Still no

Can you drag the plus button to another position while in customize mode?

Try to drag the plus button to the palette window and leave customization mode to see if that stays. Close and restart Firefox for further testing.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

cor-el said

Can you drag the plus button to another position while in customize mode? Try to drag the plus button to the palette window and leave customization mode to see if that stays. Close and restart Firefox for further testing.

I can put it everywhere but where I want it to go. That is my problem here. And what do you mean by "Palette Window"?

That is the "Additional Tools and Features" window where the buttons that aren't on a toolbar are positioned that you see when you enter customization mode.

What happens if you remove the preferences icon from the Tab bar or possibly position the preferences button at the far left?

Does that allow to drop the plus next to the last tab?

cor-el said

That is the "Additional Tools and Features" window where the buttons that aren't on a toolbar are positioned that you see when you enter customization mode. What happens if you remove the preferences icon from the Tab bar or possibly position the preferences button at the far left? Does that allow to drop the plus next to the last tab?

Sorry for the late reply I've been really busy lately. When I go there and I drag the plus to the last tab, it snaps back to the end of the page, as shown in the attached pictures.

Did you close and restart Firefox in between the screenshots or at least closed the customization window?

Did you try to click the Restore Defaults button?

cor-el said

Did you close and restart Firefox in between the screenshots or at least closed the customization window? Did you try to click the Restore Defaults button?

Yes, i already tried that.

  1. 1
  2. 2