X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox won't display .swf files

  • 18 replies
  • 6 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Amenephis
பதிவிடப்பட்டது

Hello,

Everything was running completely fine in Firefox and then all of a sudden it simply stopped displaying .swf files. Where they should be is simply blank. On websites with a background I can see the background through where the .swf file should be. This includes opening locally saved files as well as every website with a .swf file that's supposed to play.

I do mean suddenly quite literally, as it was right in the middle of a browsing session. I changed nothing, just...one minute they were working fine, the next they completely halted. It's clear the program is recognizing that something's supposed to be there, as Adblock pops up a little "Block" tab over where the file should be, but again, that space is completely blank. It's not black, it's transparent.

I've completely uninstalled Shockwave and reinstalled it from scratch, and "updated" it three times now, all to no effect.

Hello, Everything was running completely fine in Firefox and then all of a sudden it simply stopped displaying .swf files. Where they should be is simply blank. On websites with a background I can see the background through where the .swf file should be. This includes opening locally saved files as well as every website with a .swf file that's supposed to play. I do mean suddenly quite literally, as it was right in the middle of a browsing session. I changed nothing, just...one minute they were working fine, the next they completely halted. It's clear the program is recognizing that something's supposed to be there, as Adblock pops up a little "Block" tab over where the file should be, but again, that space is completely blank. It's not black, it's transparent. I've completely uninstalled Shockwave and reinstalled it from scratch, and "updated" it three times now, all to no effect.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Adobe PDF Plug-In For Firefox and Netscape 15.8.20082
  • PlayNow Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2
  • 5.1.40728.0
  • VLC media player Web Plugin
  • NPWLPG
  • iTunes Detector Plug-in

பயன்பாடு

  • Firefox 40.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • Support URL: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

நீட்சிகள்

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • EPUBReader 1.5.0.6.1-signed ({5384767E-00D9-40E9-B72F-9CC39D655D6F})
  • Trend Micro BEP Firefox Extension 7.0.0.1081 ({38783831-6098-4faa-A9C9-1EE1E343F4D2}) (Inactive)
  • Trend Micro NSC Firefox Extension 6.8.0.1072 ({22C7F6C6-8D67-4534-92B5-529A0EC09405}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 10cb1462
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 9-26-2012
  • driverDate2:
  • driverVersion: 9.17.10.2867
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello,

Thank you for your response. I ran your fix, and the exact same issue still presented identically in Safe Mode as in normal operations. I attempted to load websites with embedded .swf files, and I also attempted to run files saved on my computer. All had the same problem still.

Hello, Thank you for your response. I ran your fix, and the exact same issue still presented identically in Safe Mode as in normal operations. I attempted to load websites with embedded .swf files, and I also attempted to run files saved on my computer. All had the same problem still.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

The fact that the issue still occurs while in safe mode tells me that the issue is most likely not caused by an add-on that has been installed on Firefox.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


If the above does not solve the issue, can you please test to see if the Adobe Flash file will load in the default Internet Explorer that is included with your version of Windows? Tests cannot be run from Google Chrome, as Chrome comes with a built-in flash player and cannot be used to determine whether there is an issue with flash on your computer.

The fact that the issue still occurs while in safe mode tells me that the issue is most likely not caused by an add-on that has been installed on Firefox. Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.adobe.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. ---- If the above does not solve the issue, can you please test to see if the Adobe Flash file will load in the default Internet Explorer that is included with your version of Windows? Tests cannot be run from Google Chrome, as Chrome comes with a built-in flash player and cannot be used to determine whether there is an issue with flash on your computer.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello,

I visited the link you supplied, and I cannot see any Flash logo anywhere. Every place where there is supposed to be a Flash file, is instead completely blank. Right-clicking on those spaces instead produces the standard Firefox context menu.

Also, attempting to open local Flash files in Internet Explorer resulted in it simply asking whether I wanted to open or save the file in an infinite loop. I then attempted to load a speed testing website which has been failing to run in Firefox, and that site informed me that I needed to have Flash installed for it to work. I reinstalled Flash, and the site now runs properly in Internet Explorer. It still fails to run in Firefox. Attempting to run local files in Internet Explorer after reinstalling Flash again leads to a blank white screen.

Hello, I visited the link you supplied, and I cannot see any Flash logo anywhere. Every place where there is supposed to be a Flash file, is instead completely blank. Right-clicking on those spaces instead produces the standard Firefox context menu. Also, attempting to open local Flash files in Internet Explorer resulted in it simply asking whether I wanted to open or save the file in an infinite loop. I then attempted to load a speed testing website which has been failing to run in Firefox, and that site informed me that I needed to have Flash installed for it to work. I reinstalled Flash, and the site now runs properly in Internet Explorer. It still fails to run in Firefox. Attempting to run local files in Internet Explorer after reinstalling Flash again leads to a blank white screen.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

Can you please ensure that the Adobe Flashplayer plugin is not disabled on Firefox? To do so, please follow these steps:

  1. Select Add-ons from the Tools drop-down in the menu bar
  2. Select the Plugins from the sidebar
  3. Locate Adobe Flash
  4. Select Always Activate from the drop-down menu
  5. Restart Firefox

See if this repairs the issue. If not, please uninstall Adobe Flashplayer and try downloading and installing Shockwave Flash for Firefox.

Can you please ensure that the Adobe Flashplayer plugin is not disabled on Firefox? To do so, please follow these steps: #Select ''Add-ons'' from the ''Tools'' drop-down in the menu bar #Select the ''Plugins'' from the sidebar #Locate ''Adobe Flash'' #Select ''Always Activate'' from the drop-down menu #Restart Firefox See if this repairs the issue. If not, please uninstall Adobe Flashplayer and try downloading and installing [https://get.adobe.com/shockwave/ Shockwave Flash] for Firefox.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

I suppose I should have double checked this right off of the start, but can you please ensure that you are downloading and installing the Flash Player for the correct operating system and for Firefox from this website?

I suppose I should have double checked this right off of the start, but can you please ensure that you are downloading and installing the Flash Player for the correct operating system and for Firefox from [https://get.adobe.com/flashplayer/ this] website?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello,

I do not have an Adobe Flash option when I go into that menu. I do have Shockwave Flash however, and that is set to Always Activate. In addition, yes, that is the website I have been downloading and reinstalling Flash from. Just to be certain, I went ahead and downloaded it again and ran it from the link you supplied, to no avail.

I have uninstalled and reinstalled Flash previously as well.

Hello, I do not have an Adobe Flash option when I go into that menu. I do have Shockwave Flash however, and that is set to Always Activate. In addition, yes, that is the website I have been downloading and reinstalling Flash from. Just to be certain, I went ahead and downloaded it again and ran it from the link you supplied, to no avail. I have uninstalled and reinstalled Flash previously as well.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello,

I disabled Hardware Acceleration, and the problem still persists. Quite the conundrum.

Hello, I disabled Hardware Acceleration, and the problem still persists. Quite the conundrum.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

When you load a page with the SWF content on it, is there a plugin icon on the left side of the address bar? If there is, can you please see if it is telling you to allow Adobe Flash or Adobe Shockwave?

When you load a page with the SWF content on it, is there a plugin icon on the left side of the address bar? If there is, can you please see if it is telling you to allow Adobe Flash or Adobe Shockwave?
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59418 பதில்கள்
பதிவிடப்பட்டது

Make sure your Java (Not JavaScript) is up to date Verify Java and Find Out-of-Date Versions {web link}

Version 8 Update 60 Release date August 18, 2015

Make sure your Java (Not JavaScript) is up to date '''[http://java.com/en/download/installed.jsp Verify Java and Find Out-of-Date Versions]''' {web link} Version 8 Update 60 Release date August 18, 2015
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

No, there is no plugin icon there. By comparison, there is a plugin icon on the page that FredMcD linked to, for Java.

Also, on the topic of that page, yes my Java is up to date.

Thank you for your continued assistance with this.

No, there is no plugin icon there. By comparison, there is a plugin icon on the page that FredMcD linked to, for Java. Also, on the topic of that page, yes my Java is up to date. Thank you for your continued assistance with this.
Wesley Branton
  • Top 25 Contributor
594 தீர்வுகள் 5019 பதில்கள்
பதிவிடப்பட்டது

Have you checked to ensure that there is no malware on your computer? Since the issue occurs on more than just Firefox and started so suddenly, it seems like this might be the issue. Even if you have an anti-virus software active on your computer, certain malware cannot be detected. Can you please run some of the free tools from this list?

Further information can be found in the Troubleshoot Firefox issues caused by malware article.


I recommend and use AdwCleaner myself and find that it does a great job of cleaning your computer from malware.

Have you checked to ensure that there is no malware on your computer? Since the issue occurs on more than just Firefox and started so suddenly, it seems like this might be the issue. Even if you have an anti-virus software active on your computer, certain malware cannot be detected. Can you please run some of the free tools from this list? * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] * [http://general-changelog-team.fr/en/downloads/viewdownload/20-outils-de-xplode/2-adwcleaner AdwCleaner] * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. ---- I recommend and use AdwCleaner myself and find that it does a great job of cleaning your computer from malware.
FredMcD
  • Top 10 Contributor
4248 தீர்வுகள் 59418 பதில்கள்
பதிவிடப்பட்டது

Amenephis said

On websites with a background I can see the background through where the .swf file should be. This includes opening locally saved files as well as every website with a .swf file that's supposed to play.

Please post some of the links where you are having problems.

''Amenephis [[#question-1082928|said]]'' <blockquote> On websites with a background I can see the background through where the .swf file should be. This includes opening locally saved files as well as every website with a .swf file that's supposed to play. </blockquote> Please post some of the links where you are having problems.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

http://www.speedtest.net/ is the site I've been using, but I have identical issues on several other sites, including the Flash site itself. I'll run the antivirus stuff in a moment.

http://www.speedtest.net/ is the site I've been using, but I have identical issues on several other sites, including the Flash site itself. I'll run the antivirus stuff in a moment.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I installed and ran every single scanner you linked to there, as well as Spybot S&D just for grins since I had forgotten to reinstall it since I last formatted my computer...none of them came up with anything.

I installed and ran every single scanner you linked to there, as well as Spybot S&D just for grins since I had forgotten to reinstall it since I last formatted my computer...none of them came up with anything.
cor-el
  • Top 10 Contributor
  • Moderator
17481 தீர்வுகள் 157964 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

You can check for problems with current Shockwave Flash plugin versions and try this: *make sure you have the latest Flash version:<br>http://www.adobe.com/special/products/flashplayer/fp_distribution3.html *check for updates for your graphics drive drivers<br>https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration *disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) *disable hardware acceleration in the Flash plugin *disable hardware acceleration in Firefox<br />https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also: *http://kb.mozillazine.org/Flash#Troubleshooting *https://support.mozilla.org/kb/adobe-flash-protected-mode-firefox ---- Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

That got it! Disabling Protected Mode in Shockwave Flash caused everything to suddenly start working again. Thank you so much!

That got it! Disabling Protected Mode in Shockwave Flash caused everything to suddenly start working again. Thank you so much!