Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

exceptions - allow, block, allow for session

  • 17 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000

Firefox used to give me a pop up window that asked whether I wanted to allow, block, or allow for session whenever I visited a new website and dealt with cookies accordingly. It also added the resulting choices to an exceptions file. I upgraded to Firefox 40.0.2 and no longer get the choice window. I use Windows XP pro.

Now Firefox seems to allow all cookies of whatever origin. The websites do NOT show up in the exceptions page. The exceptions page has a place at the top to type in individual websites. Will I have to type in the address of every website on the internet that I visit? Can I get the old system with the pop up window of choices back? Please help as I have found no way to either control the cookies or prevent every website and their links to put cookies on my computer.

Thank you for your help with this frustrating problem.

All Replies (17)

Usually this setting doesn't change. Did you notice any other changes after the update? Did an Old Firefox Data folder appear on your desktop?

If you would like to change your cookie handling preferences you can do that here:

"3-bar" menu button (or Tools menu) > Options > Privacy

If the selector says "Firefox will: Remember history", change it to "Firefox will: Use custom settings for history"

Then you can change the "Keep until" setting for cookies to "ask me every time"

Thank you jscher2000 !

Yes, a folder called Old Firefox Data has appeared on my desktop. It has many files, but the names mean nothing to me.

AND changing the settings within the privacy page now returns the pop-up window to my main Firefox screen which in turn enters my choices into the exceptions menu. Thank you very much.

BUT some websites (like show up in my exceptions list repeatedly even though the choice screen does not appear and I keep deleting their "allow for session" entry from the exceptions list. They must be getting that permission from somewhere else.

So thank you jscher 2000. You solved much of my problem. Hooray.

For sites that appear by themselves, it's possible that an add-on or Firefox itself is accessing that site. It's hard to know for sure, but AP is a news organization, so something news related??

If you want to change the permission for a site that is already listed, another interface is available, the Permissions Manager. Type or paste about:permissions in the address bar and press Enter to load that. Because Firefox checks a large number of files, it may take time for the left column to load fully. You can type part of a site's address into the box at the top of the column to filter it down to what you're looking for. You can just keep this open in a tab somewhere instead of going into and out of Options.

The Old Firefox Data folder is created by the Refresh feature. It should contain all your old settings files, including what I assume is a huge database of site-specific cookie permissions. There may be a way to transplant that into your cleaned up post-Refresh settings (profile) folder to give you a head start on rebuilding the list.

When I looked at your previously posted questions, it seems that you may have had cookie issues for over a month. I'm not sure whether your Old Firefox Data folder has only the most recent settings folder moved by your most recent Refresh, or also contains one from before that might have a better database. This is hard to say because the files that store exceptions can't be easily examined. It's pretty much the realm of experiment.

If you want to experiment, look inside Old Firefox Data and see how many semi-randomly named folders you find. Then look inside each one and check the last modified date for a file named permissions.sqlite to see when they were moved to the desktop.

Note: Windows may hide the .sqlite file extension as it does with some others. To work with files as accurately as possible, I suggest showingall file extensions. This Microsoft support article has the steps:

Thank you for continuing to work with me on this. I appreciate that a lot.

The current status is: the exceptions list is populated every time I tell the pop-up window whether to allow, block, or allow for session. The list is emptied every time I close the Firefox browser. That's inconvenient, but I can live with it as it's a huge improvement over not being able to block or control cookies.

When I went to "about::permissions, I found websites listed that never had a pop-up window. They were,,, and I don't know what they are.

All others were websites I had visited today. I went through and blocked all that were marked "allow". Those additional websites showed up in my exceptions list afterward.

Then I closed are reopened Firefox. The exceptions list was now empty as was the about:permissions list. The about permissions list was reset to allow cookies.

On the privacy page I have checked "clear history when Firefox closes" because I want cookies deleted at that time. Does this cause the exceptions and permissions list to be cleared as well? Is there a way to keep the exceptions and permissions list and yet clear the cookies when I close Firefox?

Yes, I have been trying to solve the issues for a while now. I upgraded Firefox from 32.02 on May 1, to 38.0.1 to 38.0.5 on June 9, to 39.0 on July 23, and to 40.0.2 on August 13. My problems probably began with the upgrade to 39.0.

Thank you for sticking with me on this.  I feel the problem is close to being solved.  I've liked Firefox and would like to continue using it.

By the way, is essential to Firefox? I am asked to give cookie permission every time I boot Firefox I don't trust google.

If your cookie permissions are removed every time you shut down Firefox, check the following dialog:

"3-bar" menu button (or Tools menu) > Options > Privacy

If necessary, set the selector to "Firefox will: Use custom settings for history"

Click the Settings button to the right of "Clear history when Firefox closes" and review the categories. Make sure to UNCHECK the box for "Site Preferences". That's the category which stores site-specific permissions for cookies, popup windows, perhaps even zoom level.

Regarding Safe Browsing, that cookie is set when Firefox updates the malware/phishing site block list, which probably happens a few times a day. I doubt that cookie is critical to a successful download; it probably would still work if you block cookies from that site.

I unchecked site preferences within the settings as you suggested. That didn't help and all my exceptions are cleared whenever i close Firefox, or at least they are gone when Firefox is brought up again.

I'm not sure what "cache" is within the same settings window. Everything except "site preferences" in that window is checked. Those are the same things that show up in the "clear recent history" window.

Within "about:preferences", cookies are marked "allow for session" I don't know what should be checked there, but in any case it doesn't mention exceptions.

Both my antivirus (Avira) and my malware checker (Malwarebytes) show nothing bad when I do scans.

I just closed Firefox and rebooted the whole computer and this time the exceptions were still in the list.

I had used about:preferences to individually block, allow, and allow for session and they they saved in the exceptions this time.

However, now I'm no longer getting the pop-up window that asks if I want to block, allow, or allow for session about cookies and cookies are showing that weren't asked about.


It is possible that the cookies.sqlite file that stores the cookies is corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can try the same with the permissions.sqlite file and rename the file. Note that this will reset all permissions.

If you use cleanup software like CCleaner or use software like Advanced SystemCare then check the settings for the Firefox application.

You can use this button to go to the current Firefox profile folder:

Azaelia said

Within "about:preferences", cookies are marked "allow for session" I don't know what should be checked there, but in any case it doesn't mention exceptions.

Azaelia said

However, now I'm no longer getting the pop-up window that asks if I want to block, allow, or allow for session about cookies and cookies are showing that weren't asked about.

Do you mean about:preferences#privacy -- the Options page, Privacy panel? Make sure that is still set to:

Keep until: ask me every time

Everything seems to have worked well all day today. I'm getting the pop-up window for choices and the choices are appearing in the Exceptions list - and the list is staying populated. I'm hopeful the problem may be finally cleared. I did run CCleaner and that did not interfere.

I have not deleted or renamed any .sqlite files, but if the problems recur that will be my next step.

Thank you both for your help.

I am checking the needs more information box just to keep the thread open, though I hope not to need to come back to it.

There is something else I've been having trouble with. I think it's another issue with the messed-up settings. Sometimes, not always, when I try to click a link on a page it never loads or never takes effect.

For example, I can't sign out of this help page in the normal manner (clearing history will log me out), can't bring up animals on after i enter the zip code, animal type, etc., (alI I see are spinning bars) and what I've typed in becomes lost. This happens with some websites, but not others.

I've tried clearing the blocked sites from the Exceptions folder, but that doesn't help, so the bad setting must be somewhere else.

Thanks again for your help.

Clearing history potentially affects a lot of categories of data. The next time this happens on a site, could you try clearing only cached files: How to clear the Firefox cache. If you have a large hard drive, that can lock up Firefox for a minute or two.

Does that make any difference?

No, unfortunately that did not help. I still cannot click through to new subsidiary pages from within some (not all) websites and cannot sign out of the Firefox help page (though I can from some others.)

I think the problem is a bad setting somewhere because I went through the exceptions page and deleted everything I didn't recognize.

I think the problems all began with an upgrade and am sorry I did that. Is there a way to reset or restore Firefox without losing my bookmarks? I hate to leave Firefox but am considering doing so. I need my browser to work for me.

When this is finally solved, it will probably be something obvious and I will feel bad for missing it.

Again, thanks. You must be as frustrated as I am.

Could you explain what happens in this situation:

Azaelia said

I still cannot click through to new subsidiary pages from within some (not all) websites and cannot sign out of the Firefox help page (though I can from some others.)

Do you get an error message, or a blank page, or nothing happens at all?

Azaelia said

Is there a way to reset or restore Firefox without losing my bookmarks?

Yes, you can read about what the Refresh feature does in this article: Refresh Firefox - reset add-ons and settings. If you run it, an Old Firefox Data folder should appear on your desktop. Please hang onto that for a week or so in case it takes some time to notice something important missing.

Before I do the refresh, is it possible that the newer Firefox versions do not work with my Windows XP pro? I mentioned it in the first post, but not that it has servce pack 3.

Hi Azaelia, a lot of Firefox 40 users are on XP. Obviously with a computer in service for 5 or more years there are going to be a lot of differences among systems so we'll just have to try to help you work that out.