X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

No more inspector in Firefox 31? Can I inspect an element? How? "View source" is missing too.

  • 16 replies
  • 8 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

At my work, I have Firefox 31.

I have a page. I want to inspect an element. No way.

There is no more inspector in Firefox 31?! Can I inspect an element? How?

By the way, "View source" has disappeared too in Firefox 31. This does not help.

Does Mozilla plan to remove all the useful features from Firefox?

Thank you.

Nicolas B.

At my work, I have Firefox 31. I have a page. I want to inspect an element. No way. There is no more inspector in Firefox 31?! Can I inspect an element? How? By the way, "View source" has disappeared too in Firefox 31. This does not help. Does Mozilla plan to remove all the useful features from Firefox? Thank you. Nicolas B.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 18.0 r0
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • 5.1.40416.0
  • VLC media player Web Plugin
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

கூடுதல் தகவல்

[I followed the (half-wrong) guidelines for adding the troubleshooting info. Doing so pasted a personal text here! Because the button "Copy text to clipboard" in about:support does not copy anything.]

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

[I followed the (half-wrong) guidelines for adding the troubleshooting info. Doing so pasted a personal text! Because the button "Copy text to clipboard" in about:support does not copy anything. Someone may want to fix things.]

NB

[I followed the (half-wrong) guidelines for adding the troubleshooting info. Doing so pasted a personal text! Because the button "Copy text to clipboard" in about:support does not copy anything. Someone may want to fix things.] NB
John99 971 தீர்வுகள் 13138 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

I have not got that version available right now. The view source should be available as a keyboard shortcut Crtl+U combination. The Inspect should be available as an option on right click.

As this is a work computer or system you are talking about consult your IT Department. They may well have configured Firefox to prevent such actions.

No doubt you also have the current Release of Firefox 38 39 on your own computers, instead of or as well as the Firefox 31 ESR that you may need for work. Presumably you have no similar problems on your own computer.


edit - oops we are on fx39, & I am actually usingtht to post as shown in my next post

I have not got that version available right now. The view source should be available as a keyboard shortcut '''''Crtl+U''''' combination. The Inspect should be available as an option on right click. As this is a work computer or system you are talking about consult your IT Department. They may well have configured Firefox to prevent such actions. No doubt you also have the current Release of Firefox <s>38</s> '''39''' on your own computers, instead of or as well as the Firefox 31 ESR that you may need for work. Presumably you have no similar problems on your own computer. ------ edit - oops we are on fx39, & I am actually usingtht to post as shown in my next post

John99 மூலமாக திருத்தப்பட்டது

John99 971 தீர்வுகள் 13138 பதில்கள்
பதிவிடப்பட்டது

Hi again Nicholas,

The copy text button in the troubleshooting page works ok for me. it probably wouldn't surprise me if there is something going wrong with the options to add information to questions, it often seems to be missing & I guess people may run into problems.

Can you test first of all to see if the button normally works for you. Unless it does it is not likely to work in the Ask A Question workflow.

Can you please also test on your own Firefox 39 Release. I have no Idea what modifications your Work IT people may have made.


My copy text:


Application Basics


Name: Firefox Version: 39.0 Build ID: 20150629114848 User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0 Multiprocess Windows: 0/2 (default: false)

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: JSONView Version: 1.0.2 Enabled: true ID: jsonview@brh.numbera.com

Name: Lazarus: Form Recovery Version: 2.3.1-signed Enabled: true ID: lazarus@interclue.com

Name: Modern Download Manager Version: 0.2.1.1-signed Enabled: true ID: modernDownloadManager@teo.pl

Name: SQLite Manager Version: 0.8.3.1-signed Enabled: true ID: SQLiteManager@mrinalkant.blogspot.com

Name: Ubuntu Firefox Modifications Version: 3.0 Enabled: true ID: ubufox@ubuntu.com

Name: Ubuntu Online Accounts Version: 0.5 Enabled: true ID: online-accounts@lists.launchpad.net

Name: Unity Desktop Integration Version: 3.0.2 Enabled: true ID: webapps-team@lists.launchpad.net

Name: Unity Websites integration Version: 2014.08.06.beta Enabled: true ID: {2e1445b0-2682-11e1-bfc2-0800200c9a66}

Name: DownThemAll! Version: 2.0.18.1-signed Enabled: false ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8}

Graphics


Adapter Description: X.Org -- Gallium 0.4 on AMD CAICOS Asynchronous Pan/Zoom: none Device ID: Gallium 0.4 on AMD CAICOS Driver Version: 3.0 Mesa 10.1.3 GPU Accelerated Windows: 0/2 Basic Vendor ID: X.Org WebGL Renderer: X.Org -- Gallium 0.4 on AMD CAICOS windowLayerManagerRemote: false AzureCanvasBackend: cairo AzureContentBackend: cairo AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 327680 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20150629114848 browser.startup.homepage_override.buildID: 20150629114848 browser.startup.homepage_override.mstone: 39.0 dom.mozApps.used: true extensions.lastAppVersion: 39.0 media.gmp-gmpopenh264.lastUpdate: 1435837056 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20150629114848 media.gmp-manager.lastCheck: 1438170173 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1437933348 places.history.expiration.transient_current_max_pages: 34243 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 0 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1435838876

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


Sandbox


Seccomp-BPF (System Call Filtering): true Seccomp Thread Synchronisation: true User Namespaces: true Media Plugin Sandboxing: true

Hi again Nicholas, The copy text button in the troubleshooting page works ok for me. it probably wouldn't surprise me if there is something going wrong with the options to add information to questions, it often seems to be missing & I guess people may run into problems. Can you test first of all to see if the button normally works for you. Unless it does it is not likely to work in the Ask A Question workflow. Can you please also test on your own Firefox 39 Release. I have no Idea what modifications your Work IT people may have made. My copy text: ------------- Application Basics ------------------ Name: Firefox Version: 39.0 Build ID: 20150629114848 User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0 Multiprocess Windows: 0/2 (default: false) Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: JSONView Version: 1.0.2 Enabled: true ID: jsonview@brh.numbera.com Name: Lazarus: Form Recovery Version: 2.3.1-signed Enabled: true ID: lazarus@interclue.com Name: Modern Download Manager Version: 0.2.1.1-signed Enabled: true ID: modernDownloadManager@teo.pl Name: SQLite Manager Version: 0.8.3.1-signed Enabled: true ID: SQLiteManager@mrinalkant.blogspot.com Name: Ubuntu Firefox Modifications Version: 3.0 Enabled: true ID: ubufox@ubuntu.com Name: Ubuntu Online Accounts Version: 0.5 Enabled: true ID: online-accounts@lists.launchpad.net Name: Unity Desktop Integration Version: 3.0.2 Enabled: true ID: webapps-team@lists.launchpad.net Name: Unity Websites integration Version: 2014.08.06.beta Enabled: true ID: {2e1445b0-2682-11e1-bfc2-0800200c9a66} Name: DownThemAll! Version: 2.0.18.1-signed Enabled: false ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8} Graphics -------- Adapter Description: X.Org -- Gallium 0.4 on AMD CAICOS Asynchronous Pan/Zoom: none Device ID: Gallium 0.4 on AMD CAICOS Driver Version: 3.0 Mesa 10.1.3 GPU Accelerated Windows: 0/2 Basic Vendor ID: X.Org WebGL Renderer: X.Org -- Gallium 0.4 on AMD CAICOS windowLayerManagerRemote: false AzureCanvasBackend: cairo AzureContentBackend: cairo AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0 Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 327680 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.download.folderList: 2 browser.download.importedFromSqlite: true browser.download.useDownloadDir: false browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20150629114848 browser.startup.homepage_override.buildID: 20150629114848 browser.startup.homepage_override.mstone: 39.0 dom.mozApps.used: true extensions.lastAppVersion: 39.0 media.gmp-gmpopenh264.lastUpdate: 1435837056 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20150629114848 media.gmp-manager.lastCheck: 1438170173 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1437933348 places.history.expiration.transient_current_max_pages: 34243 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 0 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1435838876 Important Locked Preferences ---------------------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8 NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2 Experimental Features --------------------- Sandbox ------- Seccomp-BPF (System Call Filtering): true Seccomp Thread Synchronisation: true User Namespaces: true Media Plugin Sandboxing: true
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank you John for your fast reply!

John99 said

The view source should be available as a keyboard shortcut Crtl+U combination.

To show the source, Ctrl U works, that is good news! But we have to guess this. How? This is not discoverable. In previous Firefoxes, "View source" was available in the menus. Too bad that this has disappeared in Firefox 31.

John99 said

The Inspect should be available as an option on right click.

I cannot "Inspect element".

1) On the page, the right click does nothing, the contextual menu is blocked. Because of a bug of Firefox. "It's not a bug, it's a feature!" some would say. The author of the page probably asks Firefox, with some JavaScript, to block the contextual menu. And Firefox obeys that folly.

2) So I tried to open the Inspector with other ways. With the menus. With F12... No way.

3) On a normal page now, right click shows the contextual menu, but there is no item "Inspect element". Do you have it in Firefox 38?

John99 said

No doubt you also have the current Release of Firefox 38 on your own computers, instead of or as well as the Firefox 31 ESR that you may need for work. Presumably you have no similar problems on your own computer.

Does Firefox 38 offer "Inspect element" on right click, for you?

Thank you John for your fast reply! ''John99 [[#answer-760886|said]]'' <blockquote> The view source should be available as a keyboard shortcut '''''Crtl+U''''' combination. </blockquote> To show the source, Ctrl U works, that is good news! But we have to guess this. How? This is not discoverable. In previous Firefoxes, "View source" was available in the menus. Too bad that this has disappeared in Firefox 31. ''John99 [[#answer-760886|said]]'' <blockquote> The Inspect should be available as an option on right click. </blockquote> I cannot "Inspect element". 1) On the page, the right click does nothing, the contextual menu is blocked. Because of a bug of Firefox. ''"It's not a bug, it's a feature!"'' some would say. The author of the page probably asks Firefox, with some JavaScript, to block the contextual menu. And Firefox obeys that folly. 2) So I tried to open the Inspector with other ways. With the menus. With F12... No way. 3) On a normal page now, right click shows the contextual menu, but there is no item "Inspect element". Do you have it in Firefox 38? ''John99 [[#answer-760886|said]]'' <blockquote> No doubt you also have the current Release of Firefox 38 on your own computers, instead of or as well as the Firefox 31 ESR that you may need for work. Presumably you have no similar problems on your own computer. </blockquote> Does Firefox 38 offer "Inspect element" on right click, for you?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

John99 said

The copy text button in the troubleshooting page works ok for me. it probably wouldn't surprise me if there is something going wrong with the options to add information to questions, it often seems to be missing & I guess people may run into problems. Can you test first of all to see if the button normally works for you. Unless it does it is not likely to work in the Ask A Question workflow.

I had already tested the button. The button for copying the text in "about:support" is broken. It does not copy anything.

[Edited by nykola: fixed typing error.]

''John99 [[#answer-760893|said]]'' <blockquote> The copy text button in the troubleshooting page works ok for me. it probably wouldn't surprise me if there is something going wrong with the options to add information to questions, it often seems to be missing & I guess people may run into problems. Can you test first of all to see if the button normally works for you. Unless it does it is not likely to work in the Ask A Question workflow. </blockquote> I had already tested the button. The button for copying the text in "about:support" is broken. It does not copy anything. [Edited by nykola: fixed typing error.]

nykola மூலமாக திருத்தப்பட்டது

the-edmeister
  • Top 25 Contributor
  • Moderator
5412 தீர்வுகள் 40310 பதில்கள்
பதிவிடப்பட்டது

John99 said

The view source should be available as a keyboard shortcut Crtl+U combination.

To show the source, Ctrl U works, that is good news! But we have to guess this. How? This is not discoverable. In previous Firefoxes, "View source" was available in the menus. Too bad that this has disappeared in Firefox 31. ++++++++++++++++++++++++ View Source wasn't removed from the contextual menu. But please see this support page with regards to keyboard commands: Keyboard Shortcuts - Tools > Page Source


Inspect Element has always worked for me, except when I had a faulty extension that broke some elements in Firefox. See what happens in the Firefox SafeMode.

And when a page author [attempts] to disable the context menu on their pages, I get around that with a bookmarklet to override "his" blocking code and the 2nd (after using the bookmarklet) time I right-click the context menu appears. And their may be another similar bookmarklet that would work without needing to right-click twice - it works well enough for me that I have looked for a different version the "Enable Context Menu" bookmarklet.

''John99 [[#answer-760886|said]]'' <blockquote> The view source should be available as a keyboard shortcut '''''Crtl+U''''' combination. </blockquote> To show the source, Ctrl U works, that is good news! But we have to guess this. How? This is not discoverable. In previous Firefoxes, "View source" was available in the menus. Too bad that this has disappeared in Firefox 31. ++++++++++++++++++++++++ View Source wasn't removed from the contextual menu. But please see this support page with regards to keyboard commands: [https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly?redirectlocale=en-US&redirectslug=Keyboard+shortcuts#w_tools Keyboard Shortcuts - Tools > Page Source] -------------------- Inspect Element has always worked for me, ''except'' when I had a faulty extension that broke some elements in Firefox. See what happens in the [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox SafeMode]. And when a page author ''[attempts]'' to disable the context menu on their pages, I get around that with a bookmarklet to override "his" blocking code and the 2nd (after using the bookmarklet) time I right-click the context menu appears. And their may be another similar bookmarklet that would work without needing to right-click twice - it works well enough for me that I have looked for a different version the "Enable Context Menu" bookmarklet.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

John99 said

Can you please also test on your own Firefox 39 Release. I have no Idea what modifications your Work IT people may have made.
  1. I could test with a recent vanilla Firefox, if...
  2. I also tried to get Firefox Nightly to test something.

But none of these is possible.

I need that the site of Firefox propose to simply download the application Firefox, in a zip file if needed.

Alas, the site of Firefox does not propose that.

  1. The site proposes installers.
  2. The link starts with "https://ftp." It does not work here, God knows why.
  3. The installer is not even autonom. He needs to download stuff from the Internet. Typically, this fails here in my secure work environment.

As you see, there is much room for improvement at Mozilla's hands. Most of it is simply: "do as you did 10 years ago".

( There is also room for improvement in the IT security policy at my work, this is another subject. :-) )

''John99 [[#answer-760893|said]]'' <blockquote> Can you please also test on your own Firefox 39 Release. I have no Idea what modifications your Work IT people may have made. </blockquote> # I could test with a recent vanilla Firefox, ''if...'' # I also tried to get Firefox Nightly to test something. But none of these is possible. I need that the site of Firefox propose to simply download '''the application Firefox''', in a zip file if needed. Alas, the site of Firefox does not propose that. # The site proposes '''installers'''. # The link starts with "https://ftp." It does not work here, God knows why. # The installer is not even autonom. He needs to download stuff from the Internet. Typically, this fails here in my secure work environment. As you see, there is much room for improvement at Mozilla's hands. Most of it is simply: '''"do as you did 10 years ago"'''. ( There is also room for improvement in the IT security policy at my work, this is another subject. :-) )
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

the-edmeister said

Inspect Element has always worked for me, except when I had a faulty extension that broke some elements in Firefox.

This is interesting. You have "Inspect element" at right click in what version of Firefox?

''the-edmeister [[#answer-760930|said]]'' <blockquote> Inspect Element has always worked for me, ''except'' when I had a faulty extension that broke some elements in Firefox. </blockquote> This is interesting. You have "Inspect element" at right click in what version of Firefox?
jscher2000
  • Top 10 Contributor
8799 தீர்வுகள் 71970 பதில்கள்
பதிவிடப்பட்டது

Hi Nicolas, it sounds as though either your Firefox is damaged, or an extension is mucking it up, or your Firefox has been reconfigured by your IT.

(1) Have you turned on the menu bar?

You can use one of these methods to show the toolbar list and select Menu Bar there:

(2) Did you try Firefox's Safe Mode?

That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

(3) Do you have the freedom to install another version?

If so, I suggest this way:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement after this reinstall?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

(4) Remove any user.js file in your profile folder. You can access that folder while Firefox is closed by pasting the following into the Start menu search box and pressing Enter:

%APPDATA%\Mozilla\Firefox\Profiles

Here you should find one or more semi-randomly-named folders. Click into each and check for a file named user.js and unless you created it yourself, delete it.

Note: by default, Windows hides the .js file extension. To work with files accurately, I suggest setting Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Back to normal?

Hi Nicolas, it sounds as though either your Firefox is damaged, or an extension is mucking it up, or your Firefox has been reconfigured by your IT. '''(1) Have you turned on the menu bar?''' You can use one of these methods to show the toolbar list and select Menu Bar there: * right-click a blank spot on the tab bar (or the "+" button) * tap the Alt key to activate the classic menu bar > View > Toolbars * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) '''(2) Did you try Firefox's Safe Mode?''' That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? '''(3) Do you have the freedom to install another version?''' If so, I suggest this way: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (A) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (B) Exit out of Firefox (if applicable). (C) Rename the program folder, either: ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (D) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Any improvement after this reinstall? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins (4) Remove any '''user.js file''' in your profile folder. You can access that folder while Firefox is closed by pasting the following into the Start menu search box and pressing Enter: %APPDATA%\Mozilla\Firefox\Profiles Here you should find one or more semi-randomly-named folders. Click into each and check for a file named user.js and unless you created it yourself, delete it. Note: by default, Windows hides the .js file extension. To work with files accurately, I suggest setting Windows to show all file extensions. This article has the steps: http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions Back to normal?
the-edmeister
  • Top 25 Contributor
  • Moderator
5412 தீர்வுகள் 40310 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

nykola said

the-edmeister said
Inspect Element has always worked for me, except when I had a faulty extension that broke some elements in Firefox.

This is interesting. You have "Inspect element" at right click in what version of Firefox?

Firefox 39.0, but it's never not worked for me in any previous version - it's something I use frequently.

''nykola [[#answer-760936|said]]'' <blockquote> ''the-edmeister [[#answer-760930|said]]'' <blockquote> Inspect Element has always worked for me, ''except'' when I had a faulty extension that broke some elements in Firefox. </blockquote> This is interesting. You have "Inspect element" at right click in what version of Firefox? </blockquote> Firefox 39.0, but it's never not worked for me in any previous version - it's something I use frequently.

the-edmeister மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17587 தீர்வுகள் 159100 பதில்கள்
பதிவிடப்பட்டது

Does the view-source: protocol work?

Does the view-source: protocol work? *view-source:https://support.mozilla.org/en-US/questions/1074896
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

cor-el said

Does the view-source: protocol work?

Thank you for the tip, this is a very nice trick! :-)

But this trick does not work for all situations (the trick making a new request, AJAX, POST request...).

[Edited by nykola.]

''cor-el [[#answer-761061|said]]'' <blockquote> Does the view-source: protocol work? *view-source:https://support.mozilla.org/en-US/questions/1074896 </blockquote> Thank you for the tip, this is a very nice trick! :-) But this trick does not work for all situations (the trick making a new request, AJAX, POST request...). [Edited by nykola.]

nykola மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17587 தீர்வுகள் 159100 பதில்கள்
பதிவிடப்பட்டது

Did you install Firefox yourself or do you have a special version from your IT department?

Did you try the DOM Inspector and possibly the Live Http Headers extension to inspect internet traffic?

Did you install Firefox yourself or do you have a special version from your IT department? Did you try the DOM Inspector and possibly the Live Http Headers extension to inspect internet traffic? *https://addons.mozilla.org/firefox/addon/live-http-headers/ *https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ *https://developer.mozilla.org/DOM_Inspector *https://developer.mozilla.org/Introduction_to_DOM_Inspector
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I did not install Firefox myself.

cor-el said

Did you try the DOM Inspector and possibly the Live Http Headers extension to inspect internet traffic?

I wanted to use the extension Live HTTP Headers, but apparently it required restarting Firefox, so I did not. (Who says I am lazy? ;-))

What do you mean by "the DOM Inspector"? I did try to find the inspector in Firefox. To no avail. I did not try an extension.

cor-el said

These pages are not found.

I am reassured that according to you people here Firefox 39 still has "Inspect element".

Thank you for your help.

I did not install Firefox myself. ''cor-el [[#answer-761510|said]]'' <blockquote> Did you try the DOM Inspector and possibly the Live Http Headers extension to inspect internet traffic? </blockquote> I wanted to use the extension Live HTTP Headers, but apparently it required restarting Firefox, so I did not. (Who says I am lazy? ;-)) What do you mean by "the DOM Inspector"? I did try to find the inspector in Firefox. To no avail. I did not try an extension. ''cor-el [[#answer-761510|said]]'' <blockquote> *https://developer.mozilla.org/DOM_Inspector *https://developer.mozilla.org/Introduction_to_DOM_Inspector </blockquote> These pages are not found. I am reassured that according to you people here Firefox 39 still has "Inspect element". Thank you for your help.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

jscher2000 said

(1) Have you turned on the menu bar?

Yes.

jscher2000 said

(2) Did you try Firefox's Safe Mode?

In safe mode too, I get the issue: no "Inspect element".

''jscher2000 [[#answer-760946|said]]'' <blockquote> '''(1) Have you turned on the menu bar?''' </blockquote> Yes. ''jscher2000 [[#answer-760946|said]]'' <blockquote> '''(2) Did you try Firefox's Safe Mode?''' </blockquote> In safe mode too, I get the issue: no "Inspect element".
jscher2000
  • Top 10 Contributor
8799 தீர்வுகள் 71970 பதில்கள்
பதிவிடப்பட்டது

Are you able to do a Clean Reinstall per an earlier post?

Are you able to do a Clean Reinstall per an earlier post?