Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes on exit

  • 9 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 1 view
  • Last reply by Greg Hines

Hi,

Using Firefox 39.0 and finding it crashes each time I exit the program. OK in safe mode.

Have updated graphics drivers and disabled hardware acceleration and that does not help.

Also disabled all Extensions and that too did not help.

OS is W7/SP1 x64

Crash report at:-

https://crash-stats.mozilla.com/report/index/8abf1008-cbef-457f-92f7-08c402150715

Any help appreciated.

TIA

Greg

Hi, Using Firefox 39.0 and finding it crashes each time I exit the program. OK in safe mode. Have updated graphics drivers and disabled hardware acceleration and that does not help. Also disabled all Extensions and that too did not help. OS is W7/SP1 x64 Crash report at:- https://crash-stats.mozilla.com/report/index/8abf1008-cbef-457f-92f7-08c402150715 Any help appreciated. TIA Greg

All Replies (9)

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Hi,

I think if you read my original post you will see I've already tried your suggestions.

Greg

It is a problem with some NVidia component (nvwgf2um.dll) and D3D11, so it is definitely related to issues with the graphics display driver.

  • Firefox 39.0 Crash Report [@ NDXGI::CDevice::DeallocateCB(void*, _D3DDDICB_DEALLOCATE const*) ]

You can try to toggle the layers.d3d11.disable-warp pref to true on the about:config page.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

Changing layers.d3d11.disable-warp pref to true did not help.

Is it strange that this has only recently started to happen. No graphic drivers were updated UNTIL the problem started.

Don't understand why I should boot into safe mode as I don't usually operate the PC in this mode. Please explain?

Greg

Booting Windows in Safe Mode with network support will disable external software, so you can verify that it is indeed a problem with NVidia.

You can check if you have the latest Direct X (D3D) drivers and possibly run the DirectX Diagnostic Tool.

You can try to disable OMTC.

  • layers.offmainthreadcomposition.enabled = false

If toggling a pref doesn't help the you can reset the pref to undo/reverse the change.

Hi,

No problem in Safe Mode with Networking.

Disabling layers.offmainthreadcomposition.enabled = false did not help.

Regards,

Greg

Hi,

No other ideas on how to fix this problem?

Regards,

Greg

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page

Hi,

New profile is OK. :)

Have transferred bookmarks and all important information per the link you gave me.

Is it possible to transfer the extensions from one profile to another. I will do one by one and test each as I go?

TIA

Greg