Search Support

Why is Firefox telling me to update Adobe Reader and Flashplayer and Firefox, when I have the latest updates on my laptop?

  • 4 பதிலளிப்புகள்
  • 15 இந்த பிரச்னைகள் உள்ளது
  • 1305 views
  • Last reply by jscher2000

I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I wouldn't worry about Adobe Reader. If the Help > Check for Updates inside your Reader XI says you are current, as far as I am concerned, that is fine. The Plugin Checker always pushes you to get the newest release, but Adobe is still providing security updates for Reader 11, and since the radically different interface of Reader DC is definitely not going to be everyone's favorite, I think that will continue for quite a while.

Read this answer in context 👍 5

All Replies (4)

You are using Firefox 29, Flash 17, and Reader 11. You need to use Firefox 39, Flash 18, and Reader 2015.

eagle654b said

I am using windows 8.1. I have the latest versions of Fiirefox, Reader and Flash, but Firefox keeps saying I need to update to the latest version. Why?

I updated to firefox 39, but adobe says reader 11 is the latest update available for my computer. I also can't find the version for flash.

James மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I wouldn't worry about Adobe Reader. If the Help > Check for Updates inside your Reader XI says you are current, as far as I am concerned, that is fine. The Plugin Checker always pushes you to get the newest release, but Adobe is still providing security updates for Reader 11, and since the radically different interface of Reader DC is definitely not going to be everyone's favorite, I think that will continue for quite a while.