Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

What can I do to get Adobe Flash Player to work?

  • 2 பதிலளிப்புகள்
  • 10 இந்த பிரச்னைகள் உள்ளது
  • 162 views
  • Last reply by jscher2000

Adobe Flash Player repeatedly crashes. I've tried installing it multiple times, both from Firefox and directly from Adobe with no success. I get the message also that Shock Player has crashed.

Any suggestions as to how to fix this, please?

Thank you,

beverlygr53

All Replies (2)

Your System Details shows no players are installed.

Having more than one version of a program may cause issues.

Flash Player Version 17.0.0.134
https://www.adobe.com/products/flashplayer/distribution3.html

Your More System Details doesn't show "Shockwave Flash" which could indicate that it is set to "Never Activate" (such plugins are invisible to websites).

This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?