Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove "+" and "Add" in Search bar?

  • 14 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 14 views
  • Last reply by cor-el

Hello all. I just started to notice with the last Firefox upgrade (36.0 for Linux Mint 1.0) that when I go to certain sites a + sign pops up in my search bar magnifying glass and when I click on search bar space an entry at the bottom of the search bar's drop down list box (where the search suggestions show) appears that says "Add (whatever it wants me to add)". For instance right now It's showing "Add "Mozilla Support"". When I go to Youtube it says "Add "Youtube video search". On other sites, like Facebook, it doesn't happen. I don't want to see this and want to remove this functionality. How do I get rid of this behavior? I've tried turning off search suggestions and changing my default search engine (currently using Google but have tried others but no change in this behavior). Any help would be appreciated. Thanks.

- Rocky

All Replies (14)

rockyjoe said

Hello all. I just started to notice with the last Firefox upgrade (36.0 for Linux Mint 1.0) that when I go to certain sites a + sign pops up in my search bar magnifying glass and when I click on search bar space an entry at the bottom of the search bar's drop down list box (where the search suggestions show) appears that says "Add (whatever it wants me to add)". For instance right now It's showing "Add "Mozilla Support"". When I go to Youtube it says "Add "Youtube video search". On other sites, like Facebook, it doesn't happen. I don't want to see this and want to remove this functionality. How do I get rid of this behavior? I've tried turning off search suggestions and changing my default search engine (currently using Google but have tried others but no change in this behavior). Any help would be appreciated. Thanks. - Rocky

I think it's a built-in feature. May be there is not way till now to remove that icon.

That is this CSS rule in searchbar.css.

  • chrome://browser/skin/searchbar.css
.searchbar-search-button[addengines="true"] {
  list-style-image: url("chrome://browser/skin/search-indicator-badge-add.png");
}

You can override this rule and replace this image by the default search indicator image.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* replace icon with the green + indicator */
.searchbar-search-button[addengines="true"] {
list-style-image: url("chrome://browser/skin/search-indicator.png") !important;
}

/* remove Add search engine item */
#PopupSearchAutoComplete .addengine-item {
 display:none !important;
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.


(edited the code according to [/questions/1050438#answer-699746] - c)

cor-el மூலமாக திருத்தப்பட்டது

Thanks for the info but there is no chrome folder in my Firefox profile folder (which on my system is my_user/.mozilla/firefox).

You need to create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist and a plain text file named userChrome.css in that folder.

I created a chrome folder in the .mozilla directory and created a userChrome.css file within that directory with the following contents:

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

searchbar-search-button[addengines="true"] { list-style-image: url("chrome://browser/skin/search-indicator.png") !important; }

and it did nothing.

Not knowing if I had the correct directory I move the chrome directory to .mozilla/firefox, still nothing.

Finally moved it to the user's home directory, nothing again.

Thanks.

Sorry, I forgot the '.' to denote a class name. This code should work.

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.searchbar-search-button[addengines="true"] {
 list-style-image: url("chrome://browser/skin/search-indicator.png") !important;
}

#PopupSearchAutoComplete .addengine-item {
 display:none !important;
}

Unfortunately that didn't do anything either.

rockyjoe மூலமாக திருத்தப்பட்டது

Did you make sure that the userChrome.css is a plain text file and is located in the chrome folder in the Firefox profile folder?

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Directory

Does other code in the file work?

#urlbar .textbox-input-box,findbar .textbox-input-box, #search-container .textbox-input-box {font-size:13pt!important; font-family:monospace}

Yes. It's a plain text file called userChrome.css and resides in the chrome folder of the Firefox profile folder.

There is no other code in this file, just:

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.searchbar-search-button[addengines="true"] {

list-style-image: url("chrome://browser/skin/search-indicator.png") !important;

}

  1. PopupSearchAutoComplete .addengine-item {
display:none !important;

}


I added the #urlbar code that you showed also but it didn't do anything either, so I took it out.

When I go to chrome://browser/skin/searchbar.css there's a lot of information in it but I don't know where this file is. Is it relevant at all? You referenced it earlier but I didn't understand your explanation of it.

If the other code isn't working then it is likely that there is a problem with the file.

Does disabling all extensions have any effect?

You can start with the Classic Theme Restorer extension as that makes a lot of changes to the user interface.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

All extensions are disabled now. No change. I still see the + there. I'll try to create a new profile now and will let you know what it does. Thanks.

First make sure that the userChrome.css file is working by putting some code in the file of which you know will work and you notice immediately.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.menubar-text { font-size: 18px !important; }

cor-el மூலமாக திருத்தப்பட்டது

I just created a new clean profile and also a chrome folder with the code you just gave me. What was I supposed to see? Also, there was no change. I still see "+" on the magnifying glass and the option to add "Mozilla Support" to my search.

That code should enlarge the font size of text in the menu bar. So you need to enable this toolbar if it is hidden.

  • Tap the Alt key or press F10 to show the Menu Bar