X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox 36: How can I KEEP my default search engine choice and avoid Yahoo Search?

  • 2 replies
  • 8 இந்த பிரச்னைகள் உள்ளது
  • Last reply by maxglitz
பதிவிடப்பட்டது

Firefox 36 now insists I use Yahoo search by constantly changing my default search engine choice. No matter now many times I set it for Google, I'll search for something and it's Yahoo again. I've unchecked Yahoo in the search preferences, hoping it won't show up again. Have restarted Firefox several times. No luck.

Is my last resort to REMOVE Yahoo search from my list of search engines to keep this from happening? I MIGHT want to use it sometime later, but not every day.

ALSO. If this matters, When I populated this question with "installed plugins" information about my Mac and Firefox, a blank one appeared, so I went to tools > add-ons. That screen appeared for a second and instantly blipped away to another screen: DNS Yahoo Error Handler that had "developer garmin communicator plugin icon" filled in in the search request area. My web experience is being taken over by Yahoo now?

Firefox 36 now insists I use Yahoo search by constantly changing my default search engine choice. No matter now many times I set it for Google, I'll search for something and it's Yahoo again. I've unchecked Yahoo in the search preferences, hoping it won't show up again. Have restarted Firefox several times. No luck. Is my last resort to REMOVE Yahoo search from my list of search engines to keep this from happening? I MIGHT want to use it sometime later, but not every day. ALSO. If this matters, When I populated this question with "installed plugins" information about my Mac and Firefox, a blank one appeared, so I went to tools > add-ons. That screen appeared for a second and instantly blipped away to another screen: DNS Yahoo Error Handler that had "developer garmin communicator plugin icon" filled in in the search request area. My web experience is being taken over by Yahoo now?

maxglitz மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hmm, it does sound like you have some kind of hijacker in your Firefox. Try this:

Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Command+Shift+a
  • Tools menu > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. (Or if it's obviously badware, remove.)

If Firefox gets redirected at this point, see the next section.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?


If Firefox cannot use the Add-ons page, you may need to block extensions by using Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

(Not all add-ons are disabled: Flash and other plugins still run)

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Can you remove it?

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Coupons Inc., Coupon Printing FireFox Plugin
  • Provides information about the default web browser
  • DivX Plus Web Player version 2.2.1.2
  • DivX VOD Helper Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.1.0.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Simplifies the uploading of photo files.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 16.0 r0
  • eMusic DLM 4.1.3.2
  • iPhoto6

பயன்பாடு

  • Firefox 36.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0/Darwin/en-US/

நீட்சிகள்

  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • DownloadHelper 4.9.24 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Ebay Shopping Assistant by Spigot 2.2 ({A92BC493-FA5B-40a5-AFC8-6672926C9544})
  • FoxClocks 3.4.14 ({d37dc5d0-431d-44e5-8c91-49419370caa1})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Ghostery 5.4.2 (firefox@ghostery.com)
  • Print Edit 13.8 (printedit@DW-dev)
  • Searchme 2.4 (searchme@mybrowserbar.com)
  • Show Parent Folder 2.1 (showParentFolder@alice)
  • Slick Savings 3.6 ({84977DE9-1026-4508-B9A7-9116BDAAB098})
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouTube Video and Audio Downloader 0.4.3 (feca4b87-3be4-43da-a1b1-137c24220968@jetpack)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x9488
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'quartz', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 4670 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8695 தீர்வுகள் 71071 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hmm, it does sound like you have some kind of hijacker in your Firefox. Try this:

Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Command+Shift+a
  • Tools menu > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. (Or if it's obviously badware, remove.)

If Firefox gets redirected at this point, see the next section.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help?


If Firefox cannot use the Add-ons page, you may need to block extensions by using Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

(Not all add-ons are disabled: Flash and other plugins still run)

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Can you remove it?

Hmm, it does sound like you have some kind of hijacker in your Firefox. Try this: Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either: * Command+Shift+a * Tools menu > Add-ons In the left column, click Extensions. Then, if in doubt, disable. (Or if it's obviously badware, remove.) ''If Firefox gets redirected at this point, see the next section.'' Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that help? ---- If Firefox cannot use the Add-ons page, you may need to block extensions by using Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled (Not all add-ons are disabled: Flash and other plugins still run) After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Can you remove it?

jscher2000 மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks, jscher2000.

With your suggestion for how to restart with Add-ons disabled, I may have solved the problem. Several items in there including “Search me” which I never added and at least two more. I dumped anything that I didn’t add. The rest were older and posed no problems.

IMPORTANT: This clued me as to what to remove: Before I restarted with add-ons off, I couldn’t access my Tools page because it would instantly redirect to another page. Several times, Ghostery (love it) prevented a redirect to "api.mybrowserbar.com to cj.dotomi.com,which is part of Dotomi." I searched for it and found that it IS a hijacker. Symptoms include funky browser home page problems (that I also discovered when it wouldn’t load, or took me to Yahoo Search), redirects to its own search, etc. With that in mind, I removed “Search me” from my add-ons and a couple that appeared to be trackers. They likely came together with a new video download software that I un-installed yesterday because it didn’t work. None of the new extensions/plug-ins share a name with that mybrowserbar.com, but seemed to indicate they were related.

Thanks again for the help. Wonder what the best way to warn people would be. Though I don’t know yet for SURE how I got it. Macs have seemed so safe before.

Thanks, jscher2000. With your suggestion for how to restart with Add-ons disabled, I may have solved the problem. Several items in there including “Search me” which I never added and at least two more. I dumped anything that I didn’t add. The rest were older and posed no problems. IMPORTANT: This clued me as to what to remove: Before I restarted with add-ons off, I couldn’t access my Tools page because it would instantly redirect to another page. Several times, Ghostery (love it) prevented a redirect to "api.mybrowserbar.com to cj.dotomi.com,which is part of Dotomi." I searched for it and found that it IS a hijacker. Symptoms include funky browser home page problems (that I also discovered when it wouldn’t load, or took me to Yahoo Search), redirects to its own search, etc. With that in mind, I removed “Search me” from my add-ons and a couple that appeared to be trackers. They likely came together with a new video download software that I un-installed yesterday because it didn’t work. None of the new extensions/plug-ins share a name with that mybrowserbar.com, but seemed to indicate they were related. Thanks again for the help. Wonder what the best way to warn people would be. Though I don’t know yet for SURE how I got it. Macs have seemed so safe before.