X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox default spellchecker dictionary changed by Gmail

  • 16 replies
  • 4 இந்த பிரச்னைகள் உள்ளது
  • Last reply by brajawill
பதிவிடப்பட்டது

Sometime during the past year, Firefox has stopped retaining US English as my default spellchecker dictionary. I believe Gmail is somehow the culprit, though I cannot suggest how. I have my default spellchecker dictionary set to US English (en-US).

In some tests I did just now: Launch Firefox, go to edit environment in Wikipedia, spellchecker dictionary is set to US English, about:config spellchecker.dictionary setting concurs. Restart FF, go to Gmail > compose, dictionary defaults to the French one I have installed (fr-xx-classique+reforme1990)*, about:config spellchecker.dictionary setting concurs. Open second tab, go to WP edit session, dictionary is set to en-US, though about:config setting still set to French.

I tried the above troubleshooting steps in a couple different sequences and did not get consistent results. At first, once I had switched to en-US in the Gmail compose environment (by right-clicking on an underlined string), that setting seemed to take for the remainder of the browser session across multiple tabs. I restarted FF and it still seemed to be holding, even in Gmail. Then, after restarting the computer and starting a Gmail compose session, the dictionary was back to French.

On Bugzilla@Mozilla, I see only one potentially related issue when I search on "default spellchecker": https://bugzilla.mozilla.org/show_bug.cgi?id=1061650

Anyone else reporting such behavior? Anyone have any ideas? --Eric

current system: FF 34.0.5 on Windows 7 sp1

  • Note: There is an open, longtime Red Hat Bugzilla bug that looks to be reporting possibly related behavior on Linux systems:

https://bugzilla.redhat.com/show_bug.cgi?id=439598

Sometime during the past year, Firefox has stopped retaining US English as my default spellchecker dictionary. I believe Gmail is somehow the culprit, though I cannot suggest how. I have my default spellchecker dictionary set to US English (en-US). In some tests I did just now: Launch Firefox, go to edit environment in Wikipedia, spellchecker dictionary is set to US English, about:config spellchecker.dictionary setting concurs. Restart FF, go to Gmail > compose, dictionary defaults to the French one I have installed (fr-xx-classique+reforme1990)*, about:config spellchecker.dictionary setting concurs. Open second tab, go to WP edit session, dictionary is set to en-US, though about:config setting still set to French. I tried the above troubleshooting steps in a couple different sequences and did not get consistent results. At first, once I had switched to en-US in the Gmail compose environment (by right-clicking on an underlined string), that setting seemed to take for the remainder of the browser session across multiple tabs. I restarted FF and it still seemed to be holding, even in Gmail. Then, after restarting the computer and starting a Gmail compose session, the dictionary was back to French. On Bugzilla@Mozilla, I see only one potentially related issue when I search on "default spellchecker": https://bugzilla.mozilla.org/show_bug.cgi?id=1061650 Anyone else reporting such behavior? Anyone have any ideas? --Eric current system: FF 34.0.5 on Windows 7 sp1 *Note: There is an open, longtime Red Hat Bugzilla bug that looks to be reporting possibly related behavior on Linux systems: https://bugzilla.redhat.com/show_bug.cgi?id=439598

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Amazon MP3 Downloader Plugin 1.0.17
  • Bitdefender QuickScan Web Netscape Plugin
  • Citrix Online App Detector Plugin
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • Version 5.38.6.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • LogMeIn Rescue Technician Console
  • CANON iMAGE GATEWAY Mycamera Plugin
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • Winamp Application Detector

பயன்பாடு

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • Support URL: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

நீட்சிகள்

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Search Bar 2.8 (add-to-searchbox@maltekraus.de)
  • AddThis 3.5.9 ({3e0e7d2a-070f-4a47-b019-91fe5385ba79})
  • Bitdefender QuickScan 0.9.9.142 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Bookmark Favicon Changer 1.74 (bookmarkfaviconchanger@sonthakit)
  • ChatZilla 0.9.91.1 ({59c81df5-4b7a-477b-912d-4e0fdf64e5f2})
  • Cutyfox URL Shortener (bit.ly, is.gd, goo.gl) 1.4.1 (cutyfox@apps.metzweb.net)
  • Dictionnaire français «Classique & Réforme 1990» 4.3 (fr-classique-reforme1990@dictionaries.addons.mozilla.org)
  • FireFTP 2.0.21 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • IMDb ratings for watchever 0.0.7 (jid1-FpyZ8qozEHjs2A@jetpack)
  • LogMeIn, Inc. Rescue Technician Console 7.3.0.1445 (TechnicianConsole@logmeinrescue.com)
  • Show Parent Folder 2.1 (showParentFolder@alice)
  • Simple Timer 2.0.2 (simpletimer@grbradt.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Update Scanner 3.2.0 ({c07d1a49-9894-49ff-a594-38960ede8fb9})
  • Xmarks 4.3.5 (foxmarks@kei.com)
  • Classic Theme Restorer 1.2.8.2 (ClassicThemeRestorer@ArisT2Noia4dev) (Inactive)
  • Favicon Picker 3 0.5 ({446c03e0-2c35-11db-a98b-0800200c9a67}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4200
  • adapterDescription2:
  • adapterDeviceID: 0x9710
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 043b1028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-3-2012
  • driverDate2:
  • driverVersion: 8.970.100.3000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4200 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage: https://accounts.google.com/ServiceLogin?service=mail&passive=true&rm=false&continue=https://mail.google.com/mail/?zx%3Dr6jlcv7p8cvj%26shva%3D1&ss=1&scc=1&ltmpl=default&ltmplcache=2&emr=1#inbox
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.drawInTitlebar: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 34.0.5
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • layers.acceleration.disabled: True
  • media.gmp-gmpopenh264.lastUpdate: 1413816181
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1420382293
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1420383959
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1317854593
  • plugin.disable_full_page_plugin_for_types: audio/x-mpeg,audio/mpeg,application/pdf,audio/x-mpegurl
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1419716438

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4265 தீர்வுகள் 59803 பதில்கள்
பதிவிடப்பட்டது

Type about:preferences#content<enter> in the address bar. To the far right of Languages, press Choose and check the settings.

Type about:config<enter> in the address bar. There is a search box at the top of the page. Type intl.accept_languages What is the value?

Type '''about:preferences#content'''<enter> in the address bar. To the far right of '''Languages,''' press '''Choose''' and check the settings. Type '''about:config'''<enter> in the address bar. There is a search box at the top of the page. Type '''intl.accept_languages''' What is the value?
cor-el
  • Top 10 Contributor
  • Moderator
17564 தீர்வுகள் 158858 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Current Firefox versions automatically switch the dictionary based upon the "lang" meta tag.

<html class="no-js" lang="en-US" dir="ltr">
Current Firefox versions automatically switch the dictionary based upon the "lang" meta tag. <pre><nowiki><html class="no-js" lang="en-US" dir="ltr"></nowiki></pre>
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Fred: In preferences#content, the language is set to en-us; intl.accept_languages is set to en-US, en.

co-rel: I don't find the string "lang" in the source code of my Gmail inbox page, if that helps.

Thanks to you both for replying. --Eric

Fred: In preferences#content, the language is set to en-us; intl.accept_languages is set to en-US, en. co-rel: I don't find the string "lang" in the source code of my Gmail inbox page, if that helps. Thanks to you both for replying. --Eric
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Update: I'm now thinking it's Gmail that is the culprit here. It seems that every new Gmail session starts off with French as the spell-check language. Anyone know if that would tend to be an issue with FF or with Gmail? --Eric

Update: I'm now thinking it's Gmail that is the culprit here. It seems that every new Gmail session starts off with French as the spell-check language. Anyone know if that would tend to be an issue with FF or with Gmail? --Eric
FredMcD
  • Top 10 Contributor
4265 தீர்வுகள் 59803 பதில்கள்
பதிவிடப்பட்டது

If this problem is only on gmail pages, check the site settings.

If this problem is only on gmail pages, check the site settings.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The display language is set to English; I assume that would tell Gmail to assume I'm composing in English as well.

The display language is set to English; I assume that would tell Gmail to assume I'm composing in English as well.
FredMcD
  • Top 10 Contributor
4265 தீர்வுகள் 59803 பதில்கள்
பதிவிடப்பட்டது

Never underestimate the stupidity of programers. Now go to the web site and check the options.

Never underestimate the stupidity of programers. Now go to the web site and check the options.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Sorry, I should have been more specific. In Gmail's account settings, there is a drop-down menu to choose the display language. Mine is set to English. As I mentioned above in my reply to cor-el, there is no "lang" tag in the source code of the Gmail account page, so I can't see any evidence there of a language being set in the html.

Sorry, I should have been more specific. In Gmail's account settings, there is a drop-down menu to choose the display language. Mine is set to English. As I mentioned above in my reply to cor-el, there is no "lang" tag in the source code of the Gmail account page, so I can't see any evidence there of a language being set in the html.
FredMcD
  • Top 10 Contributor
4265 தீர்வுகள் 59803 பதில்கள்
பதிவிடப்பட்டது

If this happens only with Gmail locations, have you contacted their support people?

If this happens only with Gmail locations, have you contacted their support people?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I posted on the help forum. No sign yet of it having got Google staff's attention: https://productforums.google.com/forum/#!mydiscussions/gmail/IjaWJMDRkEQ

I posted on the help forum. No sign yet of it having got Google staff's attention: https://productforums.google.com/forum/#!mydiscussions/gmail/IjaWJMDRkEQ
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

More info: I have dictionaries for English, German, and French installed. I just noticed something funny in the add-ons listing views: While the German dictionary is listed under the Dictionaries category, the French one is under Extensions. Any ideas? See screenshots attached. Thanks. --Eric

More info: I have dictionaries for English, German, and French installed. I just noticed something funny in the add-ons listing views: While the German dictionary is listed under the Dictionaries category, the French one is under Extensions. Any ideas? See screenshots attached. Thanks. --Eric
FredMcD
  • Top 10 Contributor
4265 தீர்வுகள் 59803 பதில்கள்
பதிவிடப்பட்டது

See what happens when you disable one of them.

See what happens when you disable one of them.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

At the suggestion of someone in the Gmail forum, I uninstalled the French extension one and reinstalled it in a way that made it go into the Dictionaries category. Now I'm waiting to see what happens. Thanks.

At the suggestion of someone in the Gmail forum, I uninstalled the French extension one and reinstalled it in a way that made it go into the Dictionaries category. Now I'm waiting to see what happens. Thanks.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Well, I guess the above change did not address the problem. I just went to compose an e-mail, and the spell-check was set to French.

Well, I guess the above change did not address the problem. I just went to compose an e-mail, and the spell-check was set to French.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hello all- Just an FYI/update: I am now encountering the same problem on a different Windows machine: Windows 7 Enterprise 64-bit sp1 Firefox 35.0 --Eric

Hello all- Just an FYI/update: I am now encountering the same problem on a different Windows machine: Windows 7 Enterprise 64-bit sp1 Firefox 35.0 --Eric
brajawill 0 தீர்வுகள் 6 பதில்கள்
பதிவிடப்பட்டது

This is not a Gmail thing. This is certainly a Firefox problem. I have this same problem, and it happens not just with Google products.

Many people have this problem it seems, and we're all left to the help forums which are not offering the right solution. Of course the forums are helpful, but this problem still persists.

Contact Mozilla directly? https://input.mozilla.org/en-US/feedback

Not sure if it helps in solving the problem...but maybe ;)

This is not a Gmail thing. This is certainly a Firefox problem. I have this same problem, and it happens not just with Google products. Many people have this problem it seems, and we're all left to the help forums which are not offering the right solution. Of course the forums are helpful, but this problem still persists. Contact Mozilla directly? https://input.mozilla.org/en-US/feedback Not sure if it helps in solving the problem...but maybe ;)

brajawill மூலமாக திருத்தப்பட்டது