Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop Firefox from remembering login names?

  • 8 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 6401 views
  • Last reply by Solarityx

When I log into a website, Firefox is remembering those names. I have changed every setting I know of but it still insists on 'suggesting' login names. How do I turn off this function?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

"Never remember history" means Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
    "Always use Private Browsing mode"

You will have to disable PB mode temporarily if pressing the Delete key when that entry is highlighted in the drop-down list like I posted above.

Read this answer in context 👍 2

All Replies (8)

If you open Firefox setting and head to the "Privacy" tab you can change "Firefox will" to "Use custom settings…". One of the options which will appear if you do this is "Remember search and form history". Turn that setting off and Firefox should stop suggesting entries when you're filling out forms.

Details like websites remembering you (log you in automatically) are stored in a cookie. You can remove such a cookie to make the website remember you.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

There are other things that need your attention.

Your System Details List shows multiple Flash plugins.

  • Shockwave Flash 16.0 r0
  • Shockwave Flash 11.9 r900

You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\

@ Scott: I am set to 'never remember history'. If I change it to 'custom', it is already set to 'always use private browsing mode' which doesn't allow for checking off the 'remember search and form'. Thank you for your response.

@ cor-el: I have removed all cookies, cleared the cache, restarted Firefox and your suggestion of 'delete' the drop down name. It still appears when next I go to log into the pages. :(

I will look into the flash player after work. I have noticed 2 running at times and I wasn't sure what was going on with that. Thank you.

Can you clarify if you are talking about suggestions in a drop-down list or about the website remembering you via a special cookie (that shouldn't happen in PB mode)?

You will have to disable Private Browsing mode temporarily if you can't remove suggestions.

Use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

The websites remember my log in name. All I have to do is click in the 'nickname or email address' box and it drops down with my login name.

My setting is 'Never remember history'. Not 'private browsing'.

This started after the last update that Mozilla did. I've never had my history remembered nor login names nor passwords.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

"Never remember history" means Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
    "Always use Private Browsing mode"

You will have to disable PB mode temporarily if pressing the Delete key when that entry is highlighted in the drop-down list like I posted above.

I must of been skipping a step somewhere. Now that I've done it correctly, it does seem to have worked. Thank you so much for your patience and help!

Cheers