Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is my browser spawning invisible windows?

  • 20 பதிலளிப்புகள்
  • 6 இந்த பிரச்னைகள் உள்ளது
  • 3029 views
  • Last reply by tensider

Operating system: OS X 10.9

Starting about four months ago, I began to see untitled and non-selectable windows spawning after my browser had been open for a while (i.e. after I visited a few sites). The number of these invisible windows grows over time, but are removed if I close the browser and start a new session. This has persisted through many new versions of Firefox.

I tried turning off all of the add-ons. Still happened.

I tried keeping track of what sites caused the problem. No correlation.

Today I uninstalled Firefox, using AppZapper -- which should have removed everything -- then did a new install. The only thing that I imported were bookmarks from the backup directory in my old Profile folder.

...and it's happening again. Here is a screen shot: http://imgur.com/ojcODd1

Any help would be appreciated.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

By default "privacy.clearOnShutdown.cookies": false, is usually true. and network.cookie.lifetimePolicy": 1, is usually 0.

I do not know exactly if this is the result of cookies not being removed, however these are the about:config entries that stand out from version 34.

Read this answer in context 👍 2

All Replies (20)

Possible Mal-Ware Scan For Macs {web link}

Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

I did have Adblock Plus installed. Currently I am running Adblock Edge.

Have you tried the mal-ware scan?

Yes. ClamXav found heuristic matches in gmail archives, but nothing that seemed like an active threat.

I believe that I have found a clue:

If I leave only a single tab open, I do not get the invisible windows. It's only when there are multiple tabs. This leads me to believe that opening a new tab creates this window instance.

Now I'm just not sure what to do with that information...

Your System Details shows;

Installed Plug-ins

RBlue Jeans Installation Plugin RBlue Jeans Video Plugin

Blue Jeans Video Plugin Blue Jeans Installation Plugin

Having more than one version of a program may cause issues.

That's really interesting. App Zapper was supposed to remove everything related to my previous installation, but it appears that all of my plug-ins are there. I'm going to manually delete those and see if that helps.

Thanks! I'll report back.

I removed the earlier instance of BlueJeans plug-in and everything seemed to be going well, but today the invisible windows are back :-(

I've called the big guys to help you. Good luck.

Does your sessionstore file have a large number of blank entries? (textedit or notepad) Profiles - Where Firefox stores your bookmarks, passwords and other user data

Looks like this is a test version of Blue Jeans? https://community.bluejeans.com/bluej.../firefox-equivilant-of-google-chrome-extension

The file called sessionCheckpoints.json has this in it:

{"profile-after-change":true,"final-ui-startup":true,"sessionstore-windows-restored":true}

and, interestingly enough, I do not see a file called "sessionstore.js" in my profile folder. Other .js files are not hidden. Could that be the issue?

You are right that there is a more recent version of the bluejeans plugin. I have installed it, and hopefully there won't be two versions this time (though now I know how to manually remove the old one).

That is because they moved to session-backups folder. There are the last 5 or 6 sessions.

Mine says the same, sorry wrong path: {"profile-after-change":true,"final-ui-startup":true,"sessionstore-windows-restored":true}

Ok, what else can we try as I type aloud. Try to rename recovery.js to recoveryold.js and rename the recovery.bk to recovery.js and restart Firefox.

No luck. I'm going to try removing everything - the app, the extensions, the add-ons - whole shebang - then reinstall.

If that doesn't work, do you have an exorcist on duty?

-( I deleted all of my add-ons. Removed any folder in both the all users and my username's Libraries that was related to Mozilla or Firefox. I used AppZapper to remove the application and its associated files.

The only thing that I put back in was 1Password.

STILL getting spawned windows.

Here is the Troubleshooting dump:

{

 "application": {
   "name": "Firefox",
   "version": "33.1.1",
   "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0",
   "supportURL": "https://support.mozilla.org/1/firefox/33.1.1/Darwin/en-US/",
   "numTotalWindows": 65,
   "numRemoteWindows": 0
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.frecency_experiment": 4,
   "browser.places.smartBookmarksVersion": 7,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20141113143407",
   "browser.startup.homepage_override.mstone": "33.1.1",
   "browser.startup.homepage_override.buildID": "20141113143407",
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "33.1.1",
   "media.gmp-gmpopenh264.lastUpdate": 1417211654,
   "media.gmp-gmpopenh264.version": "1.1",
   "media.gmp-manager.lastCheck": 1417211654,
   "network.cookie.prefsMigrated": true,
   "network.cookie.lifetimePolicy": 1,
   "network.cookie.cookieBehavior": 1,
   "places.history.enabled": false,
   "places.history.expiration.transient_current_max_pages": 104858,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "plugin.importedState": true,
   "privacy.sanitize.sanitizeOnShutdown": true,
   "privacy.clearOnShutdown.cookies": false,
   "privacy.donottrackheader.enabled": true,
   "privacy.sanitize.migrateFx3Prefs": true
 },
 "lockedPreferences": {},
 "graphics": {
   "numTotalWindows": 65,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "OpenGL",
   "windowLayerManagerRemote": true,
   "adapterDescription": "",
   "adapterVendorID": "0x8086",
   "adapterDeviceID": "0x 166",
   "adapterRAM": "",
   "adapterDrivers": "",
   "driverVersion": "",
   "driverDate": "",
   "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine",
   "info": {
     "AzureCanvasBackend": "quartz",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "none",
     "AzureContentBackend": "quartz"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.7",
     "version": "4.10.7"
   },
   "NSS": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.17.2",
     "version": "3.17.2"
   },
   "NSSSSL": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.17.2 Basic ECC",
     "version": "3.17.2 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": [
   {
     "name": "1Password",
     "version": "4.2.5",
     "isActive": true,
     "id": "onepassword4@agilebits.com"
   }
 ],
 "experiments": []

}

தீர்வு தேர்ந்தெடுக்கப்பட்டது

By default "privacy.clearOnShutdown.cookies": false, is usually true. and network.cookie.lifetimePolicy": 1, is usually 0.

I do not know exactly if this is the result of cookies not being removed, however these are the about:config entries that stand out from version 34.

I will change those entries and see if it makes a difference.

Definitely an issue on shutdown as well. I will ask someone to take a look at this too/

I have been running the browser all morning and thus far no invisible windows :-)

It did delete all of my cookies after I shut down the browser, which meant any two-factor sites that I signed into previously were once again suspicious of me. I will undo that bit of privacy control and see if the problem returns.

Still no spawning invisi-windows for a couple of days. I'm re-adding add-ons one by one (but only the most critical - some of those were leftovers that should have been deleted a long time ago).

I am adding Adblock and will see how that goes.

Thanks!!!!

Problem seems solved. Thank you muchly for sticking with this one until the end.