Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

One word search in address bar not working.

  • 71 பதிலளிப்புகள்
  • 128 இந்த பிரச்னைகள் உள்ளது
  • 8037 views
  • Last reply by Lurker

I've been away from my desktop for a week and now the searches in the address bar are not working. For example, I used to just type 'test' into the search bar and the tab would show a list of Google searches. Two words work though. Any and all help would be deeply appreciated. I've tried Search Reset, changing the keyword and fixup in about:config.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks for the paste. Looks like this service based in Malaysia: http://midas.nervesis.com/ (http://www.nervesis.com.my/). Does it seem plausible that your ISP is using this service?? Even if it is, it should not be able to override the new way that address bar search works in Firefox 33.

I think the question of a bad extension was raised before. Have you tested in Firefox's Safe Mode to rule that out? It's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Read this answer in context 👍 0

All Replies (11)

Hi Lurker, what version of Firefox are you running now?

Firefox 33 changed how address bar search works so that one-word searches are sent to your search engine first, with a DNS check in the background. If the DNS check returns an address, you get an infobar asking whether you wanted that instead, which appears above the search results.

Note: This assumes keyword.enabled has its default value of true.

jscher2000 மூலமாக திருத்தப்பட்டது

Currently I'm running 33.1 though I want to point out that I wasn't when I first encountered this problem. It still persists until now. Can you clarify what you meant by the DNS check ?

Hi Lurker, before Firefox 33, if you submitted something in the address bar that did not have any spaces, such as the word intranet, Firefox would do a DNS lookup first before trying search, since your local network might actually have a server named intranet. People have been aggravated by this for years because it was slow and allowed service providers to hijack the query and show results in a different search engine. So starting in Firefox 33, those queries are sent to your default search engine first, and meanwhile Firefox does the DNS lookup in the background just in case you actually do have a server by that name.

What is your keyword search setting right now? You can check using the about:config preferences editor:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste keyw and pause while the list is filtered

(3) If the keyword.enabled preference is bolded and "user set" to false, double-click it to switch it back to the default value of true.

It is set to true. I suspect that my service provider is actually hijacking the query like you said since I'm being redirected to local information. Any advice on how to stop this ?

Hi Lurker, could you give the address of the results page you're getting for a one-word search, for example, for firefox?

If there's no real address, it could be a feature of one of your add-ons.


The possible solutions for a service provider DNS diversion are:

(1) Find the way that the service provider let's you opt out. Often there is a little message on the page along the lines of "Why am I getting this page" that leads to an opt-out.

(2) If you cannot opt out, you can change your DNS service to OpenDNS or Google Public DNS, or another service of your choosing.

Unfortunate there is no true address however I am relatively certain that this is not caused by add-ons. I've attached two pictures to show you instead what happens.

As you can see there is no choice to opt out and I can also verify that I have been using Google's Public DNS all along. Although, the DNS change was only done on my wireless connection. I did not change the Ethernet connection' DNS even though I'm also connected through there. Could this have cause a clash in the connection ?

Hi Lurker, that's strange! On the second example where it says "Get me out of here" in the lower right corner, where does that lead?

If you press Ctrl+u to display the HTML source code of the page, does it have an address in the title var of the viewer (e.g., Source of: URL)? If you want to share the source, the easiest way would be to Ctrl+a, Ctrl+c to select and copy all, then paste into a form on Pastebin and save that and share the URL here. (You don't need an account to use Pastebin and unlike this site, the HTML won't get mangled.)

http://pastebin.com/

Regarding which DNS Firefox is using, I'm not sure Firefox can report where it is doing its lookups. I think it sends the queries to Windows to take care of. However, someone more knowledge about the deep inner workings might know how to figure it out. (I assume that given a choice, Windows will use Ethernet over wi-fi for speed reasons.)

Clicking 'Get me out of here' only redirects to the same page a couple of times until it finally shows Server Not Found.

I am unfamiliar with HTML but I'm assuming the source you are looking for is in line 13 ? Here's the link.

http://pastebin.com/1MX05aQP

As regards to the DNS, I've set both connections to use Google's public DNS. Now, the searches take longer and doesnt show the image I've posted above anymore. Instead, I received another Server Not Found.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Thanks for the paste. Looks like this service based in Malaysia: http://midas.nervesis.com/ (http://www.nervesis.com.my/). Does it seem plausible that your ISP is using this service?? Even if it is, it should not be able to override the new way that address bar search works in Firefox 33.

I think the question of a bad extension was raised before. Have you tested in Firefox's Safe Mode to rule that out? It's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Wow, this is interesting. Restarting Firefox in Safe Mode seems to have fixed the problem. Right now using Firefox normally again, all searches through the address bar seems to be working perfectly.

Note, I did not disable any add-ons manually for this normal session as well. This is very weird but things seems to be finally working again after 4 months. I'll still be keeping a look out in case things go crazy again though.

Regardless, thank you very much Jscher2000. I really appreciate your help in solving this problem.

  1. 1
  2. 2
  3. 3
  4. 4