Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When clicking on Firefox icon on desktop, "isearch.omiga-plus" starts instead.

  • 4 பதிலளிப்புகள்
  • 8 இந்த பிரச்னைகள் உள்ளது
  • 1 view
  • Last reply by Silke777

I have restarted Firefox in safemode and reset Firefox.

Now when I click on the Firefox icon on the desktop, the following message appears:

"Server not found. Firefox can't find the server at isearch.omiga-plus.com."

தீர்வு தேர்ந்தெடுக்கப்பட்டது

If problems return quickly after a reset, it can indicate a lingering malware problem. I'm not sure what you've tried so for, but I suggest starting here:

Open the Windows Control Panel, Uninstall a Program. Click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can "mop up" remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These programs are free and if you instead get a fake quick scan followed by a request for payment, something very serious is installed. Try the specialized malware forums listed in that article for step-by-step assistance.

Read this answer in context 👍 1

All Replies (4)

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can open the about:config page via the location/address bar and search for prefs that refer to isearch.omiga-plus.com. You can reset user set (bold) prefs via the right-click context menu to the default value.

Holding the Shift button while clicking on the Firefox icon and then clicking "Reset Firefox" gets me past Omiga, but I have to do it every time and am not sure how to completely remove the malware safely without downloading more with unsafe removal programs.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

If problems return quickly after a reset, it can indicate a lingering malware problem. I'm not sure what you've tried so for, but I suggest starting here:

Open the Windows Control Panel, Uninstall a Program. Click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Take out as much trash as possible here.

Then, in Firefox, open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Finally, you can "mop up" remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These programs are free and if you instead get a fake quick scan followed by a request for payment, something very serious is installed. Try the specialized malware forums listed in that article for step-by-step assistance.

Thanks. Running Malwarebytes Anti-Malware seems to have removed the isearch.omiga-plus infection.