Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to remove the search bar from new tab page?

  • 12 பதிலளிப்புகள்
  • 15 இந்த பிரச்னைகள் உள்ளது
  • 4436 views
  • Last reply by Barian

I've added extra pinned site rows and columns on the new tab page. The new search bar is redundant and space hogging. Please provide how to disable in step by step instructions :)

Edit: Answer 1. Go to Firefox Profile Folder (go to about:support in Firefox then click Open folder/Show in Finder to get there) 2. Open or create the chrome folder in the Firefox Profile Folder. 3. Create a blank text file, copy and paste this code into the text file.

@-moz-document url(about:newtab) {

 #newtab-search-container, #newtab-search-logo { display:none !important; } 
 #newtab-margin-top, #newtab-search-container { display:none!important; }
 } 

4. Save it as userContent.css (using ALL FILES under the drop down menu) 5. Place the new css file into the chrome folder.

Barian மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Fox_1923: You're not supposed to create a new chrome file but a userContent.css file in the chrome folder. You can use mine and cor-el's code together in the userContent.css file to get rid of the large margin in the top along with the search box. I've used it just fine in the latest Nightly and so have others who dislike the search box.

One thing you could be doing wrong is not setting the file type to all Files and Notepad or whatever else you are using is adding an unneeded extension (for Windows, .txt = userContent.css.txt doesn't work!) See this for clarification:

Read this answer in context 👍 1

All Replies (12)

You can use the following code and put it into the userContent.css file in the chrome folder of your Firefox Profile Folder (go to about:support in Firefox then click Open folder to get there) If the chrome folder doesn't exist, create it. Make sure when you save the .css file that you choose the file type as ALL FILES as opposed to the regular .txt.


@-moz-document url(about:newtab) 
{
  #newtab-search-container, #newtab-search-logo { display:none !important; } 
  } 

Moses மூலமாக திருத்தப்பட்டது

Other possible code in userContent.css:

@-moz-document url(about:newtab){
 #newtab-margin-top, #newtab-search-container { display:none!important; }
}

Make sure to use a plain text editor like Text Edit (do not use rich text).

I searched chrome folder in my profile and there are tree and they belong to add-ons (they are in extensions folder), I created new chrome file and did rest of the process but search box still appears.

+We dont need a THIRD search box. Its too useless.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Fox_1923: You're not supposed to create a new chrome file but a userContent.css file in the chrome folder. You can use mine and cor-el's code together in the userContent.css file to get rid of the large margin in the top along with the search box. I've used it just fine in the latest Nightly and so have others who dislike the search box.

One thing you could be doing wrong is not setting the file type to all Files and Notepad or whatever else you are using is adding an unneeded extension (for Windows, .txt = userContent.css.txt doesn't work!) See this for clarification:

Unfortunately I'm failed.

As I said, there is three chrome folders in my profile, I delete mine and put css file into one of them, and as you mentioned I corrected type of file but it didn't worked.

Is there any way to do it via about:config?

Thanks for your help...

Why do you have three chrome folders? I'm assuming since you searched for chrome it pulled up other folders named chrome in different subfolders such as extensions. Create a chrome folder in the root of your Profile Folder then put it in there. For example, here's my path to the chrome folder and my userContent.css

  • E:\Users\moses\AppData\Roaming\Mozilla\Firefox\Profiles\12345678.default\chrome\userContent.css

No, there isn't a way to do it in about:config afaik. I'm sure cor-el would know more as he's more skilled in about:config than I.

The chrome folder directly is in the xxxxxxxx.default folder (main profile folder) and not in a sub folder in the extensions folder. So you first need to create the chrome folder in the main profile folder with the random name (xxxxxxxx.default). The file should have this path:

  • xxxxxxxx.default/chrome/userContent.css

I save the txt file as "all files" but its still shown as text file, maybe its the problem

here is the situation,

The file type shouldn't be be TXT file, but CSS file (Cascading Stylesheet), so it is possible that you saved the file as a text file and that the file has a hidden .txt file extension.

thanks for your helps guys, but unfortunately CSS thing didn't worked for some reason and I don't want to reset my FF now,

so I started to use this add-on: https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/ and its really nice and useful.

Fox_1923 மூலமாக திருத்தப்பட்டது

The css file worked perfectly for me. Thankyou :D

Sorry for the late reply, I got distracted by work and forgot all about this question.

I DID NOT CHOOSE THE SOLUTION. I don't know how things work on here, but I definitely did not choose the firefox add on answer.

Edit: I undid Fox_1923's answer selection and edited my question to contain the step by step solution as well as choosing the solution that worked for me.

Barian மூலமாக திருத்தப்பட்டது