Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

addons not updating

  • 21 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 59 views
  • Last reply by FredMcD

Hello all, My add-ons are not updating - neither automatically when I open FF nor when I go to the addons page and press "update now". When I go to the mozilla addons webpage and install a new version of addons this works sometimes and sometimes I get "This add-on could not be downloaded because of connection failure" I have "update addons automatically" checked. I have FF 28.0 (I don't like the new FF 29)

Please help, Thanks!

All Replies (20)

When I do "check for updates" on the addons page, I get "no updates found" even when there are newer versions available

LAST RESORT ! ! Reset Firefox {web link}

Please update to Firefox 30 (which came out today) and then try to update your add-ons.

I installed 29.0.1 - 30 isn't available for me yet (FF says "you have latest version").

Problem still exists (in 29)

Can you give me the name of one of your add-ons that isn't updating and tell me what version you have?

ghostery. I had to go to the ghostery page and install it manually

Please go to your profile folder (How do I find my profile?) and then rename the following files - extensions.sqlite, extensions.sqlite-journal, extensions.rdf and extensions.ini to extensionsOLD.sqlite, etc, etc.

Make sure firefox is closed, and then after renaming the file, reopen Firefox

I just updated to 30. I'll wait until some of my addons get new releases and see if the update procedure comes back. If not - I'll try your suggestion.

Thanks

OK - the problem persists. I went into the folder, but the only "extensions" files are: .sqlite .log .json .ini and extensionApi.js

there are no extensions.sqlite-journal or extensions.rdf

your advice?

that's fine, not all those files have to be there, just rename the ones you do have. Do you have a compatiblity.ini file as well? try renaming that as well.

Renamed all extension* files as well as the compatibility.ini file restarted FF problem still there

Alright, lets try something a bit more in depth.

Write down all your extensions, then Reset Firefox. Refresh Firefox - reset add-ons and settings

Then install your extensions back into Firefox.

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backup of files that you choose.

OPIE {web link} Import/Export extension preferences

I know and like FEBE. One thing though - if there's something screwed up with the profile, won't FEBE create a backup with the problem?

FEBE will backup everything that you have selected in the options.

HOWEVER, when the time comes, you get to choose what is restored.

You can check for problems with preferences.

Delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

1. I did a full FEBE profile backup 2. I reset FF 3. When I opened FF, it blocked all my connections (even google) due to "connection is untrusted" 4. I did a full FEBE profile restore

5. problem still there

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

the time is fine. in any case - i did a profile restore and this particular problem is resolved. the main problem persists

  1. 1
  2. 2