Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website is loading in Korean instead of English

  • 2 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 7 views
  • Last reply by zeroknight

The Firefox browser now displays the website "chaturbate.com in an Asian language, appears to be Korean, since updating the browser. It should display in English. How can I change this? Thank you.

The Firefox browser now displays the website "chaturbate.com in an Asian language, appears to be Korean, since updating the browser. It should display in English. How can I change this? Thank you.

All Replies (2)

Ed Shepherd said

How can I change this?

Scroll to the bottom where it says English and click on it.

Helpful?

Disable any VPN/proxy and make sure English is your preferred display language.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.