Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't play twitter and reddit videos/gif in Firefox

  • 3 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 27 views
  • Last reply by zeroknight

My OS is ubuntu20.046LTS, and the Firefox is 118.0.2. Just like the images i post, i can't play the videos at all, but i can play the youtube videos. The developer tools console in twitter video post shows 2 errors:

 The Content-Security-Policy: The page’s settings blocked the loading of a resource at data:i (“object-src”);
 The connection to https://api.twitter.com/live_pipeline/events?topic= was lost while loading the page.

I thought my problem may be related to these errors so i post them. Alough i can play the videos in chrome normally, but i used to the Firefox, please help me

My OS is ubuntu20.046LTS, and the Firefox is 118.0.2. Just like the images i post, i can't play the videos at all, but i can play the youtube videos. The developer tools console in twitter video post shows 2 errors: The Content-Security-Policy: The page’s settings blocked the loading of a resource at data:i (“object-src”); The connection to https://api.twitter.com/live_pipeline/events?topic= was lost while loading the page. I thought my problem may be related to these errors so i post them. Alough i can play the videos in chrome normally, but i used to the Firefox, please help me
Attached screenshots

All Replies (3)

Install ffmpeg:

sudo apt install ffmpeg


For flatpak (22.08 runtime):

flatpak install org.freedesktop.Platform.ffmpeg-full

Helpful?

zeroknight said

Install ffmpeg: sudo apt install ffmpeg For flatpak (22.08 runtime): flatpak install org.freedesktop.Platform.ffmpeg-full

Hello, my ffmped version is 6.0, and Flatpak is 1.6.5, after i enter command "flatpak install org.freedesktop.Platform.ffmpeg-ful", i choose the "runtime/org.freedesktop.Platform.ffmpeg-full/x86_64/22.08", but the problem is still existed. The errors reported by the console are still the same two.

qweyola மூலமாக திருத்தப்பட்டது

Helpful?

Does the snap package work? It comes with the necessary libavcodec library built-in.

sudo snap install firefox


You could also try this unofficial flatpak Nightly which also has it built-in:

https://gitlab.com/projects261/firefox-nightly-flatpak/

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.